procmailrc not working

Below is my $HOME/.procmailrc. All recipes work excep for "Subject: [SOGo]". All these messages end up in the inbox, none end up in the sogo folder. I can't figure out what's wrong.
# Send all mail with "[SPAM]" in the subject to spam folder, do not send to inbox.
:0:
* ^Subject: .*\[SPAM\]
/user/mfoley/mbox.spam

# Send all mail with "[SOGo]" in the subject to sogo folder AND send to inbox.
:0c:
* ^Subject:.*\[SOGo\]
/user/mfoley/2014/mail/sogo

# Send all mail with "Attempted Break-ins" in subject to breakin folder, do not send to inbox.
:0:
* ^Subject:.*Attempted Break-ins
mbox.sshBreakins

# Forward email to Android smart phone, except for:
:0Hc:
* ! From:.*jmarkfoley@hotmail
* ! From:.*mfoley@novatec
* ! From:.*sbsadmins@ohprs
* ! From:.*staples.com
* ! From:.*bestbuy.com
* ! From:.*smartdraw.com
* ! From:.*hprsportal@ohprs.org
* ! Subject:.*Attempted Break-ins
* ! Subject:.*backup.*OK
* ! Subject:.*completed OK
* ! Subject:.*Pension Checks
* ! Subject:.*New registration
* ! ^Subject:.*\[SPAM\]
* ! ^Subject:.*Need Part:
* ! ^Subject:.*\[SOGo\]
! droid

Open in new window

Here are some sample header from a SOGo message:
Date: Sun, 28 Dec 2014 18:48:13 -0500
From: Steve Ankeny <steve_a@cinergymetro.net>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.3.0
To: users@sogo.nu
Content-Type: text/plain; charset=utf-8; format=flowed
X-Validation-by: lmarcotte@inverse.ca
Subject: Re: [SOGo] Moving a SOGo installation to another server?
Reply-To: users@sogo.nu
X-Loop: users@sogo.nu

Open in new window

LVL 1
jmarkfoleyAsked:
Who is Participating?
 
arnoldConnect With a Mentor Commented:
Procmailrc can have logging, which you could activate and disable around this filter
LOG=/path/to/where/you/want/logfile
VERBOSE=on # to activate
:0c:
* ^Subject:  .*\[SOGo\]
/home/mfoley/2014/sogo

VERBOSE=off # to deactivate

Run mkdir -p 2014/mail to makesure the directories in the path exist.
If you want the email differentiated by year, that can be achieved if needed.
0
 
arnoldCommented:
It is working as you configured it.  You are using the c flag meaning copy which it does and stores one message in the sogo mbox and the other copy continues through the remaining filters, failing to match any additional filters, it is delivered to the inbox.
0
 
jmarkfoleyAuthor Commented:
Yes, that is what I *intended*, and it is ending up in the inbox, which is what I want, but it is *not* storing a message in the sogo mbox. That's the problem.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
Duncan RoeSoftware DeveloperCommented:
none end up in the sogo folder Are permissions OK? (writable by user ID of daemon)
0
 
Duncan RoeSoftware DeveloperCommented:
Is sogo an mbox (file) or directory?
0
 
Duncan RoeSoftware DeveloperCommented:
Anything in syslog?
0
 
jmarkfoleyAuthor Commented:
> Run mkdir -p 2014/mail to makesure the directories in the path exist.

Doh! What a moron! That was my problem!!! My actual path should have been ~/mail/2014, not ~/2014/mail. I just wasn't seeing that. I switched to the correct path and all is well.

Thanks for the suggestion to check the path.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.