Solved

iis 7.5 localhost works but url does not

Posted on 2014-12-30
12
356 Views
Last Modified: 2015-01-05
I have setup a web site on a Windows 7 Pro computer.  I have the binding set to the IP as well as a host name.  I am able to connect to the site via localhost or internal IP but cannot access via url/host name.  From the host computer if I enter https://localhost or https://192.168.1.5 I get the web page.  But if I enter https://cloud.domain.com I get Connection Timed Out or Page Cannot Be Displayed depending on browser.  I have 443 open in the Windows firewall.  I have the Vipre FW disabled.  I can ping the url from outside the network so DNS is resolving correctly.  

FYI, RDP protocol, which was configured the same way in Windows FW and on the router passes through fine.
0
Comment
Question by:jb1023
  • 7
  • 4
12 Comments
 
LVL 2

Expert Comment

by:Adam Resnick
Comment Utility
I am presuming that you are testing from a PC separate from your web host. Have you tried manually altering your hosts file on the testing PC to ensure that DNS resolution isn't involved? Is your domain internal or external? (In other words, is your domain literally a '.com' with a publicly hosted domain and domain server, or is this actually an intranet?)
0
 

Author Comment

by:jb1023
Comment Utility
Yes, I am testing from a separate pc.  From the testing pc I am able to access the web site using the hosting computers internal ip address.  From outside my network I am not able to access the site using the public IP address.  Yes, the domain is a .com with a public name server entry.
0
 
LVL 2

Expert Comment

by:Adam Resnick
Comment Utility
OK - we've established that you've got an internal IP and an external IP for this server. I'll presume the Vipre firewall is running in software on the host system but not connected to the public internet. What do you have doing your network firewall? Have you defined a NAT (Network Address Translation) entry to route the traffic from the external IP to the internal IP?
0
 

Author Comment

by:jb1023
Comment Utility
I have a Buffalo DD-WRT router doing NAT.  The NAT function seems to work for RDP.  The Vipre FW is completely disabled, only the AV function is enabled. I just disabled my Windows FW as a test, so no FW at all on the host pc.  Still no go using url or public IP.
0
 

Author Comment

by:jb1023
Comment Utility
Actually, let em retract that last statement about the router, RDP is not working outside the network either.  I am going to reset the router and see if that works.  I will post results back here asap.
0
 
LVL 2

Expert Comment

by:Adam Resnick
Comment Utility
Are you doing a full NAT from the external IP to the internal IP, or by individual port? For example, with a Watchguard, I'll create a NAT rule that pushes port 80 from an external IP x.x.x.x to an internal IP y.y.y.y, but traffic from 8080 from external IP x.x.x.x to internal IP y.y.y.z. Unless you map the specific port, or are using a full on one-to-one NAT where all traffic on the external IP is routed to the internal IP, that may be your problem.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 1

Expert Comment

by:goldied
Comment Utility
You need to post us up some screen shots of your router setup. The port forwarding page and the security page.

If you've disabled your firewall on the router then you've disabled controlling NAT completely which is why it won't work.
0
 

Author Comment

by:jb1023
Comment Utility
Adam, I am just using port forwarding for specific ports.

goldied, I have attached some screen shots of the two pages you requested.  As for the disabled FW, that is my Vipre FW, it is a software FW that comes with my AV software.  The Buffalo router FW is enabled and is what is performing NAT.  I also use the Win FW but for testing I have turned it off periodically.
NAT-cleaned.jpg
Security-cleaned.jpg
0
 
LVL 2

Assisted Solution

by:Adam Resnick
Adam Resnick earned 500 total points
Comment Utility
Did rebooting the router clear up the RDP access issue? Also, I noticed in your configuration that you are using the DMZ function for HTTPS, but not for HTTP. Have you looked at the traffic log on the router while testing? That would be the best way to determine if the traffic is ever reaching your IIS host over port 443 or 80.
0
 

Author Comment

by:jb1023
Comment Utility
I not only rebooted the router but updated the firmware I reset it to factory default and started over.  No change and nothing entered in the logs.  I accessed the Comcast modem and completely disabled the internal FW on that device.  No change and nothing entered in the logs.  I disabled the Win FW.  No change and nothing entered in the logs.  I don't know if I had the DMZ setup previously or not but it is definitely not setup now.
0
 

Accepted Solution

by:
jb1023 earned 0 total points
Comment Utility
Got it.  I had to setup port forwarding on my comcast modem as well as on my router.  Even in bridge mode with the comcast FW disabled it was blocking incoming traffic.
0
 

Author Closing Comment

by:jb1023
Comment Utility
It is a Comcast thing as far as I can tell.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now