Solved

cisco router to router dialup modem connection

Posted on 2014-12-30
13
299 Views
Last Modified: 2015-01-20
I want to create a connection between two cisco 2821 routers using a phone line and route traffic through that connection.  I know it's old tech but I haven't found much on the topic.
0
Comment
Question by:SolusMIB
  • 6
  • 5
  • 2
13 Comments
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
If the routers do not have a telephone jack with an internal modem, I do not see how you could do this.

There was an SMC Barricade box that was a Router with a modem and telephone jack. I had one and used where the only service was phone and the client needed multiple (two) computers connected at the same time.

But I do not know if that device is an longer available. It was very low tech a decade ago.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Here is something that might work for you.

http://www.perle.com/lp/ethernet-modem.shtml?gclid=CjwKEAiAt4mlBRDXwt_m9ICU4DcSJAAS_X0WEMC2ltBNRrl7rFi8dGrRckGCNWQNNT2kdH7MQ_emnxoCxyDw_wcB

Also, are you in an area with cellular capability?  If so, ISP's provide Internet Hotspots with Ethernet output internally. Two sites with these could connect via Internet which would make more sense for you if you have cellular capability.
0
 
LVL 12

Expert Comment

by:profgeek
Comment Utility
If you really need to do it that way, find a couple of refurbished Cisco 2511 routers and use external modems with them (they were designed for dial-up access using external modems).  I only used them for incoming (not outgoing) modem access, but you should be able to figure out a way to have them dial out.  Again, this is old technology as I used these back around 1995 when I had an ISP business before the days of broadband.  I think the routers are still around in the $200 price range.  If you get some, make sure you get the modem cables with them.
0
 

Author Comment

by:SolusMIB
Comment Utility
Thank for your responses and I should have been more clear on my request.  I have two cisco 2821 routers and each have a wic-1am-v2 modem card installed.  I"ve also been able to setup external modems and have them dial and telnet with each other.  What I'm having trouble with is a solid connection between the two that I can route traffic through.  I've read several articles about backing up a serial connection with modems but it usually turns into ISDN.  What I have running on these two routers is GRE vpn tunnel to connect the two via cable internet modems.  Works well until one of the connections goes down (yea, should be a lease line, I know).  That's were I'd like to have a dial up modem to dial up modem connection between the two.  I haven't seen much in config options for doing that and was hoping someone here might have done this in the past.  I know it's old tech, and I do have a failover via cellular internet access and cradlepoint that works rather well, however, we have to have a connection option at any level or business stops.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Are the modems POTS or ISND?   For POTS, I typically did an ATZ to reset the modem before dialing with ATDT. There were modem parameters for flow control, bits, parity and duplex but I no longer have a record of those.

I do have a failover via cellular internet access and cradlepoint that works rather well  <-- It is 2015 tomorrow. Is this not your answer?
0
 

Author Comment

by:SolusMIB
Comment Utility
Pots line and I understand the at commands.  What I'm looking for is a setup for routing traffic through the connection.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
If the connection is made, and if you set up a TCP/IP connection (SLIP) then there should not be much routing to do.
0
 

Author Comment

by:SolusMIB
Comment Utility
I'm thinking there's more to it then that.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
That is all there was to it in the days of dial up Internet. Modem, Trumpet Winsock, and SL/IP interface.

I think what you have forgotten is that connections today are TCP/IP and a straight modem to modem connection is NOT TCP/IP. Add to that (from above) the typical failure point above was the modem.
0
 
LVL 12

Expert Comment

by:profgeek
Comment Utility
One of the problems with dialup connections is that they generally disconnect when there is no traffic for a period of time.  So if you are trying to keep an open line, much like you do with a broadband or T1/T3 connection, it won't happen very easily.  When there is a disconnect, you'll have to initiate a reconnect the next time you want to send data.  That may happen in either direction, in this case, whereas with the old dialup days, all connections were initiated by dialup users.  The routers never dialed them.  The other problem is hung modems.  Modems have a tendency to hang if not disconnected properly.  I remember when I was running a small ISP business back in those days, I constantly had to physically reset modems that had become hung, and wouldn't answer incoming calls.  That's why many businesses went to ISDN lines before broadband connections becamse available.
0
 

Author Comment

by:SolusMIB
Comment Utility
I'm actually speaking with Cisco tech support and there is way more to this then I had imagined.  Please close and/or delete this thread.
0
 

Accepted Solution

by:
SolusMIB earned 0 total points
Comment Utility
Ok, I'm not sure if I should share this here.  The Cisco tech wasn't much help.   I decided to put some cli together myself and this is what I came up with.   NOTE: This is an internal analog card in both 2821 routers (1 calls / 1 answers).

version 15.1
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname TESTING
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
!
!
aaa session-id common
!
memory-size iomem 10
clock timezone EST -5 0
clock summer-time EST recurring
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c
modemcap entry MY_USR_MODEM:MSC=&F1S0=1
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
vtp domain #######
vtp mode transparent
username ####### privilege 15 password 7 #######
username admin password 7 #######
username ##name of other router## password 7 #######
!
redundancy
!
!
interface Loopback0
 ip address 10.10.140.1 255.255.255.0
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.10.60.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Async0/3/0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer pool-member 20
 dialer-group 1
 no keepalive
 ppp authentication chap callin
 routing dynamic
!
interface Dialer10
 ip unnumbered Loopback0
 encapsulation ppp
 ip ospf demand-circuit
 dialer pool 20
 dialer idle-timeout 900
 dialer string ##other modem phone number##
 dialer-group 1
 ppp authentication chap callin
!
!
router eigrp 1
 network 10.0.0.0
 redistribute
!
router ospf 5
 network 10.10.60.0 0.0.0.255 area 0
 network 10.10.140.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map nonat interface GigabitEthernet0/0 overload
!
ip route 10.10.0.0 255.255.0.0 10.10.140.2
!
ip access-list extended nonat
 permit ip 10.10.10.0 0.0.0.255 any
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
!
route-map nonat permit 10
 match ip address nonat
!
!
control-plane
!
!
mgcp profile default
!
!
alias exec c config t
alias exec half show run | begin no ip http
alias exec ass show run int Async0/3/0
alias exec 0 show run int g0/0
alias exec 1 show run int g0/1
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
line 0/3/0
 script dialer dialout
 modem InOut
 transport input all
 autoselect ppp
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 transport input all
!
scheduler allocate 20000 1000
end


The receiving end is about the same but  I left the dialer/loopback code out.  I was able to ping inside my main network (with some well placed IP route statements).  I used the dialer to turn this on and off (shut / no shut).

I'll use some TTL code to make this a backup connection so my facilities will always have a connection option the next time they cut the fiber..>LOL<

Please, any suggestions or corrections, I would greatly appreciate it.
0
 

Author Closing Comment

by:SolusMIB
Comment Utility
It took a lot of sources to get the final working code.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now