Citrix Receiver is not showing OPEN button

In windows 7 I have opened internet explorer and pointed it to Xenapp web interface and downloaded and installed Citrix receiver. However when I click on it I see just preferences I do not see the Open button.
I have not published any App yet.

Any idea why Open button is not there ?

Who is Participating?
Dirk KotteConnect With a Mentor SECommented:
possible you have installed the "old" Receiver without plugins.
with old Versions i have seen this some times. Plugin-install fails and you get an empty hull.

another possible reason:
if you installed "Receiver for web" the app is started from the Webbrowser and there are no other dialogues or open buttons.

Should you see the apps within the receiver?

would suggest to uninstall the Client (possible with ReceiverCleanupUtility) and install the most current Receiver from Citrix Webpage.
Radhakrishnan RConnect With a Mentor Senior Technical LeadCommented:

Have you installed the Citrix receiver on an Iphone or Android and checked? as the citrix receiver mainly used on those devices. I don't think there will be an open button in Citrix receiver. Once you installed, it will ask you to enter your user name (domain) and password then you will re-direct to the desktop or published applications.

If this is not the case then I would suggest to uninstall the current citrix receiver and download the file from this location and see it works as expected?

Dirk KotteSECommented:
do you download and install the receiver from citrix directly or from webinterface-page?
which version do you install?
jskfanAuthor Commented:

installed from web interface
jskfanAuthor Commented:
I try to reinstall it later...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.