Solved

Sbs 2011 IIS Configuration Issues - Companyweb and remote.domain.com

Posted on 2015-01-02
20
392 Views
Last Modified: 2015-01-04
I am having an issue with my IIS configuration on SBS 2011

When I go to remote.domain.com, it defaults to the www.domain.com site instead of the Remote Web access.
Going to http://comanyweb/ gives HTTP Error 500.0 - Internal Server Error - Module "SharePoint14Module" could not be found

iis---web.pngiis---application.png
0
Comment
Question by:Sterling Schaefer
  • 10
  • 9
20 Comments
 

Author Comment

by:Sterling Schaefer
ID: 40527967
Going to the IIS site Default Web Site / Remote, and selecting Basic Setting/Test gives Invalid application path.

The current path is C:\Program Files\Windows Small Business Server\Bin\WebApp\RemoteAccess

The Application pool is SBS Web Applications application pool
0
 
LVL 22

Expert Comment

by:Rick Hobbs
ID: 40528739
What is your internal domain?  It is best if it is www.externaldomain.local  and your external name should be www.externaldomain.com (or org, edu, net, gov, tw, or similar).  You should then have a DNS entry of internalIPaddress for ,local defined on your internal DNS server(s).  The externalIPaddress should resolve correctly to your external IP address though your external DNS primary and secondary servers.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40528751
Did this just recently go bad?
What happens if you go to https://remote.domain.com/remote   does that work?
0
 

Author Comment

by:Sterling Schaefer
ID: 40529145
The local domain is domain.local, and the external is domain.com.  DNS is set up correctly inside the network and outside as well.

Going to https://remote.domain.com/remote gives 401 - Unauthorized: Access is denied due to invalid credentials.

The general authentication for IIS is Anonymous Auth is enabled, all others are disabled; this is the same for Default Web Site, and the application site of /Remote
0
 

Author Comment

by:Sterling Schaefer
ID: 40529147
The sites used to work with no issues; started to have issues a few months ago.  I believe that it started after a MS Update, but can not say for sure.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529165
I have two suggestions here....
First download and install the SBS BPA for 2011 http://www.sbslinks.com/sbsbpa.htm   make sure it gets updated to 1.5 before you'll get any valuable results
While you're working on that, run the Fix My Network wizard from the SBS Console > Network > Connectivity tab
Fix everything it finds, regardless of whether you think it applies

You can also try re-running the "setup my internet address" wizard from the Getting Started list on the main page of the SBS console.   Any chance this occurred when you installed Sophos on the server?
0
 

Author Comment

by:Sterling Schaefer
ID: 40529178
I have run the SBS BPA as suggested in other posts, and tried to run Fix My Network Wizard to no avail.  This was happening prior to Sophos.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529180
and have you tried re-running the "setup your internet" address wizard again?
0
 

Author Comment

by:Sterling Schaefer
ID: 40529281
Yes
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529338
I've reviewed your two pictures that originally posted  (.net version and bindings) and they match my own box, except for ID# of course and I don't have Sophos

And I get the same error as you did when I click on test button but mine is working.

Let me go back to your original posting.   When you're trying to connect to remote.domain.com and it goes to www.domain.com.   is this from inside the network or outside?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Author Comment

by:Sterling Schaefer
ID: 40529381
Behavior is the same both inside the network, and outside the network.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529409
it would help to have the actual domain name (external) in order to look at a couple of things.
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529441
While not the exact cause of the issue, it appears there might be a misconfiguration of your external DNS.
doing a DNS query for all records for the domain name you provided does not return a record for remote, which should be "A" or host record of your domain.   I then went and did a DNS check of remote.domainname.com and found the record and it's public IP points to the same IP address as your mail.domainname.com record.

On that "remote" folder, Make sure that the domain "users" security group has read&execute set to allow, List Folders set to allow and Read set to allow.

Make sure SYSTEM has full control

I'm not an IIS guru by any stretch.  If the permissions are correct, you may have to open a support case with Microsoft, or a third party group that has an IIS person.

Does Outlook Web Access work?
0
 

Author Comment

by:Sterling Schaefer
ID: 40529465
OWA does work going to https://remote.domain.com/owa/

Permissions on /remote are already set as you suggested.
0
 
LVL 35

Assisted Solution

by:Cris Hanna
Cris Hanna earned 500 total points
ID: 40529484
In IIS > Sites > Default Web Site > Remote
.NET Authorization Rules > Open Feature

Should show
Deny                  Anonymous Users                             Local
Allow                  All Users                                              Local
Allow                 All Users                                              Inherited
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40529490
In IIS > Sites > Default Web Site > Remote
IIS section > Authentication > Open Feature
Do you see listed
Anonymous Authentication                      Enabled
ASP .NET Impersonation                           Disabled
Basic Authentication                                  Disabled                HTTP 401 Challenge
Digest Authentication                                Disabled                HTTP  401 Challenge
Forms Authentication                                Enabled                 HTTP  302  Login/Redirect
Windows Authentication                           Disabled                HTTP  401 Challenge
0
 

Author Comment

by:Sterling Schaefer
ID: 40530309
Setting Forms Auth to enabled under Authentication fixed the authentication error and not the page works with https://remote.domain.com/remote/

This used to work without the /remote/, although there may be an issue with the redirect on the main page.

The http://companyweb/ still gives HTTP Error 500.0 - Internal Server Error
Module "SharePoint14Module" could not be found
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40530316
As I indicated, not an IIS guru, so I'm not sure I can get you back to a point of not having to put in the full URL
Regarding CompanyWeb...give this a try:

You Must Manually Run PSCONFIG after Installing SharePoint 2010 Patches
http://blogs.technet.com/b/sbs/archive/2011/05/24/you-must-manually-run-psconfig-after-installing-sharepoint-2010-patches.aspx
0
 

Author Comment

by:Sterling Schaefer
ID: 40530329
After running "PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures" I still recieve the same error on companyweb.
0
 
LVL 35

Accepted Solution

by:
Cris Hanna earned 500 total points
ID: 40530350
My best suggestion on CompanyWeb would be to follow the Repair SharePoint 2010 documentation in the SBS 2011 Technet Library.  http://technet.microsoft.com/en-us/library/gg680310.aspx

Was the client using CompanyWeb or this is just an issue because it errors when they open IE because CompanyWeb is set as the Home Page?
0

Featured Post

New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Small Business Network Solution 9 91
Microsoft  Partnership 1 68
Funa@india.com 6 424
How to correct account that was created in SBS without using the SBS console. 2 70
A lot of problems and solutions are available on the net for the error message "Source server does not meet minimum requirements for migration" while performing a migration from Small Business Server 2003 to SBS 2008. This error pops up just before …
This guide is intended for migrating Windows 2003 Standard with Exchange 2003 to Windows Small Business Server 2008. You will need the following: Exchange Best Practice Analyzer: http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-…
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now