Solved

Sharepoint 2013 quick edit

Posted on 2015-01-02
20
164 Views
Last Modified: 2015-01-12
I created a bunch of lists on on sharepoint page about a year ago and I went to go update one of the links but the "quick edit" option isnt working to open up the grid view to edit the list.  I've checked settings and it is still enabled.
How else can I edit a list?
0
Comment
Question by:fleets9876
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 9
20 Comments
 
LVL 10

Expert Comment

by:Mohit Nair
ID: 40531070
Please help us with a screenshot to understand which quick edit is not working. Do you get an exception error ?
0
 

Author Comment

by:fleets9876
ID: 40531449
Attached is screenshot of button.  When I click it, nothing happens.
It used to change the view to a spreadsheet/grid  view to edit.
I've also tried creating a new view. which did not work.  Same with different version browsers.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40533921
what version of IE are you using ?
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:fleets9876
ID: 40533926
Ive tried on all versions starting at 8 through 11.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40533955
do you get any error when you switch to datasheet view ?
do you see any javascript error on the page when you switch to datasheetview?
0
 

Author Comment

by:fleets9876
ID: 40533960
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40533977
from what i can see is the active x on the browser isnt working good . can you try this ?

1.       Close Internet Explorer
2.       Start -> Run… -> “regedit” (without quotation marks)
3.       In the Registry Editor, delete the following Folder (sub-key)…
Path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility
Sub-Key: {65BCBEE4-7728-41A0-97BE-14E1CAE36AAE}
4.       Start Internet Explorer and open SharePoint content in the Datasheet View
0
 

Author Comment

by:fleets9876
ID: 40533999
I have a 652623DC.... and a 65FB3073... but no 65BCBEE4.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40534015
What version of office you have installed on your pc ? 64bit isnt supported fyi
0
 

Author Comment

by:fleets9876
ID: 40534027
2010 and yes I believe it is 64 bit but I also tried it on an old server using IE8 and Office 2007 32 bit and get same response.
It seems like it is a permission thing even though I am a Sharepoint Admin with full control.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40534045
if its a permission issue you would not find the control "edit in datasheet" to be enabled. lets rule tat out.
if you had office 32 and then upgraded to 64 and then brought back to 32 active x still finds it as 64 and not 32 , so you have to roll out the office completely, delete the left over files manually from the system and do a clean install of 32 bit and try it
0
 

Author Comment

by:fleets9876
ID: 40534083
I tried it on a server with no office installed and still get same response.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40534115
datasheet view requires office installed , which will install the active x controls for office (excel) kinda edit.
0
 

Author Comment

by:fleets9876
ID: 40534127
Ok I tried it on a 2003 server with office 2007 32 bit with still no luck.
Is there an active x control I can download and reinstall?
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40534144
0
 

Author Comment

by:fleets9876
ID: 40534161
Didn't help. Maybe some code got corrupted on the actual page. I'll have to try creating a new site with a list and see if it works.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40534177
yeah, try creating a new site and see if tat works, one another thing datasheet view wont work on doc libs,pics libs, any libraries .
0
 

Assisted Solution

by:fleets9876
fleets9876 earned 0 total points
ID: 40534328
I found out how to edit it another way - you add /AllItems.aspx to the end of the address and it shows it in grid view.
0
 
LVL 8

Accepted Solution

by:
Jayaraja Jayaraman earned 500 total points
ID: 40534369
glad you figured out an altenate
0
 

Author Closing Comment

by:fleets9876
ID: 40543992
Figured out an alternative
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note:  There are two main ways to deploy InfoPath forms:  Server-side and directly through the SharePoint site.  Deploying a server-side InfoPath form means the form is approved by the Administrator, thus allowing greater functionality in the form. …
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question