slideshow images are distorted

See the slideshow on this page?

http://leafyhead.com/pages/Home.cfm

Notice the images in the slideshow are quite distorted -- increased in size so that they overfill the allotted parameters of the slideshow.

Why is that happening? I've been staring at this for hours. Thank you for any advice.

Eric
LVL 3
Eric BourlandAsked:
Who is Participating?
 
Deniz DursunCommented:
You are welcome. I hope this code can solve your problem.

You can put that code after than <body> tag or before than </body> tag.

Kind Regards
0
 
Deniz DursunCommented:
Hello;

I think adaptiveHeight parameter of slideshow can solve your problem. If you can edit kickstart.js, you can change adaptiveHeight parameter false to true.

If you can't edit kickstart.js, please try to put this code any row after than body tag (Home.cfm) for reload slider with new settings:

<script type="text/javascript">
$(document).ready(function(){
	var slider=$('.slideshow').bxSlider();
	e.preventDefault();
	slider.reloadSlider({
		mode: 'horizontal',
		video: true,
		useCSS: true,
		pager: true,
		speed: 500,
		startSlide: 0,
		infiniteLoop: true,
		captions: true,
		adaptiveHeight: true,
		touchEnabled: true,
		pause: 4000,
		autoControls: false,
		controls: false,
		autoStart: true,
		auto: true
	});
});
</script>

Open in new window

0
 
Eric BourlandAuthor Commented:
Deniz,

Thank you for your kind and helpful reply.

I will try the script that you suggest.

However, I am not sure where to place this script. I have tried the script inside the <HEAD></HEAD> tag, and after the </BODY> tag. Neither place seemed to have any effect.

What do you suggest?

Thank you for your help. =)

Eric
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Eric BourlandAuthor Commented:
Got it!

Hmm ... I tried after the <BODY> tag: http://leafyhead.com/pages/Home.cfm

Looks like the images are still distorted.

Any idea what I could be missing? =)

Thank you again, Deniz.

best from Eric
0
 
Deniz DursunCommented:
I downloaded your codes and i tried. My code working but first slideshow still running with parameters from kickstart.js.
Kickstart.js catching slideshow class. So, if you change your slideshow class to slideshow2, it will work.

This is your solution:
1.)  Change your slideshow class to slideshow2 (<ul class="slideshow2">)

2.) Put this code after <body> tag:
<script type="text/javascript">
$(document).ready(function(){
	var slider=$('.slideshow2').bxSlider({
		mode: 'horizontal',
		video: true,
		useCSS: true,
		pager: true,
		speed: 500,
		startSlide: 0,
		infiniteLoop: true,
		captions: true,
		adaptiveHeight: true,
		touchEnabled: true,
		pause: 4000,
		autoControls: false,
		controls: false,
		autoStart: true,
		auto: true
	});
});
</script>

Open in new window

0
 
aboo_sCommented:
By distorted do you mean they are stretched by width and height?
if that is the case ,then you should just delete the width and height option you added to your images code:
<li><img src="https://lh5.go...d1.jpg" alt="" width="550" height="350" /></li>

Open in new window

should become:
<li><img src="https://lh5.go...d1.jpg" alt="" /></li>

Open in new window

0
 
Eric BourlandAuthor Commented:
Dear aboo_s,

Thanks for your note.

>>>>then you should just delete the width and height option you added to your images code:
Indeed, I tried that already.

These are the correct dimensions for the images: width="550" height="350"

The images are very big ... or, at least, they are magnified.

I think something is going on with the javascript and / or the CSS. The BX Slider has gone a little crazy.

Thank you for the idea, though.

Eric
0
 
Eric BourlandAuthor Commented:
Friends, I really appreciate your helpful notes. I have simplified code as much as I can; the weird behavior in the slideshow persists. I am going to use another slideshow script -- maybe I can find an all-CSS slideshow.

Thank you again for your thoughtful replies.

best from Eric
0
 
Eric BourlandAuthor Commented:
Thank you again, friends, for your help.

Eric
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.