Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Wordpress Comments

Posted on 2015-01-04
2
Medium Priority
?
77 Views
Last Modified: 2015-01-28
We have a website that is using the Envato Wordpress theme.  We have never used the site for blog posts before this week.  We have created a page, http://www.fbcptc.org/devotion-spot, that now will list weekly posts.  The posts are shown 1 per page and we are asking people to comment on each post.  However, as we added the 2nd post this week, we noticed that the comments from the first week were still listed.  It seems that the comments are being created at a page level instead of the post level.  Our web designer is not sure how to fix this beyond copying and pasting the previous week's comments.  However, this is not a satisfactory solution as it prevents replies to previous comments and if someone posts a comment on a previous week, it will show on the current week.  Is there a solution to this?
0
Comment
Question by:Hamilj03
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40530947
We have created a page, http://www.fbcptc.org/devotion-spot, that now will list weekly posts.  However, as we added the 2nd post this week, we noticed that the comments from the first week were still listed.

Not sure what you did to list the posts, but it certainly sounds like a problem with the Loop and the post ID is not passing correctly so the first post's comments show on other pages.  

We would need to see the page template code to assist further.
0
 
LVL 3

Accepted Solution

by:
Morgan Finley earned 2000 total points
ID: 40541551
I second what Jason suggested.

Alternatively, it might be as simple as going into the "Reading" settings and selecting the page to display posts in the drop-down. I'm assuming you might have set a static homepage in the settings here, unless your theme has a home.php or similar file to create the homepage.

If your theme does have a custom home.php, you can still select a page to display blog posts under the reading settings without selecting a homepage.
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Now that you've installed WordPress 2.9 (http://www.experts-exchange.com/articles/Web_Development/Blogs/WordPress/WordPress-2-9-What-to-Expect-When-Upgrading-to-WordPress-2-9.html?) on your site, you need to install some plugins to get the most out …
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
The purpose of this video is to demonstrate how to reset a WordPress password if you are locked out and cannot reset the password. A typical use would be if you cannot access the email to which WordPress would send the password recovery email to…
The purpose of this video is to demonstrate how to Test the speed of a WordPress Website. Site Speed is an important metric of a site’s health. Slow site speed can result in viewers leaving your site quickly and not seeing your content. This…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question