Solved

Prevent Outlook from connecting if RPC encryption is not enabled.

Posted on 2015-01-05
12
121 Views
Last Modified: 2015-01-17
I would like to prevent Outlook 2010 and 2013 clients from connecting if RPC encryption is disabled/unchecked. I'm using a Exchange 2010 server and I've configured a setting that should accomplish this (unless I'm missing something).
Set‐MailboxServer <ServerName> ‐MapiEncryptionRequired:$true
I've also check the following command and "EncryptionRequired" is set to true.
Get‐RpcClientAccess | fl Server,EncryptionRequired
However, when I run Outlook with the RPC encryption feature unchecked, I'm still able to connect to the exchange server, and send messages. One thing I noticed is the address book is no longer works, so I think I'm on the right track. Is there anything I'm missing? Thank you for your time.
0
Comment
Question by:Domenic DiPasquale
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 53

Assisted Solution

by:Will Szymkowski
Will Szymkowski earned 167 total points
ID: 40531528
From what you have illustrated above it appears correct. Does this happen with all clients?

Take a look at the technet below to ensure that you have done all of the steps accordingly, and haven't missed anything.
Technet for Encrypted Connections

Will.
0
 
LVL 43

Expert Comment

by:Amit
ID: 40531545
How many CAS servers  you have in  your environment. As you need to run this on all CAS servers.
0
 

Author Comment

by:Domenic DiPasquale
ID: 40531756
Amit: I've have on exchange 2010 server that's in production. I also have a exchange 2013 server install, but I haven't migrated any mailboxes to the new server. But I did apply the configuration to both servers.

Will: This Technet link is what I used to configure and verify RPC encryption.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 43

Expert Comment

by:Amit
ID: 40531789
So here is a twist. I am sure you know, how clients now connect to Exchange 2013. Everything is now http. How you installed Exchange 2013, multi-role or you separated the roles?

Also, you need to tell your Exchange design, how many servers in total, how many sites they are spread out.
0
 

Author Comment

by:Domenic DiPasquale
ID: 40531810
When I installed Exchange 2013, I installed both CAS and mailbox, since we will be decommissioning exchange 2010 server at some point. I only have 1 active exchange 2010 server. The exchange 2013 server is not being used at this time until we're ready to move mailboxes. Both servers are on the same network.
0
 
LVL 43

Expert Comment

by:Amit
ID: 40531911
Go and shut down your Exchange 2013 and then test again. Let me know the result.
0
 

Author Comment

by:Domenic DiPasquale
ID: 40531973
I've shutdown the Exchange 2013 server, and test Outlook 2010 and 2013 without using RPC encryption. Unfortunately, I'm still able to connect to the server and send messages.
0
 
LVL 43

Assisted Solution

by:Amit
Amit earned 333 total points
ID: 40532009
Ok Restart RPC Client Access services on your Exchange 2010 server and test again. Suggest you to check this as well
http://www.msexchange.org/articles-tutorials/exchange-server-2007/planning-architecture/uncovering-new-rpc-client-access-service-exchange-2010-part2.html
0
 

Author Comment

by:Domenic DiPasquale
ID: 40533326
I've restarted the RPC Client Access service. But I'm still able to connect to the exchange server, and send messages. I'm reviewing the MSExchange,org article now.
0
 
LVL 43

Expert Comment

by:Amit
ID: 40533821
Ok, check the article.
0
 

Author Comment

by:Domenic DiPasquale
ID: 40549353
I haven't been able to prevent outlook clients from connecting to the exchange server. For now, I've downloaded the office 2010 and 2013 admin templates and created a group policy that enforces RPC encryption (or prevents the user from disabling the setting).
0
 
LVL 43

Accepted Solution

by:
Amit earned 333 total points
ID: 40549477
That was the last option, you can try. Push it via GPO, so it will force user to use RPC Encryption.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question