Solved

3COM NBX and Cisco 4507

Posted on 2015-01-05
9
210 Views
Last Modified: 2015-01-25
I want to replace our 3Com superstack switches with a Cisco 4507. We have a 3COM NBX v3000 VoIP system with the 3Com 3102 business phones. The 3Com was configured to use vlan 1 for data and vlan 250 for phones. In the Cisco switch I used vlan 10 for data and vlan 50 for the phones. I setup DHCP for the phones on the cisco swtich, configured option 184 per the 3Com admin guide, enabled the dhcp service. When I plug the phones in the sit at the "Wait for NCP" status message.

I've implemented the Cisco switch for our data and have all the phones and the NBX plugged into 1 of the 3COM switches so the phones will still work.

Any help would be greatly appreciated!

Attached is the config of my Cisco 4507.
4507-Core.txt
0
Comment
Question by:Jason Batchos
  • 6
  • 3
9 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 40533507
Hi,

please show provide us the sanitized config of cisco!

Best regards,
Istvan
0
 

Author Comment

by:Jason Batchos
ID: 40533989
I attached it as a file. File name is 4507-Core.txt is the sanitized config file from the Cisco switch. Here it is again pasted below just for good measure.


Current configuration : 16109 bytes
!
version 12.2
no service pad
service tcp-keepalives-in
service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
service password-encryption
service compress-config
!
hostname 4507R CORE
!
boot-start-marker
boot system flash slot0:cat4500-entservicesk9-mz.122-54.SG1.bin
boot system flash bootflash:cat4500-entservicesk9-mz.122-54.SG1.bin
boot system flash slavebootflash:cat4500-entservicesk9-mz.122-54.SG1.bin
boot-end-marker
!
logging buffered 32768
logging console critical
no logging monitor
enable secret 5 <REMOVED>
!
username <REMOVED> privilege 15 secret 5 <REMOVED>
username <REMOVED> privilege 15 secret 5 <REMOVED>
!
!
aaa new-model
!
!
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
qos
ip subnet-zero
no ip source-route
ip domain-name <REMOVED>
ip name-server 10.1.X.X
no ip bootp server
ip vrf mgmtVrf
!
ip multicast-routing
ip dhcp excluded-address 10.250.X.1 <VLAN INTERFACE IP>
ip dhcp excluded-address 10.250.X.190 <3COM NBX IP>
!
ip dhcp pool PHONES
   network 10.250.X.0 255.255.255.0
   dns-server 10.1.X.X
   default-router 10.250.X.1
   option 184 ip 10.250.X.190
   lease 7
!
!
cluster run
!
!
!
power redundancy-mode redundant
!
!
!
!
spanning-tree mode pvst
spanning-tree loopguard default
spanning-tree extend system-id
spanning-tree vlan 1,10,20,50,99 priority 24576
!
redundancy
 mode sso
 main-cpu
  auto-sync config-register
  auto-sync standard
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh version 2
buffers small permanent 75
buffers middle permanent 75
buffers big permanent 75
buffers huge permanent 2
!
!
interface FastEthernet1
 ip vrf forwarding mgmtVrf
 no ip address
 speed auto
 duplex auto
!
interface GigabitEthernet1/1
 description TRUNK to 3750 # 2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet1/2
 shutdown
!
interface GigabitEthernet2/1
 shutdown
!
interface GigabitEthernet2/2
 shutdown
!
interface GigabitEthernet4/1
 description STANDARD USER PORT CONFIGURATION
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 50
 spanning-tree portfast
!
interface GigabitEthernet4/15
 description PHONE SYSTEM NBX
 switchport access vlan 50
 spanning-tree portfast
!
interface GigabitEthernet4/16
 description TO ROUTER (Internal network gateway)
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet4/25
 description WAP 1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet4/47
 description PHONE SYSTEM Expansion Chassis
 switchport access vlan 50
 spanning-tree portfast
!
interface GigabitEthernet4/48
 description TRUNK To 3750 #3
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet5/25
 description WAP 2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet5/33
 description WAP 3
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet5/47
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet5/48
 description SERVER
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface Vlan1
 description NIU
 no ip address
 shutdown
!
interface Vlan5
 description Internal network to Router
 ip address 10.10.X.1 255.255.255.252
 no ip redirects
!
interface Vlan10
 description Office VLAN
 ip address 10.1.X.2 255.255.255.0
 ip helper-address 10.1.X.X
 no ip redirects
!
interface Vlan20
 description GUEST VLAN - DO NOT assign IP address for this VLAN subnet Connects to 2nd Interface on Router
 no ip address
 ip helper-address 10.X.X.1
 no ip redirects
!
interface Vlan50
 description Phone VLAN
 ip address 10.250.X.1 255.255.255.0
 no ip redirects
!
interface Vlan99
 description Management VLAN
 ip address 10.10.X.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.X.2 permanent   <INTERNAL NETWORK GATEWAY ACCESS THROUGH ROUTER INTERFACE CONNECTED TO VLAN 5>
no ip http server
no ip http secure-server
!
!
!
logging history informational
!
!
snmp-server community <REMOVED> RO
!
control-plane
!
line con 0
 password 7 <REMOVED>
 stopbits 1
line vty 0 4
 transport preferred ssh
 transport input ssh
line vty 5 15
 no exec
 transport preferred ssh
 transport input ssh
!
ntp clock-period 17179602
ntp update-calendar
end
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 40535438
Hi,

you need:

interface GigabitEthernet4/1
 description STANDARD USER PORT CONFIGURATION
switchport trunk encapsulation dot1q
 switchport mode trunk
switchport tunk native vlan 10
switchport trunk allowed vlan 10,50
 switchport voice vlan 50
 spanning-tree portfast
0
 

Author Comment

by:Jason Batchos
ID: 40536132
Istvan,

So every user port needs to be a trunk port and not an access port?
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 40537415
Yep, because only cisco phones recognizes from CDP protocolls the voice vlan
0
 

Author Comment

by:Jason Batchos
ID: 40538268
sweet. I'll go in tonight and try it out.
0
 

Author Comment

by:Jason Batchos
ID: 40543003
It didn't work.
0
 

Accepted Solution

by:
Jason Batchos earned 0 total points
ID: 40559454
I found the issue. It was on the 3COM end. in the system configuration area where you can change the IP address there is a checkbox for VLAN ID and then a box. When I moved replaced the original switches with Cisco's I changed the VLAN. Once I changed the VLAN to reflect the new VLAN, everything worked the way I originally had things configured.
Istvan, thanks for all your help!
0
 

Author Closing Comment

by:Jason Batchos
ID: 40568997
The issue was not with the configuration of the Cisco switches but rather on the 3COM NBX configuration.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Ever wanted to query Cisco Call Manager CDR records from MS SQL Server? Here's how! CUCM can be configured to upload a CDR file to a given FTP server every minute. This article will show you how to set this up, schedule the import of this data an…
I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now