Xen Project install on Fedora 21

Hi

I am trying to get Xen server up and running on Fedora 21. That is from Xen project and not the Citrix version. Not sure why they are called the same thing but hey.

Trying to install it - I keep coming across this error. I have tried to install the dependancies manually but this didn't work and ended up duplicating the modules so I can to uninstall them again.

Full output below

[root@xenserver1 rinse.git]# yum -y install xen xen-hypervisor xen-libs xen-runtime
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * fedora: mirror.bytemark.co.uk
 * kernel-xen: au1.mirror.crc.id.au
 * updates: mirror.bytemark.co.uk
Package xen is obsoleted by xen44, trying to install xen44-4.4.1-8.el6.x86_64 instead
Package xen-hypervisor is obsoleted by xen44-hypervisor, trying to install xen44-hypervisor-4.4.1-8.el6.x86_64 instead
Package xen-libs is obsoleted by xen44-libs, trying to install xen44-libs-4.4.1-8.el6.x86_64 instead
Package xen-runtime is obsoleted by xen44-runtime, trying to install xen44-runtime-4.4.1-8.el6.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package xen.x86_64 0:4.4.1-11.fc21 will be obsoleted
---> Package xen-hypervisor.x86_64 0:4.4.1-11.fc21 will be obsoleted
---> Package xen-libs.x86_64 0:4.4.1-11.fc21 will be obsoleted
---> Package xen-runtime.x86_64 0:4.4.1-11.fc21 will be obsoleted
---> Package xen44.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: xen44-qemu = 4.4.1-8.el6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: xen44-licenses = 4.4.1-8.el6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: xen44-doc = 4.4.1-8.el6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: python(abi) = 2.6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-4.4.1-8.el6.x86_64
---> Package xen44-hypervisor.x86_64 0:4.4.1-8.el6 will be obsoleting
---> Package xen44-libs.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-libs-4.4.1-8.el6.x86_64
--> Processing Dependency: liblzma.so.0()(64bit) for package: xen44-libs-4.4.1-8.el6.x86_64
---> Package xen44-runtime.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: python(abi) = 2.6 for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Running transaction check
---> Package xen-licenses.x86_64 0:4.4.1-11.fc21 will be obsoleted
---> Package xen44.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: python(abi) = 2.6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-4.4.1-8.el6.x86_64
---> Package xen44-doc.x86_64 0:4.4.1-8.el6 will be installed
---> Package xen44-libs.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-libs-4.4.1-8.el6.x86_64
---> Package xen44-licenses.x86_64 0:4.4.1-8.el6 will be obsoleting
---> Package xen44-qemu.x86_64 0:4.4.1-8.el6 will be installed
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
--> Processing Dependency: libpng12.so.0()(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
---> Package xen44-runtime.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: python(abi) = 2.6 for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
---> Package xz-compat-libs.x86_64 0:5.1.2-14alpha.fc21 will be installed
--> Running transaction check
---> Package libpng12.x86_64 0:1.2.50-8.fc21 will be installed
---> Package xen44.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: python(abi) = 2.6 for package: xen44-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-4.4.1-8.el6.x86_64
---> Package xen44-libs.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-libs-4.4.1-8.el6.x86_64
---> Package xen44-qemu.x86_64 0:4.4.1-8.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: xen44-qemu-4.4.1-8.el6.x86_64
---> Package xen44-runtime.x86_64 0:4.4.1-8.el6 will be obsoleting
--> Processing Dependency: python(abi) = 2.6 for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libyajl.so.1()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: xen44-runtime-4.4.1-8.el6.x86_64
--> Finished Dependency Resolution
Error: Package: xen44-runtime-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: xen44-qemu-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libgnutls.so.26()(64bit)
Error: Package: xen44-runtime-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libgnutls.so.26()(64bit)
Error: Package: xen44-runtime-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libyajl.so.1()(64bit)
Error: Package: xen44-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: xen44-libs-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libyajl.so.1()(64bit)
Error: Package: xen44-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: python(abi) = 2.6
           Installed: python-2.7.8-7.fc21.x86_64 (@fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.4.1-16.fc21.x86_64 (@fedora)
               python(abi) = 3.4
               python(abi) = 3.4
Error: Package: xen44-qemu-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: xen44-runtime-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: python(abi) = 2.6
           Installed: python-2.7.8-7.fc21.x86_64 (@fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.4.1-16.fc21.x86_64 (@fedora)
               python(abi) = 3.4
               python(abi) = 3.4
Error: Package: xen44-runtime-4.4.1-8.el6.x86_64 (kernel-xen)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
LVL 1
ColinMDAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
gheistConnect With a Mentor Commented:
Remove this repository:
http://xen.crc.id.au/

No, RHEL6 packages will not work on Fedora 21.
0
 
Seth SimmonsSr. Systems AdministratorCommented:
did you add custom repositories?
on my fedora 21 system it shows xen/xen-hypervisor/xen-runtime; none with 44 in the package name
0
 
ColinMDAuthor Commented:
No, just a standard server install of Fedora as far as I am aware.
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
ColinMDAuthor Commented:
If I run this command:
systemctl status xenstored.service

I get:

● xenstored.service - Xenstored - daemon managing xenstore file system
   Loaded: loaded (/usr/lib/systemd/system/xenstored.service; enabled)
   Active: inactive (dead)
           start condition failed at Tue 2015-01-06 10:26:54 GMT; 2s ago
           ConditionPathExists=/proc/xen was not met
0
 
ColinMDAuthor Commented:
running this command - xl info

Gives me:

xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error
libxl: error: libxl.c:92:libxl_ctx_alloc: cannot open libxc handle: No such file or directory
cannot init xl context
0
 
ColinMDAuthor Commented:
running this -  systemctl status xenconsoled

Gives me

● xenconsoled.service - Xenconsoled - handles logging from guest consoles and hypervisor
   Loaded: loaded (/usr/lib/systemd/system/xenconsoled.service; enabled)
   Active: inactive (dead)
           start condition failed at Tue 2015-01-06 10:29:38 GMT; 7s ago
           ConditionPathExists=/proc/xen was not met
0
 
gheistCommented:
Why you are trying to install xen for RHEL6 on Fedora 21?
0
 
ColinMDAuthor Commented:
I ran:  yum install xen
0
 
ColinMDAuthor Commented:
Is this the RPM I am removing - kernel-xen-release-6-5.noarch.rpm      

Thanks for your help
0
 
gheistCommented:
Yes, that is RPM that adds EL6 XEN44 kernel repository.
yum erase kernel-xen-release

Then continue where you started to ask here..
Probably "yum clean all" will clean surplus goods so you dont step in them
0
 
ColinMDAuthor Commented:
OK... So I have uninstalled above and can successfully run the command

yum -y install xen xen-hypervisor xen-libs xen-runtime

However, I still have the other issues where the Xen modules won't run and xl info still fails.
0
 
ColinMDAuthor Commented:
This is my fstab:

# /etc/fstab
# Created by anaconda on Wed Dec 24 11:41:15 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora--server-root /                       ext4    defaults        1 1
UUID=3b4a4399-2fc2-43d1-a263-db5ca27c91f7 /boot                   ext4    defaults        1 2
UUID=657A-EEF1          /boot/efi               vfat    umask=0077,shortname=winnt 0 0
/dev/mapper/fedora--server-home /home                   ext4    defaults        1 2
/dev/mapper/fedora--server-swap swap                    swap    defaults        0 0


This is my grub file:

# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
set pager=1

if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="XEN"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

terminal_output console
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora, with Linux 3.17.7-300.fc21.x86_64' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-3.17.7-300.fc21.x86_64-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd4,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        else
          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        fi
        linuxefi /vmlinuz-3.17.7-300.fc21.x86_64 root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
        initrdefi /initramfs-3.17.7-300.fc21.x86_64.img
menuentry 'Fedora, with Linux 0-rescue-e92f673893c242d19f7a9e8af5095e62' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-0-rescue-e92f673893c242d19f7a9e8af5095e62-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
        load_video
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd4,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        else
          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        fi
        linuxefi /vmlinuz-0-rescue-e92f673893c242d19f7a9e8af5095e62 root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
        initrdefi /initramfs-0-rescue-e92f673893c242d19f7a9e8af5095e62.img
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
menuentry 'Fedora, with Xen hypervisor' --class fedora --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-simple-8a46c987-bac9-4664-9a73-aff7890f050a' {
        insmod part_gpt
        insmod ext2
        set root='hd4,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
i=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        else
          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
        fi
        echo    'Loading Xen xen ...'
        if [ "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
            xen_rm_opts=
        else
            xen_rm_opts="no-real-mode edd=off"
        fi
        multiboot       /xen.gz placeholder   ${xen_rm_opts}
        echo    'Loading Linux 3.17.7-300.fc21.x86_64 ...'
        module  /vmlinuz-3.17.7-300.fc21.x86_64 placeholder root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
        echo    'Loading initial ramdisk ...'
        module  --nounzip   /initramfs-3.17.7-300.fc21.x86_64.img
}
submenu 'Advanced options for Fedora (with Xen hypervisor)' $menuentry_id_option 'gnulinux-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
        submenu 'Xen hypervisor, version xen' $menuentry_id_option 'xen-hypervisor-xen-8a46c987-bac9-4664-9a73-aff7890f050a' {
                menuentry 'Fedora, with Xen xen and Linux 3.17.7-300.fc21.x86_64' --class fedora --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-3.17.7-300.fc21.x86_64-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
                        insmod part_gpt
                        insmod ext2
                        set root='hd4,gpt2'
                        if [ x$feature_platform_search_hint = xy ]; then
                          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        else
                          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        fi
                        echo    'Loading Xen xen ...'
                        if [ "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
                            xen_rm_opts=
                        else
                            xen_rm_opts="no-real-mode edd=off"
                        fimultiboot       /xen.gz placeholder   ${xen_rm_opts}
                        echo    'Loading Linux 3.17.7-300.fc21.x86_64 ...'
                        module  /vmlinuz-3.17.7-300.fc21.x86_64 placeholder root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
                        echo    'Loading initial ramdisk ...'
                        module  --nounzip   /initramfs-3.17.7-300.fc21.x86_64.img
                }
        }
        submenu 'Xen hypervisor, version 4.4.1' $menuentry_id_option 'xen-hypervisor-4.4.1-8a46c987-bac9-4664-9a73-aff7890f050a' {
                menuentry 'Fedora, with Xen 4.4.1 and Linux 3.17.7-300.fc21.x86_64' --class fedora --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-3.17.7-300.fc21.x86_64-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
                        insmod part_gpt
                        insmod ext2
                        set root='hd4,gpt2'
                        if [ x$feature_platform_search_hint = xy ]; then
                          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        else
                          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        fi
                        echo    'Loading Xen 4.4.1 ...'
                        if [ "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
                            xen_rm_opts=
                        else
                            xen_rm_opts="no-real-mode edd=off"
                        fi
                        multiboot       /xen-4.4.1.gz placeholder   ${xen_rm_opts}
                        echo    'Loading Linux 3.17.7-300.fc21.x86_64 ...'
                        module  /vmlinuz-3.17.7-300.fc21.x86_64 placeholder root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
                        echo    'Loading initial ramdisk ...'
                        module  --nounzip   /initramfs-3.17.7-300.fc21.x86_64.img
                }
        }
        submenu 'Xen hypervisor, version 4.4' $menuentry_id_option 'xen-hypervisor-4.4-8a46c987-bac9-4664-9a73-aff7890f050a' {
menuentry 'Fedora, with Xen 4.4 and Linux 3.17.7-300.fc21.x86_64' --class fedora --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-3.17.7-300.fc21.x86_64-advanced-8a46c987-bac9-4664-9a73-aff7890f050a' {
                        insmod part_gpt
                        insmod ext2
                        set root='hd4,gpt2'
                        if [ x$feature_platform_search_hint = xy ]; then
                          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt2 --hint-efi=hd4,gpt2 --hint-baremetal=ahci4,gpt2  3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        else
                          search --no-floppy --fs-uuid --set=root 3b4a4399-2fc2-43d1-a263-db5ca27c91f7
                        fi
                        echo    'Loading Xen 4.4 ...'
                        if [ "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
                            xen_rm_opts=
                        else
                            xen_rm_opts="no-real-mode edd=off"
                        fi
                        multiboot       /xen-4.4.gz placeholder   ${xen_rm_opts}
                        echo    'Loading Linux 3.17.7-300.fc21.x86_64 ...'
                        module  /vmlinuz-3.17.7-300.fc21.x86_64 placeholder root=/dev/mapper/fedora--server-root ro rd.lvm.lv=fedora-server/root rd.lvm.lv=fedora-server/swap rhgb quiet
                        echo    'Loading initial ramdisk ...'
                        module  --nounzip   /initramfs-3.17.7-300.fc21.x86_64.img
                }
        }
}

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_ppc_terminfo ###
### END /etc/grub.d/20_ppc_terminfo ###

### BEGIN /etc/grub.d/30_os-prober ###menuentry 'XenServer release 6.2.0-70446c (xenenterprise) (on /dev/sda1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-9e8c2496-a3ef-4efe-90f2-b133bac994de' {
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  9e8c2496-a3ef-4efe-90f2-b133bac994de
        else
          search --no-floppy --fs-uuid --set=root 9e8c2496-a3ef-4efe-90f2-b133bac994de
        fi
        linuxefi /boot/vmlinuz-2.6.32.43-0.4.1.xs1.8.0.835.170778kdump root=/dev/sda1
        initrdefi /boot/initrd-2.6.32.43-0.4.1.xs1.8.0.835.170778kdump.img
}
submenu 'Advanced options for XenServer release 6.2.0-70446c (xenenterprise) (on /dev/sda1)' $menuentry_id_option 'osprober-gnulinux-advanced-9e8c2496-a3ef-4efe-90f2-b133bac994de' {
        menuentry 'XenServer release 6.2.0-70446c (xenenterprise) (on /dev/sda1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-2.6.32.43-0.4.1.xs1.8.0.835.170778kdump--9e8c2496-a3ef-4efe-90f2-b133bac994de' {
                insmod part_gpt
                insmod ext2
                set root='hd0,gpt1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  9e8c2496-a3ef-4efe-90f2-b133bac994de
                else
                  search --no-floppy --fs-uuid --set=root 9e8c2496-a3ef-4efe-90f2-b133bac994de
                fi
                linuxefi /boot/vmlinuz-2.6.32.43-0.4.1.xs1.8.0.835.170778kdump root=/dev/sda1
                initrdefi /boot/initrd-2.6.32.43-0.4.1.xs1.8.0.835.170778kdump.img
        }
        menuentry 'XenServer release 6.2.0-70446c (xenenterprise) (on /dev/sda1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-2.6.32.43-0.4.1.xs1.8.0.835.170778xen--9e8c2496-a3ef-4efe-90f2-b133bac994de' {insmod part_gpt
                insmod ext2
                set root='hd0,gpt1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  9e8c2496-a3ef-4efe-90f2-b133bac994de
                else
                  search --no-floppy --fs-uuid --set=root 9e8c2496-a3ef-4efe-90f2-b133bac994de
                fi
                linuxefi /boot/vmlinuz-2.6.32.43-0.4.1.xs1.8.0.835.170778xen root=/dev/sda1
                initrdefi /boot/initrd-2.6.32.43-0.4.1.xs1.8.0.835.170778xen.img
        }
}

### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
~                                                                              
~
0
 
gheistCommented:
Thats way past fixing broken yum repositories.
Could you please post new question that fits in one page on (failures in) operating the XEN.
0
 
ColinMDAuthor Commented:
The link you provided has helped a lot and pointed me in the right direction, thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.