Remote Desktop RDP to 3 PCs using a different Port per PC?

Hello Experts,

I just setup a New SonicWall TZ105  at a client.

They have 2 PCs and a Server, XX-FS1, XX-PC1 & XX-PC2

I need to configure RDP to each PC from externally.

I used the Wizard in the Sonicwall and it works for 1 PC but never for the next one.

I Know I need to create a new Port of each PC like 3390, 3391 & 3392 But I cannot get it to work.

I've tried this:

But I cannot get it to work.

Can you please provide Step by Step commands to configure my TZ 105 ?


Who is Participating?
LasareathConnect With a Mentor Author Commented:
This explains how to do it.  Works Perfectly!!!
Note: I use X3 for my WAN port. Yours may differ.

1. Open Firewall section

a. Add Address Object:
i. Local: e.g. "User1", LAN, Host,
ii. Remote: e.g. "User1 Home", WAN, Host, 123.456.789.999
iii. Repeat above for each PC.

b. Add Service Object, RDP with unique port, e.g. "RDP_3391", TCP, Start & End ranges: 3391

c. Add Access Rule, Matrix, WAN to LAN, e.g. Service: "RDP_3391", Source: "User1 Home", Destination: X3 IP

2. Open Network section

a. Add NAT Policy, e.g.
i. Original Source: Any
ii. Translated Source: Original
iii. Original Destination: X3 IP
iv. Translated Destination: "User1"
v. Original Service: RDP_3391
vi. Translated Service: Original
vii. Inbound Interface: X3
viii. Outbound Interface: Any
ix. Comment. Add one.
x. Repeat above for each PC.

Note: In case you don't know, you'll need to revise your RDP ports at each station to match the firewall ports.
LasareathAuthor Commented:
Thanks for the reply.

I used X1

For 1a I created:
i.  NICK
ii.  Not Sure what you want me to fill out here?, Is the 123.456.789.999 My WAN IP?
Firewall Management 201 with Professor Wool

In this whiteboard video, Professor Wool highlights the challenges, benefits and trade-offs of utilizing zero-touch automation for security policy change management. Watch and Learn!

123.456.789.999 is the external IP connecting to the LAN pc/server. e.g. Nick's home.
LasareathAuthor Commented:
The problem with that is I don't know that IP, He's connecting with a Laptop. So the IP will be different each time
LasareathAuthor Commented:
Can I make that IP address a Range?
No. You can't make the IP a range. In that case, you can't use the user's source IP. You'd have to open it by changing the Access Rule, Source. Instead of "User1 Home", use something like All WAN IP. However, this is basically open to the world - not good. A better solution is Sonicwall's NetExtender, which is basically a VPN. I'm not familiar with NetExtender, so I don't have workable info for you.
LasareathAuthor Commented:
I know NetExtender, I use it with many clients, This client does not want NetExtender, They want RDP
I'm not certain but, doesn't netextender let one make a secure connection to the lan? If so, at that point I think you should be able to connect via rdp
NVITCommented: the effect that the remote client becomes part of the lan and gets a lan IP.
LasareathAuthor Commented:
Yes, Or you can run a login script and just map drives.

They want to use RDP because they may not be on their laptop, they may be on a clients PC and so they want to use RDP from that PC.

There are tons of posts I've found where people say they do it all the time by using another port for each PC.

You can go to the registry of the destination PC and change the incoming RDP port

I think there is also a way to do it in NAT Policies where you tell the incoming route to go to the new IP based on which Port it came in on.
LasareathAuthor Commented:
There are people who said they got this to work:

I'm just not a SonicWall Guru
Hi. Please bear with me due to my ignorance with netextender.

Just to confirm, once the client connects via netextender, does it get an IP on the same LAN? If so, we just need to worry about rdp on the LAN side. No sonicwall at that point... I think. 8-)
In general:
On target host...
1. Change rdp port
2. Change registry
3. Open host firewall port, if applicable.

On remote client...
1. Connect via netextender.
2. Connect via rdp using hostname:port

I don't have exact steps since I'm not on a computer now. Commuting home now...
LasareathAuthor Commented:
I don't want to use NetExtender.
LasareathAuthor Commented:
There is also a Video at that URL with a really sexy sounding Indian chick showing you how to do it.  Piece of cake now. Each PC has their own Port.  3390, 3391, 3392

LasareathAuthor Commented:
It works
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.