Permissions not cascading to child objects - SBS 2011

I have a problem with a small business setup. I was trying to move the RedirectedFolders folder to a drive with more space and it kept on failing with a permission issue, i accidentally took ownership of the entire directory. I Stopped sharing the folder and manualy moved it to the E drive successfully. i enabled sharing again.

I then ran the registry hack as indicated here http://technet.microsoft.com/en-us/library/gg680331.aspx and all tested ok, for some users for users they cant write to the child objects in some or all the folders.

for example,

user 1 has a folder located at e:\Redirectedfolders\user1

NTFS here is as (System FC, Domain users R,Domain Admin FC,user1 FC)

user1 ones desktop is at e:\RedirectedFolders\user1\desktop

NTFS here is as (System FC, Domain Users R, Domain Admin FC, User1 None - no check boxes checked)
the above is present for all child objects, user is in the permission list but no permissions specified for the objects

I tried to reset the permissions using icacls

icacls "c:\parentDirectory\user1" /q /c /t /reset

this seems to remove all permissions but when i try to specify some permissions it applies them but the user still has no write access to the said folders

HELP!!!
LVL 3
Helao MwapangashaData Centre: Server EngineerAsked:
Who is Participating?
 
Helao MwapangashaConnect With a Mentor Data Centre: Server EngineerAuthor Commented:
I created a new shared folder. Set the correct permissions through SBS 2011. copied the content to the folder and the permissions reapplied correctly.
0
 
VB ITSSpecialist ConsultantCommented:
Try changing the Owner of the E:\Redirectedfolders\User1 back to either User1 or the local Administrators group on the file server.

Folder redirection doesn't seem to like it when the Owner isn't set to one of the above.
0
 
Helao MwapangashaData Centre: Server EngineerAuthor Commented:
The problem is when i do that, it applies only to the parent folder, if i check the properties of the child object, the previous permissions are still applied
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
VB ITSSpecialist ConsultantCommented:
Sounds like you need to configure the permissions to propagate to the child objects. To do this:

Right click on the User1 folder in E:\RedirectedFoldersSecurity tab > Advanced > click Change Permissions in the Permissions tab > tick Replace all child object permissions with inheritable permissions from this object.
0
 
Helao MwapangashaData Centre: Server EngineerAuthor Commented:
i tried that but nothing seems to be working.
0
 
VB ITSSpecialist ConsultantCommented:
When you re-enabled the sharing, did you grant the Everyone group Full Control to the share permissions?

Go to the Properties of the E:\RedirectedFolders folder > Sharing tab > Advanced SharingPermissions > make sure the Everyone group has Full Control, as by default the Everyone group only has Read access when you first enable sharing.
0
 
BahloulCommented:
Hi,

as you mentioned user1 should take full control as he the owner creator so you must assign full control first to everyone in sharing permission then  

go to security permission add user1 assign full-control .

and make sure from advanced option on Security tab to Replace all child object permissions with inheritable permissions from this object.

Bahloul.
0
 
Helao MwapangashaData Centre: Server EngineerAuthor Commented:
I did some research on the internet and managed to find the best possible solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.