Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Exchange 2010 migration to Exchange 2013 on Premise

Posted on 2015-01-06
13
Medium Priority
?
74 Views
Last Modified: 2015-01-19
I have our current Exchange 2010 on SBS2011 Co-existing with the new Exchange 2013 On Premise Installed and followed the Configuration steps but I cannot get our OWA Externally go to the New Exchange 2013 OWA, any guidance and troubleshooting information would be greatly appreciated.
0
Comment
Question by:dtssupport
  • 7
  • 6
13 Comments
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534106
Have you got the correct cert in place and verified that you have updated your URL of your OWA virtual directories for both Exchnage 2010 and Exchange 2013?

Your Exchange Cert should have the following SAN names
- autodiscover.domain.com
- mail.domain.com
- legacy.domain.com

Using legacy.domian.com for all of the virtual directories on Exchange 2010 and using mail.domain.com for all virtual directories on Exchange 2013.

Once this is in place you will only have to use mail.domain.com to access OWA and if the mailbox resides on Exchange 2010 it will redirect you automatically to the legacy.domain.com and log you into your mailbox (exchange 2010). For mailboxes that are already on Exchange 2013 it will go directly into the mailbox.

Will.
0
 

Author Comment

by:dtssupport
ID: 40534131
Thx Will,

I have multiple Certs listed and there are all valid and I have one that has all of the ones you listed.
Autodiscover. domain.com
mail.domain.com
legacy.domain.com

I also created a send and receive connector on the New Exchange 2013 server and now I am getting an internal pop up with the Outlook 2013 about the Security Cert and it's the one we imported from the SBS2011 Exchange 2010 Server.
0
 

Author Comment

by:dtssupport
ID: 40534137
From externally if I type in https://legacy.domain.com/owa or https://mail.domain.con/owa still pulls up the 2010 OWA
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534139
You can import a cert on an Exchange server with no issues. You need need to assign the Cert on the Exchange server with the appropriate services.

Go to the Exchange server where the cert is installed
- open the EMS
- Type Get-ExchangeCertificate (you should see your exchange cert listed there)
- Type Enable-ExchangeCertificate -Thumbprint "thumbprint of your cert" -services "smtp,iis,pop,imap"
- This cert now becomes the default cert that will be used

Also when you are getting that popup what cert is it mapped to?

Will.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534142
If you type legacy.domain.com it should go directly to your OWA login page for 2010. If you type mail.domain.com it should go to 2013 OWA.

I would start by making sure your cert assignment is correct and then going through and checking all of your URL for all of your virtual directories. Also for External Access.

Will.
0
 

Author Comment

by:dtssupport
ID: 40534181
it was mapped to the imported Certificate from the SBS2011 Exchange 2010 Server, I just enabled the one that I had created on the New Exchange Server and includes all of the Services and this one has all of the Autodiscover.domain.com, Mail.domain.com, legacy.domain.com
smtp, iis, pop, imap........ rebooted Exchange Server and https: 443 is showing the new cert, but OWA External still going to 2010 OWA....I sure there has to be some other steps, any ideas>?
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534209
Have you created External DNS pointers to point to the new Exchange server? I am assuming that is what the issue is. Do you have split DNS (Internal AD Domain and External Domain Zones access internally?) If you do does it work internally and just not when you are on the internal domain network?

Will.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534212
Your OWA externally needs to be accessible on the new server and it is pointing to the old 2010 Exchange still. Which is why it is going directly to your old 2010 server when you are using mail.domain.com

WIll.
0
 

Author Comment

by:dtssupport
ID: 40534231
I have all the Virtual Directories pointed correctly unless there is a firewall setting that has to change?
0
 

Author Comment

by:dtssupport
ID: 40534247
OWA is accessible on the new Server internally, just not externally!
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40534636
Have you configured your firewall rules to point to your new Exchange 2013 server? You should have your external IP which for mail.domain.com NAT'ed through your firewall to the new server. It is still pointing to your old 2010 server.

This is what needs to be changed.

Will.
0
 

Accepted Solution

by:
dtssupport earned 0 total points
ID: 40544764
I don't believe I will have time currently to keep this ticket open and will have to work on it later, as will work to resolve the issue thank you
0
 

Author Closing Comment

by:dtssupport
ID: 40557301
Could not come up with a solution and ran out of time to leave this question up with no activity
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses

885 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question