• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 152
  • Last Modified:

Adding exchange account on IOS device - will not verify without entering advanced settings

Hi all,

When users attempt to add their exchange account on an IOS device it does not verify after entering their email address and password. They have to tap continue to enter advanced settings and then enter the email server name and domain name, and then it will verify the account.
I would like for users to be able to setup their exchange account on an IOS device without having to enter the advanced settings. What am I missing?
0
CoSmismgr
Asked:
CoSmismgr
  • 4
  • 4
1 Solution
 
Michael ZehrCTOCommented:
I just copied this to not have to type it:

Just create an alias domain in the AD Domain and Trust >> UPN Suffixes.  for (default) smtp address and then assign using ADUC via account tab. This should help.

In general, all this mess is because Apple removed a username option during the configuration of ActiveSync client. Thereby in most cases UPN doesn't mach SMTP address.

Of course, autodiscover has to work as well. So, you Need an upn, that spells exactly like you maildomain.
0
 
CoSmismgrAuthor Commented:
Just create an alias domain in the AD Domain and Trust >> UPN Suffixes.  for (default) smtp address and then assign using ADUC via account tab. This should help.

In general, all this mess is because Apple removed a username option during the configuration of ActiveSync client. Thereby in most cases UPN doesn't mach SMTP address.

I am not an AD wizard, but I don't even see the option to create an alias domain in AD Domain and Trust snap-in. I'll try to research this solution though.
0
 
Michael ZehrCTOCommented:
Just open the snapin, right-click on AD Domain and Trust and select properties.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
CoSmismgrAuthor Commented:
That is easy enough. Can you clarify what I need to enter in the Alternative UPN suffix field? Do I enter the public hostname of my exchange server? Also, what object am I suppose to assign it to using ADUC?
0
 
CoSmismgrAuthor Commented:
I created the UPN for the public hostname of email server. I did not assign it in ADUC. I went into IIS manager and edited the default domain for autodiscover, owa, and Microsoft-Server-ActiveSync to mydomain.local. I created an A record on internal DNS server for autodiscover pointing to private IP of email server and it is working. I was able to configure Exchange account without having to enter domain name or server name! Thanks
0
 
Michael ZehrCTOCommented:
Great, I was just trying some things to give you a complet answer, but you beat me to it :-)
0
 
Michael ZehrCTOCommented:
One hint more: I think you will Need an external DNS A Record autodiscover.domain.com that Points to your mailserver, even if you have a service-record. If you don't have the autodiscover in your ssl certificate, iOS let's you accept it.
0
 
CoSmismgrAuthor Commented:
That's already in place ;) cheers
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now