Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 290
  • Last Modified:

Joomla-Linux Could not open /opt/lampp/apps/joomla/htdocs/CONTRIBUTING.md for writing.

Have the newest Joomla installed on CentOS 7.

When I log into Joomla admin interface it asks to update to Joomla version 3.3.6.
However when I do I get this message:

Could not open /opt/lampp/apps/joomla/htdocs/CONTRIBUTING.md for writing.

I am opening the web interface using Firefox.


Thank you,
HappyT
0
TheHappyTech
Asked:
TheHappyTech
  • 8
  • 7
1 Solution
 
Tom ChadaraviciusSenior DeveloperCommented:
Either the file CONTRIBUTING.md is absent and/or you lack permissions
To solve the permissions problem, if you can at least use FileZilla (S)FTP client, check the permissions of ../htdocs directory. Change them to 755 (0755) octal.
If that alone does not help, please make sure Linux "apache" user (and/or group) can read/write to that directory (chown command).
0
 
Tom ChadaraviciusSenior DeveloperCommented:
Here's the "File attribute" dialog of FileZilla. My screenshot points to "public_html", your dialog should point to "htdocs":
FileZilla - directory/file permissions dialog
0
 
TheHappyTechAuthor Commented:
This is a bit over my head... but I will do my best.

1). I tried logging in as root and doing the update through Joomla using firefox and still same error
2). While still root, I tried to find the 'apache' user under the file permissions of the htdocs folder. Did not find it.
3). I have know the very basics of using Filezilla, and I have the Xampp ftp login and password, (port 21) but I cant connect.
Maybe I dont have the correct path?? So far I am just using the IP, do I need more than that?
0
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

 
Tom ChadaraviciusSenior DeveloperCommented:
Please ensure you've got the correct permissions.
Even if you use FireFox, your Joomla runs under Apache, so Apache user/group must have write rights. The actual "apache" user may be overwritten in httpd.conf file(s); and the user/owner of htdocs may just belong to "apache"group.
Setting permissions to 0755 (755) should also resolve the user/group issue.
2. The correct path issue - I am assuming you have quoted correct path when you asked the question. But if the path is non-existent, that's definitely an issue.
0
 
TheHappyTechAuthor Commented:
I havent use Linux much before. Ill be honest about that.

Could you walk me through how to set permissions to 755?

Its the correct path.

Thank you Tom,
HappyT
0
 
Tom ChadaraviciusSenior DeveloperCommented:
If, according to you, you are new to Linux, and if the /opt/lampp/apps/joomla/htdocs/ really exist, the FileZilla is the most user-friendly way to fix the issue.
If you want to learn Linux, and if you have SSH access, I suggest to look at chmod.
1. Are you sure  the directory /opt/lampp/apps/joomla/htdocs/ exists?
2. Can you use FileZilla?
Tom
0
 
TheHappyTechAuthor Commented:
1. Yes
2. Yes

I just dont know what to do next.
0
 
Tom ChadaraviciusSenior DeveloperCommented:
1. Connect to your server using FileZilla
2. Ensure the directory exists
3. If the directory exists, right-click on htdocs
3.1. A menu will appear, there will be an item called "File attribute(s)". Select that item
4. A pop-up dialog will appear. It will look like the dialog I have posted earlier.
5. Enter 755 into the "Numeric Value" field
That should allow any user read/write file (s) in the .../htdocs directory (any except for "public; "public" is 777).
*Note: you need to connect as "root" user for this to work - or as a user who has sufficient access to modify "htdocs" directory
0
 
TheHappyTechAuthor Commented:
I've requested that this question be deleted for the following reason:

Beyond my skill level. Going to re-install another flavor of Linux and try again.

Thank you.
0
 
Tom ChadaraviciusSenior DeveloperCommented:
The procedure involving FileZilla or chmod will be the same on any Linux flavor - RHEL, CentOS ver 5/6, Fedora.
If you can access SSH terminal, type ls -l /opt/lampp/apps/joomla/htdocs/ to find out if the directory exists.
If it does not exist, you will get an answer
ls: cannot access /opt/lampp/apps/joomla/htdocs/: No such file or directory
If it does exist, you will get an output showing some parameters, such as file size(s) and timestamps.
0
 
TheHappyTechAuthor Commented:
I just moved into a new apt so I am without internet access for awhile,
I will try this monday, thank you Tom.
0
 
TheHappyTechAuthor Commented:
Thank you Tom! This was exactly the fix I needed and I learned things about FileZilla I did not know before.
0
 
TheHappyTechAuthor Commented:
Changing the permissions worked successfully, but I still cant update and apply the latest Joomla update.

I cant find the Apache user and/or group either.

I know we are close to resolving this, mind helping me out one last time?
0
 
TheHappyTechAuthor Commented:
I got it to work. I set it to set permissions for sub folders and files. All is good and updated!

Thank you Tom.
0
 
Tom ChadaraviciusSenior DeveloperCommented:
My pleasure :)
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now