Solved

Cisco WAP stops passing DHCP

Posted on 2015-01-08
6
67 Views
Last Modified: 2016-10-14
Hello

I have 4 Cisco WAP551s at one of our sites, and I have discovered a problem whereby they stop distributing/passing through DHCP addresses to clients. This happens roughly every 2 days, at which point I simply reboot them all and magically the clients get addresses again and everything is OK for another couple of days.

I don't think it's the DHCP server (Win 2012 R2) since it still gives out addresses on wired clients when this problem occurs.

I have upgraded them all to the latest firmware and tried running them in a cluster (single point setup mode) and separately with the same SSID. Problem occurs in both modes.

If I give my wireless interface a static IP, I get full network access, so I don't think there's any routing/switch config issues.

Any ideas please? They're under warranty but I have no Cisco technical support contract. I could try get them all replaced but it seems unlikely to be a hardware fault with all 4.
0
Comment
Question by:failed
  • 2
  • 2
6 Comments
 
LVL 32

Expert Comment

by:_
ID: 40539439
kind of a long shot, but it's the first thing that popped into my head.
Check the "Lease" times and settings on them and the DHCP Server.
Sounds like they might not be "renewing" properly, for one reason or another.

Mostly I'm thinking the AP's are holding the addys too long, and run out of numbers to hand out.
If a lot of people connect/disconnect all day long, the addy they get is reserved for the full Lease.
eg:
if most people only connect for 1 hour, and the Lease is for 1 day, that's 23 hours that that addy is unusable (except if the same computer connects again, and it's Lease is still good).
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 40539739
You need to do a packet capture from the AP.  This should show you whether the AP is passing DHCP requests either way.

The fact that wired clients receive addresses, and that it works after the AP is rebooted tells me that it's not a DHCP server issue, or a lease issue.
0
 

Author Comment

by:failed
ID: 40539807
I've just jumped on the switch and noticed an active dhcp pool, so I guess that must be interfering! Not sure what it's doing there, it's certainly not required.

I've tried to remove it by issuing the no ip dhcp pool command, which ran without error, but the pool is still present when I show run? If I try issue the no ip dhcp command again it says the pool is not in the database??

Excerpt from running config:

no ip dhcp use vrf connected
!
ip dhcp pool guest-builds
   default-router 192.168.69.254
!

When I try run the no ip dhcp pool command:

Switch1(config)#no ip dhcp pool guests-builds
% guests-builds is not in the database.
0
 
LVL 45

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 40539927
If the pool on the switch was interfering it would have been handing addresses to the clients.  I wouldn't stop clients receiving an address.

You're getting the error because you're using the wrong pool name.

You entered no ip dhcp pool guests-builds

The correct command you need is...

no ip dhcp pool guest-builds

Open in new window


(note guest without the trailing 's').
0
 

Author Comment

by:failed
ID: 40539930
Yep it was a simple typo, thanks for spotting that, I've removed the pool now!

I'll keep an eye on things now and see if I still get the same problem. If it's OK after a few days I'll come back and close the question.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

With the purchase of CloudCommand by Comcast customers are left in a bind as subscriptions expire and render the AP's disabled. The following will explain how to flash your Ubiquiti AP's with CloudCommand firmware back to Ubiquiti firmware. HOWTO…
Multi-source agreements are important because they set standards that all manufacturers should follow to ensure that devices are compatible with multiple vendors. The multi-source agreement (MSA) is an agreement that establishes how multiple vendors…
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now