Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


Using ADMX template on 2008 R2 Domain Controller

Posted on 2015-01-08
Medium Priority
Last Modified: 2015-01-19
I have a 2008 R2 domain controller which I use for Group Policy. Up until now I have been using the ADM files which I see now have been replaced with the ADMX which were available before. But when I went to download the template for office 2013 only the admx were available. When I tried to add it using the Add/Remove Templates, they weren't available since I think that is only for ADM type.

I have been reasearching and all the sites say to copy the admx file to C:\Windows\PolicyDefinitions or to create a PolicyDefinitions folder in the sysvol for use as a central store. I tried both and I still get an error parsing message which everyone talks about but says copying to PolicyDefinitions is the solution.

Please help.
Question by:swenger7
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 40538869
when you download files from the internet they get a ntfs stream added to the file and you need to right click the file and select unprotect .. you can also use sysinternals streams.exe to unprotect (remove the ntfs stream data) to bulk unprotect files.

Author Comment

ID: 40538880
I didn't get any stream. It was admintemplates64.exe which extracted to an admin and admx folder when I ran the executible
LVL 22

Expert Comment

by:Joseph Moody
ID: 40551043
Can you give us a screenshot showing the files in the policy definitions folder? Did you also copy the language files over?
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

LVL 24

Expert Comment

ID: 40551044
When I tried to add it using the Add/Remove Templates, they weren't available since I think that is only for ADM type.
When you tried to add the Office ADMX file, what happened exactly? Did you get an error message or did the ADMX files add OK but just didn't appear in GPMC?

Did you attempt to implement the Group Policy Central Store prior to manually loading the ADMX files?

Author Comment

ID: 40551215
Before we go to the Central Store, let's try and resolve this locally.

When I open my group policy currently I have ADM templates for Office 2010. See attached file ADM2010.JPG

When I try to Right-Click on Administrative to Add Template and browse to where the Office 2013 admx files are they don't appear which I guess is because the Add Template is only for ADM files. See attached file AddTemplates.JPG

When I manually copy the new Office 2013 ADMX files into the C:\Windows\PolicyDefinitions folder of the current domain controller as you can see in attached file Newadmx.jpg where I tried access15.admx then when I open up my policy I get an error which is attached file Error.jpg.

LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 40552545
check / reset the permissions on the folder

Author Comment

ID: 40553478
Here's the problem, the Folder has the owner as Trusted Installer as well as under Security a user called TrustedInstaller with full control. The file I copy in has inheritence, however it doesn't get the TrustedInstaller even if I force inheritence. I believe the reason is because I can't even find a user on the DC or AD called TrustedInstaller. However the file I copy in does have the Administrtor Group with full control. SO I am not sure if this is the cause of my error in group policy but if it is I am not sure how to fix it.
LVL 42

Accepted Solution

Adam Brown earned 2000 total points
ID: 40554623
There are always two files associated with an admx template, the admx file and the adml file. The adml file is a language localization file that holds the text of the settings. That must be placed into the en-us folder off the policydefinitions folder. If it's not there, you'll get errors.
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 40554662
TrustedInstaller is a local user (part of the o/s)

Author Comment

ID: 40557836
I had to copy the adml files as well.

Thanks acbrown2010

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question