How do I resolve Event ID 4012 - DFSR Replication Service Stopped on SysVol - Server 2012 Essentials R2

We're getting event ID 4012 logged: which states, The DFS Replication service stopped replication on the folder with the following local path: C:\Windows\SYSVOL\domain. This server has been disconnected from other partners for 250 days, which is longer than the time allowed by the MaxOfflineTimeInDays parameter (60). DFS Replication considers the data in this folder to be stale, and this server will not replicate the folder until this error is corrected.
 
To resume replication of this folder, use the DFS Management snap-in to remove this server from the replication group, and then add it back to the group. This causes the server to perform an initial synchronization task, which replaces the stale data with fresh data from other members of the replication group.


What I don't get is why we're seeing this in a one server environment. There's only the one DC, so why does anything need to replicate?

I'm also not sure how to resolve ...since all of the articles I've read on the topic relate to servers with multiple DCs.

Need some good advice.

Thanks...
philodendrinAsked:
Who is Participating?
 
philodendrinConnect With a Mentor Author Commented:
Issue inexplicably just went away on its own without intervention.
0
 
DeadmanIT ConsultantCommented:
This issue already raised question. check this link to solve your problem

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2012/Q_28353972.html
0
 
philodendrinAuthor Commented:
Different circumstance... read that some time ago. Why would I demote and promote anything in a single server environment. Too risky, Those are not instructions for a SBS/Essentials environment. Different animal.
0
 
DeadmanIT ConsultantCommented:
First make sure you had a backup of the SysVol folder, I ran the following:

wmic.exe /namespace:\\root\microsoftdfs path DfsrMachineConfig set MaxOfflineTimeInDays=250

Wait few minutes and check if the event ID 4002 on DC. IF Yes go to next step

Change the HKLM\System\CurrentControlSet\Services\DFSR\Parameters\StopReplicationOnAutoRecovery registry key to a DWORD value of 0 (or delete it).

In command Prompt

wmic /namespace:\\root\microsoftdfs path dfsrmachineconfig set StopReplicationOnAutoRecovery=FALSE
0
 
philodendrinAuthor Commented:
Issue inexplicably just went away on its own without intervention.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.