Solved

Exchange 2007-2013 Migration OAB Issues (0x8004010F) in outlook too!

Posted on 2015-01-09
34
333 Views
Last Modified: 2015-01-14
Evening guys, I've been stuck migrating our 2007 Exchange to 2013 all day. I have been following this procedure:
http://blogs.technet.com/b/meamcs/archive/2013/07/25/part-3-step-by-step-exchange-2007-to-2013-migration.aspx

The issue seems to be when I try to send emails using the autofill on outlook, and when I try to download the address book, I get the error message 0x8004010F.
Ive scoured the internet to try and get this (seemingly basic migration) to work, but Ive tried so much to get it to work, that I cant even remember where to start on this!
How do I go about deleting the old OAB, and starting afresh? If there's any information you may need, please let me know as Im new to posting these.
Thanks
0
Comment
Question by:total123
  • 17
  • 10
  • 7
34 Comments
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40540890
0
 

Author Comment

by:total123
ID: 40540909
I have tried that, and then re-creating a new one, and then assigning it to the mailbox database through the EAC, but its still not working.
0
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40541030
When you open up outlook does it find the OAB url?

If you press ctrl + right click the the ou look icon in the system tray and select test configuration does it have a valid OAB url defined?
C--Users-jgill-Pictures-sample-test-conf
0
 

Author Comment

by:total123
ID: 40541052
Wow, I dont even get that far :(
Autoconfiguration was unable to determine your settings!
0
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40541063
Have you configured all the autodiscover URLS on the 2013 server?, can your clients reach the 2013 servers?  

The reason why OAB is not working is Outlook does not know where to downlaod the OAB from.  But if no autoconfiguration info is showing you may have other issues.  Is this user migrated over to the 2013 system, and is the user connecting to the mailbox on 2013 correctly?,
0
 

Author Comment

by:total123
ID: 40541072
From what I know, yes. We can all log into OWA using our logins etc, and can also use outlook to send and recieve emails. The only thing that isnt working is the OAB, and viewing other peoples calendars. All mailboxes are on the 2013 database
0
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40541101
The autodiscover information is troublesome, or lack off it.  I would try the test again from a different machine, because that will cause major issues, if outlook cant detect autodiscover for URLS

THE oab error you are getting ususally means that outlook cant find the OAB
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40541213
What did you set your internal WebservicesvirtualDirectory to in Exchange 2013? OAB does use autodiscover and Exchange Web Services. Both virtual directories need to be configured properly with the proper certs in place.

Will.
0
 

Author Comment

by:total123
ID: 40541287
Do you know how I can edit the audodiscover information without exchange powershell?

internal is newexchange.domain.local/ews/exchange.asmx
0
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40541335
autodiscover can only be modified through powershell, the other urls can be done through GUI  see, technet link

Set-ClientAccessServer -Identity <CAS2013> -AutoDiscoverServiceInternalURI https://autodiscover.contoso.com/AutoDiscover/AutoDiscover.xml

http://technet.microsoft.com/en-us/library/hh529912(v=exchg.150).aspx

When you set your autodiscover URL, make sure you are in co-existance with the 2007 system if it is still up.  If the 2007 system is gone its fine.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40541502
You will also want to modify the EWS virtual directory as well.

Get-WebServicesVirtualDirectory | fl name, internal*, external*

And

Set-WebServicesVirtualDirectory -Identity <> -InternalURL <> -ExternalURL <>

Will.
0
 

Author Comment

by:total123
ID: 40541523
This is what I get for -getwebservicesvirtualdirectory:

Name                          : EWS (Default Web Site)
InternalNLBBypassUrl          : https://e2007.domain.local/ews/exchange.asmx
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
InternalUrl                   : https://e2007.domain.local/EWS/Exchange.asmx
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
ExternalUrl                   :

Name                          : EWS (Default Web Site)
InternalNLBBypassUrl          :
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
InternalUrl                   : https://e2013.domain.local/ews/exchange.asmx
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
ExternalUrl                   :

Sorry if this seems too basic, this was my first migration
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40541533
You need to change both the internal and external URL's for Exchange 2007 to legacy.domain.com/ews/exchange.asmx. Make sure that for Exchange 2013 you set the URL's using mail.domain.com/ews/exchange.asmx.

Use the following command...
Exchange 2007
Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -internalURL https://legacy.domain.com/ews/exchange.asmx -InternalNLBBypassUrl https://legacy.domain.com/ews/exchange.asmx  -ExternalURL https://legacy.domain.com/ews/exchange.asmx

Exchange 2013
Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -internalURL https://mail.domain.com/ews/exchange.asmx -InternalNLBBypassUrl https://mail.domain.com/ews/exchange.asmx  -ExternalURL https://mail.domain.com/ews/exchange.asmx

Autodiscover tells you were to locate the services. Exchange Web Services control OAB/Out Of Office/etc.

You need to make sure that these URL's are set correctly or Exchange/Outlook will not work properly.

Will.
0
 

Author Comment

by:total123
ID: 40542080
that's now been done, is there anything I need to check or wait for any replication time period ?
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40542134
What i would recommend is open Outlook and hold crtl+right click the system tray icon and from there select auto config test. put in your creds and run the test. It will display all of the URL's that you are getting your services from. Ensure they are all set properly.

Will.
0
 

Author Comment

by:total123
ID: 40542168
first off it comes back with a certificate security question connecting to the exchange 2007, which I clicked yes to.

it then says its found the autoconfig settings and displayedserver as mail.domain.com.

yet I can still not download address book, should I disable exchange 2007 services and see what happens ?
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40542170
Do you have the proper certs in place for Exchange 2007 and Exchange 2013? If so, have you enabled the certs as well?

Have you recreated the OAB and also assocaiated it with all of your databases?

Will.
0
Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

 

Author Comment

by:total123
ID: 40542171
I haven't recreated the OAB yet
Also, we have never had a cert for 2007, we do have one in place for the 2013 (godaddy)
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40542174
If you are going to be having a co-existence scenario with Exchange 2007 and Exchange 2013 you will need certs on both environments.

SAN names should be as follows...
autodiscover.domain.com
mail.domain.com
legacy.domain.com

You need to ensure that the mailbox database actually have an associating OAB. If they do not you will not be able to down the OAB. By default no OAB is assigend to databases in Exchange 2013.

Will.
0
 

Author Comment

by:total123
ID: 40542183
We are looking at taking the 2007 offline. It's just the oab that being a pain and stopping us.
Unless you believe we can turn it off at this stage ?
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40542186
You cannnot just turn off the Exchange 2007 servers you will need to migrate all mailboxes, address list, public folders, etc and then remove the server from programs and features (add/remove programs).

Make sure that your OAB is pointing to the database on Exchange 2013 and it should work for you.

Were you using any guides to do this migration?

Will.
0
 

Author Comment

by:total123
ID: 40542190
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40542199
That one is fine but you had stated that you do not have the proper certs in place and also did you check to make sure that the OAB is assigned to the Exchange 2013 database?

Do the following...
- Login to the Exchange 2013 EAC
- Click Servers
- Database
- Select your Exchange 2013 database
- Click Edit
- Click Client Sessings
- Select the OAB for 2013

See screenshot
OAB SelectionWill.
0
 

Author Comment

by:total123
ID: 40542224
I've followed the above instruction and its still failing to download the OAB.
I have not asked the system to rebuild the OAB
0
 
LVL 53

Accepted Solution

by:
Will Szymkowski earned 250 total points
ID: 40542277
Your autodiscover and Web Service URL's need to be configured properly. These are the services that allow you to download the OAB.

Also take a look at this link as it provides info on this exact error message you are getting. It is for Exchange 2007 and 2010 but same thing applies for Exchange 2013.

OAB Cannot be downloaded

WIll
0
 

Author Comment

by:total123
ID: 40542304
where not using proxy's
0
 

Author Comment

by:total123
ID: 40542314
get-autodiscovervirtualdirectory reply
name                                   server                                 internalurl
autodiscover (default        2008server                        
autodiscover (default         e2013


get-webservices....... reply
name                                    server                                 internalurl
ews (default web site)        2008server                         https://legacy.mydomain.com
ews (default web site)        e2013                                  https://mail.mydomain.com
0
 

Author Comment

by:total123
ID: 40542336
this set of commands, shall I copy it but replace with autodiscover ?

Exchange 2007
 Set-autodiscoverVirtualDirectory -Identity "EWS (Default Web Site)" -internalURL https://legacy.domain.com/ews/exchange.asmx -InternalNLBBypassUrl https://legacy.domain.com/ews/exchange.asmx  -ExternalURL https://legacy.domain.com/ews/exchange.asmx

 Exchange 2013
 Set-autodiscoverVirtualDirectory -Identity "EWS (Default Web Site)" -internalURL https://mail.domain.com/ews/exchange.asmx -InternalNLBBypassUrl https://mail.domain.com/ews/exchange.asmx  -ExternalURL https://mail.domain.com/ews/exchange.asmx
0
 
LVL 8

Expert Comment

by:Jessie Gill, CISSP
ID: 40546782
Dont use the legacy for the autodiscover url, make sure the new autodiscover url points to your 2013 cas servers, the legacy urls all need to point to your 2007 servers.
0
 

Author Comment

by:total123
ID: 40547320
Hi, early today I got forced into calling Microsoft for tech support. They were remotely looking at it for 3 hours, there was an issue with the autodiscover, it was so vast an issue that I can't really say what resolved it.

Thank you for your help
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 40547329
This was already mentioned in a previous comment of mine.

Your autodiscover and Web Service URL's need to be configured properly. These are the services that allow you to download the OAB.

Also take a look at this link as it provides info on this exact error message you are getting. It is for Exchange 2007 and 2010 but same thing applies for Exchange 2013.

OAB Cannot be downloaded
WIll
0
 
LVL 8

Assisted Solution

by:Jessie Gill, CISSP
Jessie Gill, CISSP earned 250 total points
ID: 40547353
I mentioned looking at his auto discover since the beginning of the post.

"Have you configured all the autodiscover URLS on the 2013 server?, can your clients reach the 2013 servers?  

 The reason why OAB is not working is Outlook does not know where to downlaod the OAB from.  But if no autoconfiguration info is showing you may have other issues.  Is this user migrated over to the 2013 system, and is the user connecting to the mailbox on 2013 correctly?,"

"The autodiscover information is troublesome, or lack off it.  I would try the test again from a different machine, because that will cause major issues, if outlook cant detect autodiscover for URLS

 THE oab error you are getting ususally means that outlook cant find the OAB"
0
 

Author Comment

by:total123
ID: 40547437
I was giving feed back, but then it went quite, I did post the  same response twice over 48hrs. With no replies
I thought people had lost interest and hence rang Microsoft.

What's done is done now.
As previously mentioned, thank you for your help
0
 

Author Closing Comment

by:total123
ID: 40549044
Managed to get MS to fix it, but considering you guys helped, we appreciate it
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

If you don't know how to downgrade, my instructions below should be helpful.
Are you unable to connect or configure Hotmail email account in Microsoft Outlook 2010, 2007? Or Outlook.com emails are not downloading to Outlook? Lets’ see the problem and resolve Outlook Connector error syncing folder hierarchy (0x8004102A).
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now