UAC is turned off, but Windows 8.1 Pro still won't allow a remote program to delete a file

I have two machines, DESK and NOTEBOOK.  I want to use DESK as my day to day machine, but all of the files on NOTEBOOK to be in sync so that I can just pick it up and use it when I need to travel.  So I found Allway Sync, which looks like it will do exactly what I want; background sync (or just one way until I travel) changes on DESK to NOTEBOOK.  However I get an "Access denied" from the sync utility on DESK.  UAC is turned off on NOTEBOOK.  I don't know how to further enable Allway Sync to do its thing.  If I can get it going, then I would really like UAC back on on NOTEBOOK, but if not possible that will be OK.

I selected just one folder to sync that I could mess with to watch behavior.

DESK:  Windows 7-64
NOTEBOOK:  Windows 8.1 Pro
LVL 1
Mike CaldwellDirector of Business Development, AnaquaAsked:
Who is Participating?
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
UAC should not cause sync issues. I have UAC ON for both my Windows 8 laptop and my Windows 7 desktop. I sync with Sync Back Pro and it works fine.

Make sure you can map a folder from the Windows 8 machine to the Windows 7 machine. You might wish to (should) make a user name on the Windows 7 machine which is the same user name as the Windows 8 machine.

Try setting up c:\temp on both machines and give "Everyone" permission. Try syncing that way.

You do need folder sharing working for Allway Sync to work.

Please review my article on Folder sharing on Modern Machines.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/A_16639-Folder-sharing-on-modern-machines.html

And by the way, please do keep UAC on as it was designed to be.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
First step, UAC is back on.  User name is already the same on both machines.  Not sure about PW, but can't see how to change that so that I can insure they are the same.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
Windows 8.1 doesn't seem to have a selection regarding the Public folder.
0
Firewall Management 201 with Professor Wool

In this whiteboard video, Professor Wool highlights the challenges, benefits and trade-offs of utilizing zero-touch automation for security policy change management. Watch and Learn!

 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
It is best not to use the Public folder for file sharing between computers. It is a secured folder and not meant for what you want.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
My point is that Windows 8.1 does not offer a selection to turn its access on or off.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
You said to disable it in your article.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
I still need to know how to change my User password on both machines; they may or may not be the same right now.
0
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
Just do not use the public folder. It is secure against outside access. Use different and more neutral folders (like Documents) and even, make sure one of the machines is BASE (DESK I think) and that it has the user name and password for NOTEBOOK set up as an account.
0
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
You do not need to change any usernames (should not at any rate)

On BASE, go to Computer, Manage, Local User and Groups, User and add the main user account name and password of NOTEBOOK.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
I don't for certain know the password, that's why I need to change it so that I can guarantee I am using the right one.

Once I get this working for the test folder, I want to sync all four of my partitions to corresponding partitions on NOTEBOOK.
0
 
John HurstBusiness Consultant (Owner)Commented:
How do you log into NOTEBOOK without a password?  If you are logged in, go to the same Users and Groups location above, select your own userid and change the password. Make sure you know what it is.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
I have both set up to not require log in.  I work alone, at home, so just more convenient.  But I did verify the NOTEBOOK password, and set up a user account on DESK; no change.
0
 
John HurstBusiness Consultant (Owner)Commented:
In my article I talk about network settings:   Network discovery and File and Print sharing ON for both machines. Use Passwords and password protected sharing. Make sure the NIC is set to Work/Private and NOT Public.

The setup takes a bit of thinking but it works like a charm. I sync on my demand to that machine needs to be logged in. The other one does not need to be logged in.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
So here is where I am:  user name and PW same on both.  PW and account required at NOTEBOOK (verified by checking Properties).  Homegroup management is manual on NOTEBOOK.  Trying to sync a deleted file from a folder on DESK, and NOTEBOOK throws an access denied error.
0
 
John HurstBusiness Consultant (Owner)Commented:
Try the following:

1. Turn HomeGroup OFF

2. On NOTEBOOK, open cmd.exe and type the following:

NET USE Z: \\IPaddressofDESK\folderinquestion.

Does this work?  What error do you get?
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
I entered:

NET Use Z:\\192.168.11.125\F:\junk

The return was "The network name cannot be found"
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
Oh; it also says "System error 67"
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
I also tried it the other way:  NET Use Z:\\192.168.11.108\F:\junk

Same response.

BTW: DESK is wired, NOTEBOOK is wifi.  Router is a Buffalo N-300 running DD-WRT.
0
 
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
This Microsoft Support Article talks about System error 67

http://support.microsoft.com/kb/843156

Try resetting TCP/IP on both machines, restart both and try again. Make sure NIC's are on Work/Private and not Public.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Restart the computer
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
0
 
John HurstBusiness Consultant (Owner)Commented:
Also make sure the Buffalo router firewall is not in the way. Both machines should be specifically permitted if Buffalo is blocking one or both.
0
 
Mike CaldwellDirector of Business Development, AnaquaAuthor Commented:
John, all the flushing, etc, seems to have done the trick.  Many thanks.
0
 
John HurstBusiness Consultant (Owner)Commented:
Mike - Many thanks and I was very happy to help,
0
All Courses

From novice to tech pro — start learning today.