?
Solved

XLS file used as data connection losing data

Posted on 2015-01-09
5
Medium Priority
?
79 Views
Last Modified: 2015-01-09
I have a spreadsheet that is created via an export from Crystal reports.  The xls is fine when I go to open it.  I have another spreadsheet that has a data connection to the exported sheet.  When looking at the data from the connection all data in column o is cleared out except the header.  I have recreated this with several test sheets and can't seem to find the issue.  I am attaching a test sheet and if you create a data connection to that sheet and just bring over all data it will drop the data in column o.
C--Users-timothy.watkins-Desktop-test06.
0
Comment
Question by:notasgoodasyou
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 31

Expert Comment

by:gowflow
ID: 40541232
what is the extension of this file ?? it seems too long name it truncated the extention and have is as text. if xls then shorten the name and reloaded it with the extention.

gowflow
0
 

Author Comment

by:notasgoodasyou
ID: 40541251
Here is the file again.  Don't  know why IE was adding the path to the file name.  thanks
test06.xls
0
 
LVL 31

Accepted Solution

by:
gowflow earned 2000 total points
ID: 40541265
I suspect (and this is just pure estimation) that Col O is the only col where data starts after the 8th row and I fear that the system not seeing any data is giving the field string instead of number ....

Try putting something in row 2 or 3 just sake trial in this column and try it and see if it still whipes out the data.

by the way you should always have in row 2 at least the type of data like if the field is string have A or number integer have 9 or decimal have 9.9 or currency $9.9 etc..
gowflow
0
 

Author Comment

by:notasgoodasyou
ID: 40541331
I had actually tried changing the scan rows in the data connection to no avail.  However your solution to test it with data did work and the data populated.  I have now since found the MS KB article explaining the scan rows setting on the connection is ignored and you have to change the registry setting to bypass it.  I updated the TypeGuessRows DWORD value to 0 and now all data comes through.  Thanks for your help.
0
 
LVL 31

Expert Comment

by:gowflow
ID: 40541355
Your welcome !
gowflow
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Cancel future meetings from user mailboxes in Office 365 using Remove-CalendarEvents
Ever wonder what it's like to get hit by ransomware? "Tom" gives you all the dirty details first-hand – and conveys the hard lessons his company learned in the aftermath.
This Micro Tutorial demonstrates how to create Excel charts: column, area, line, bar, and scatter charts. Formatting tips are provided as well.
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question