Solved

Exchange 2013 SSL Certificates on Multiple CAS and Mailbox Servers

Posted on 2015-01-09
3
92 Views
Last Modified: 2015-07-14
I have 5 Exchange 2013 servers.   2 CAS servers and 3 Mailbox servers installed as DAG.  The CAS servers have my UCC certificate.  One of the CAS servers has the Microsoft Exchange Server Auth certificate.  I am receiving SSL certificate errors from my Mailbox servers stating they cannot find the certificate containing the public name.   This certificate is installed on the CAS servers, but the mailbox servers are sending email to the internet.  I am also receiving errors the the Microsoft Exchange Server Auth certificate cannot be found on all servers but the CAS server it is installed on.  

I am having trouble finding any information on the correct settings in this configuration.  

I am wondering if I should export the Microsoft Exchange Server Auth certificate and the UCC certificate and import the certificate into all of the servers.

Does anyone have a configuration like this that they could confirm the SSL requirements on the mailbox and CAS servers?  What I have found says the mailbox servers SSL is all self-signed and should not need to be altered, but that is not what I am seeing.
0
Comment
Question by:tech301
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 53

Accepted Solution

by:
Will Szymkowski earned 500 total points
ID: 40541503
Certs are pretty strightforward for the most part. Whatever you do "do not remove or modify the self-signed certs" on either the CAS or Mailbox Servers.

- Simply import your cert on all of your CAS servers
- Run the Enable-ExchangeCertificate -Thumbprint <xxxxxxxxxxxxxxxxxx> -Services "pop,imap,smtp,iis" (do this for both servers)
- Ensure that all of your URL's for your virtual directories are correct
- Make sure that your SAN cert has mail.domain.com and autodiscover.domain.com
- Make sure that you have the appropriate External DNS for A record mail.domain.com and CNAME record for autodiscover.domain.com

Will.
0
 

Author Comment

by:tech301
ID: 40547478
Thanks for the reply Will.  I have the UCC cert imported to both CAS server, but I am getting the errors on the Mailbox servers.  I guess I can just import the UCC and the Microsoft Exchange Server Auth certificate to all servers to clear the errors.
0
 

Author Closing Comment

by:tech301
ID: 40881415
Not really the answer I was looking for, but in the end I just exported and imported to the CAS servers.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question