Http requests being redirected to https

I am running windows 7 premium home on my laptop and every time I try to go to a website (http://www.yahoo.com for example), I get redirected to the https: version. This happens on both IE and Firefox. No matter what you type in the address bar it changes to https:. I don't have any security software installed, though I did recently uninstall Norton Internet Security (came with the laptop). Nor do I have any addons installed. Being it happens with multiple browsers, I am thinking it is a windows or registry setting.
LVL 1
exptechAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Yahoo always comes up with 'https' because they redirect you to it.  MSN and CNet do not work with 'https' on my computer and 'microsoft.com' shows errors with 'https' because not all of the elements are loaded with 'https'.  If all sites are loading with 'https', you have a 'proxy' somewhere that is requiring it because some of those sites do not.
0
 
dbruntonConnect With a Mentor Commented:
Try clearing your browser caches.

Also some sites may automatically redirect you from http to https.
0
 
exptechAuthor Commented:
I already tried clearing the caches and setting no history for the address bars. This happens on all websites not just some of them (www.yahoo.com, www.msn.com, www.cnet.com, www.microsoft.com, etc). If fact you can not get to anything else but SSL no matter what you type in the address bar. Another interesting thing that happens is that regardless of the website it also says that their security cert is not correct.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
dbruntonCommented:
Or it is being done by your ISP.
0
 
exptechAuthor Commented:
Dave,

I go to http://www.yahoo.com multiple times a day on multiple computers I have and this is the only one where the http:// protocol is being replaced by the https: protocol. This is happening ONLY on 1 of many systems I own. The MSN and Cnet addresses where just examples of what I meant by all websites, not meant to be literal. The point is that no matter what you type in the address bar the http:// will always be replaced by https://, which I do not want. I am not looking for the SSL or TLS protocols just the http:. More than likely this is a local security or group policy setting that I am not aware of or there is an LSP in the LSP chain that is changing it. I am not sure if NIS (Norton) inserts one and it did not get removed when I uninstalled it. I never use NIS. I was hoping that it was just a setting or a reg entry, but I think if that were the case I would have received more responses already.  Hopefully I will get one, but in the meantime I am going to have to analyze the LSP chain.
0
 
exptechAuthor Commented:
I've requested that this question be deleted for the following reason:

Solved it myself. Thanks for trying guys.
0
 
dbruntonCommented:
Questioner did not supply the solution.

If there is a solution provide then I have no objection.
0
 
Dave BaldwinFixer of ProblemsCommented:
My Yahoo links on my web site are all with 'http'.  And in Every browser (IE, Firefox, Chrome, Safari, and Opera)  it is Always redirected to 'https' by the Yahoo servers.  It has nothing to do with your computer.  And for Yahoo, it is not your choice.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.