Certain Excel commands have been greyed out

I inherited several excel documents that I need to work on.  While I am able to modify cells, I am unable to insert and delete rows, format cells, change height, column width, etc. etc.

I am using an administrative account, and the file / directory ownership includes Everyone with Full Access.

Finally, the document itself appears to be shared (it says it in the title bar).  I tried unsharing the workbook as well as un-grouping the sheets, but neither worked.
RobertSystems AdministratorAsked:
Who is Participating?
Wayne Taylor (webtubbs)Connect With a Mentor Commented:
Sounds like it's been protected. Go to View > Unprotect Sheet and/or Unprotect Workbook. You may need a password.
JohnBusiness Consultant (Owner)Commented:
For a problem worksheet, are you able to open it, copy it (formulas and data) into a completely new workbook, save it as a new name, does the result work?
RobertSystems AdministratorAuthor Commented:
@John Hurst - I opened a workbook with 4 sheets, and created a new Sheet2.  Copying the data from Sheet1 -> Sheet2 in the same workbook works.  However, I am unable to delete the Sheet2.

@Wayne Taylor - The sheet does not appear to be protected.  I clicked the Review tab.  The "Protect Sheet" is greyed out, the "Protect Workbook" is accessible as well as the "Share Workbook".  I am unable to locate an Unprotect sheet or Unprotect Workbook.
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

JohnBusiness Consultant (Owner)Commented:
Try copying the information from just one sheet to a brand new workbook..   For the one sheet, does it work properly?
RobertSystems AdministratorAuthor Commented:
@John Hurst - Copying the data into a new workbook appears to resolve the issue.  However, I have about 50 excel documents, each containing multiple sheets.  On top of that, the documents are shared, which means copying the data to a new workbook would lose all of the tracked changes.  Is there a way to remove the restrictions in the current file?  If the document was restricted or protected using a copy of Office 2010, is it still possible to rectify it using a copy of Office 2007?
Seth SimmonsConnect With a Mentor Sr. Systems AdministratorCommented:
that was going to be my question...are the documents shared
this causes certain functions to not be available; found out the hard way before

Features that are unavailable in shared workbooks
RobertSystems AdministratorAuthor Commented:
@Seth - Even when I unshared the workbook, the greyed out function did not return.  Even the [Shared] in the title bar was gone.  Additionally, according to the URL that you included, adding/removing rows and columns should still be available whether the document is shared or not.

*Update* - It looks as though the Sheets are protected.  When I click on the Review tab, there is a button called "Unprotect Sheet".  However, that button is greyed out, and I am unable to remove the protection.  When I click on Protect Workbook, a drop down menu appears.  Under Restrict Editing, Protect Structure and Windows is greyed out.  Under Restrict Permission, there's a check mark next to "Unrestricted Access"

So it looks like the Workbook is also partially protected, but I don't know how to remove those features.
JohnBusiness Consultant (Owner)Commented:
If you cannot unshare or otherwise fix these worksheets, you are probably going to have to do it manually.

How could 50 sheets be secured without you knowing?  Does not someone else know what happened?
Rob HensonFinance AnalystCommented:
The Shared Workbook feature is renowned for causing problems, most threads on EE recommend not using it because of the issues it causes.

Sounds like the files may have become corrupt by the Sharing feature, even if you have switched it off.

Rob H
RobertSystems AdministratorAuthor Commented:
I was able to resolve the problem.  Here's what I did:

Open the document in Excel

Click the Review Tab

If the "Unprotect Sheet" exists but is greyed out
      Click the Share Workbook button
      Uncheck "Allow changes by more than one user at a time" && click OK
      The "Unprotect Sheet" button should no longer be greyed out

Click the "Unprotect Sheet"
Enter the password and click OK
The "Unprotect Sheet" button should now change to "Protect Sheet"

If the "Unprotect Workbook" exists, Click the "Unprotect Workbook"
Enter the password and click OK
The "Unprotect Workbook" button should now change to "Protect Workbook"

Lastly, Click the Share Workbook button again
Check "Allow changes by more than one user at a time"
Click OK

Close the document
RobertSystems AdministratorAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 500 points for Wayne Taylor's comment #a40543517
Assisted answer: 0 points for rdege's comment #a40546968

for the following reason:

As stated above, sharing the document disables certain functionality.  This appears to include adding/removing password protection.

In order to remove sheet protect, you first need to un-share the document, which in turn restores this functionality.  Then you can remove the password protection, and re-share the document
Seth SimmonsSr. Systems AdministratorCommented:
I asked you before if the document was shared because some functionality was not available which you discovered when you couldn't remove protection.  I gave you half the answer (sharing), Wayne gave the other half (protected sheet).
Seth SimmonsSr. Systems AdministratorCommented:
points should be split evenly between wayne and myself considering both our comments contributed to the author's conclusion
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.