Solved

Cannot start published app after server renaming  - citrix 6.5

Posted on 2015-01-11
9
765 Views
Last Modified: 2015-01-20
Hi guys, I'm having a damn hard time figuring out what can be wrong with my xenapp farm.
I have 2 farm PSfarm (Win 2k3 Presentation Server 4.5) and XENfarm (Win 2k8-Xenapp 6.5)
The XENfarm should replace PSfarm soon but after some requests during the project I'm having a great headache troubleshooting it... Lets get to it:
I have deployed a farm whose servers used to work fine providing access to all applications I installed and published. Everything ran smootlhy according to plan.
In the last minute I was asked to change the servers hostnames and ips, since the servers are no longer going to be hosted at site A. They now will go to site B hence, ips and hostnames have to

follow.
After changing the ip and hostname I'm no longer able to lunch any application. I can open web interface, but when I click at any published app the "loading icon" shows up and nothing else

happens.

Details:
Xenapp ver 6.5

Roles
srv-64 - Webinterface
srv-65 - xenapp
srv-66 - xenapp

Hotfixes:
XA650W2K8R2X64R04
KB2728738
KB2748302
KB2778831
KB2896256

All servers run under VMware platform.

When I use Citrix Quick Launch tool, I get the error:
Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp server.
As opposed to "XENfarm" the tool works fine when connecting to "PSfarm".

Here's what I have tried to do.
Set up the network card at ICA's protocol properties through Ica "Listener Configuration". Failed
At "Connections" in "Remote Desktop Session Host Configuration" I couldn't change the NIC card. When I do so the following error message is displayed:
Remote Desktop Session Host Configuration tool is not able to obtain the properties for this connection. The connection has either been deleted or the internal state of this connection has been

corrupted. Please close all property pages, and select refresh from the menu.

On srv-64(WI) I can telnet ports 2512, 2513, 2598, 8080 and 27000 on both servers properly.
When I run qfarm /load I get load 100 for both servers.

Anyone has a clue?
0
Comment
Question by:miltonskt
9 Comments
 
LVL 25

Expert Comment

by:Sekar Chinnakannu
ID: 40543610
after changing the hostname\ipaddress all the DN settings are correct right? can you tryed to disjoin and rejoin the server to farm? If not you can try by disjoin and rejoin the server to farm. Also make sure all the citrix servers are in running state
0
 

Author Comment

by:miltonskt
ID: 40544046
Hi Sekar, thanks for your reply.
You meant dns settings by saying "All DN settings"? If so, Yes. I could telnet from srv-64(WI) to the servers by their names!  I have also disjoined, rejoined and with no success...
Events 21002 and 31003 source Citrix Web Interface are being logged on srv-64(WI). No relevant logs on srv-65 and srv-66
0
 
LVL 25

Expert Comment

by:Sekar Chinnakannu
ID: 40544186
is this server is a data collector? Make sure no apps are causing the issue. In our case application caused the issue we removed the same from server to fix the issue. reference http://www.experts-exchange.com/Software/System_Utilities/Remote_Access/Citrix/Q_28258848.html
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 13

Expert Comment

by:Mark Galvin
ID: 40544310
Have you made the relevant changes to the sites in the WI for the XENfarm. As you have not made any change to IP/Hostname on the PSfarm I would expect that to work fine (and you say it does).
0
 

Author Comment

by:miltonskt
ID: 40546283
Sekar, yes the server is the data colector. I published notepad to make sure it wasn´t related to applications, no success.

Hi Mark, since I had lots of problems not long ago regarding name resolution I chose for using ip rather than hostnames. at WI and Licence server. So yes, WI points to valid XenApp servers.

Although I´m really agaist it (reinstall as opposed to troubleshooting it) I tried to revert  (using snapshot along a data store restore) servers to the last-functional version but it didn´t work. I´m running out of time and ideas :-( ... help is really appreciated
0
 
LVL 19

Expert Comment

by:compdigit44
ID: 40547876
The following article from Citrix discusses how to rename a XenApp server.

http://support.citrix.com/proddocs/topic/xenapp5fp-w2k8/ps-renaming-servers.html

Please let us know how you make out.
0
 

Author Comment

by:miltonskt
ID: 40549406
Hi compdigit44 thanks for your help. I did follow this content,
I´ll try to recall the attemps I´ve done, so far, to rename the servers:

1     - Added the new "A" records to DNS. (our DNS is not integrated to AD)
1.2   - From Xenapp, Removed from all published applications the servers I wanted to rename.
1.3   - Removed load evaluators

3     - On ctx-65:
3.1   - ran chglogon /disable
3.2   - stopped Citrix Independent Management Architecture service
3.3   - Changed "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\IMA\RUNTIME\PSRequired" registry value to 1
3.4   - Renamed (from ctx-65 to srv-65), changed its ip/mask/gateway and restarted the server.

4     - On ctx-66
4.1   - Removed CTX-65 from the farm.
4.2   - Set SRV-65 preference to "Most Preferred"

5     - On ctx-64 (Webinterface) changed the servers ip address at "server farms"
5.1   - Restarted server ctx-64.

6.    - Opened XennApp, chose any given app, published onto srv-65.
6.1   - published notepad onto srv-65.

Logged on fine, tried to open mentioned applications, failed.

-------------------------------------------------------------------------------------

2nd attemp (snapshot reverted, database restored)

1     - DNS Records already updated.
2.    - Joined the server (ctx-65) back to domain, restarted it.
3     - Set up ctx-66 to "most prefered"
4.1   - On ctx-65 through xenapp media, chose "Remove this server from the farm"
4.2   - Removed ctx-65 from the zone.
5     - Renamed server (from ctx-65 to srv-65)
6.1   - On ctx-65 through xenapp media, joined server to existing farm, zone etc, restarted server.
6.2   - Opened xenapp, Set up srv-65 to "most prefered", chose any given app, published onto srv-65, published notepad onto srv-65.


Logged on fine, tried to open mentioned applications, failed.
0
 

Accepted Solution

by:
miltonskt earned 0 total points
ID: 40549700
Hi guys, I finally figured out what was going on.
Something happenned that "corrupted" BOTH web interface AND published applications.
I had to recreate the WI site again at srv-64 AND* publish applications from scratch. Duplicating created applications also worked (just when accessing from the new WI site) but only their copy will work afterwards!!
I tried both separatelly and they didn´t work. Just when I did for both, it worked. I´m going to restabilish all the environment, put everything to work and then tomorrow I´m renaming and moving them again. Honestly I´m kinda afraid to struggle with another awckward issue so I would like to know your guys suggestion regarding the renaming process. Would you guys have done it differently? Appreciate everybody´s attention!
0
 

Author Closing Comment

by:miltonskt
ID: 40559325
The experts provided a great quality of content that were pertinent to the issue I have faced but they didn´t solve my problem directly.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question