Solved

Windows Remote desktop suddenly stopped allowing connections

Posted on 2015-01-12
9
81 Views
Last Modified: 2015-03-11
Say, we are running Windows2008 server R2 and with no known reason, remote desktop stopped working. I rebooted the server and this did not help. I disabled the Public firewall and remote desktop was able to connect again.

What ports do I need to allow and what could have caused this? No changes were made to Firewall by ourselves.
0
Comment
Question by:shaunwingin
  • 5
  • 3
9 Comments
 
LVL 10

Expert Comment

by:aboo_s
ID: 40543912
port 3389
You need to check that there is no rule on firewall to stop the application it's self from communicating outside the network.
You could first set up the port and try it out, if it doesn't work then you keep on debugging.
As for what caused it, well it could be anything really. Upgrade, accidental reset, virus ..whatever! Maybe too many tries to hack into the system through this port triggered some protection machanism or something.
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 40543917
First check if the particular firewall rule for Remote Desktop is enabled. If yes, sometimes it helps to uncheck and rechecked the rule.
0
 

Author Comment

by:shaunwingin
ID: 40543920
Was most likely this
Maybe too many tries to hack into the system through this port triggered some protection machanism or something.
tx
0
 

Author Comment

by:shaunwingin
ID: 40544037
Say, Cyberarms seems to be the culprit - but showing no current locks.
What can I do?

What is the name of the Remote Desktop .exe to add entire application to firewall?
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 68

Expert Comment

by:Qlemo
ID: 40544137
It is part of the service host: C:\Windows\System32\svchost.exe -k NetworkService
0
 

Author Comment

by:shaunwingin
ID: 40544293
Remote Desktop (TCP-In) created by System allows port 3389. Disabled and enabled - same issue persists.
0
 
LVL 68

Accepted Solution

by:
Qlemo earned 500 total points
ID: 40544311
Windows Firewall or Cyberarms?
0
 

Author Comment

by:shaunwingin
ID: 40544320
Windows Firewall

I've also noticed a 2nd Program is not getting access - seems more generalized issue.
0
 

Author Closing Comment

by:shaunwingin
ID: 40659401
uninstalled Cyberarms and resolved
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you migrate a Terminal Server licenses server inside the 2008 server family, you can takte advantage of the build-in migration tool. If you like to migrate an older 2003 Server (and the installed client CALs) to a 2008 R2 server for example, you …
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now