Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

USB drive from another windows server backup is inaccessable on a new server

Posted on 2015-01-12
9
Medium Priority
?
251 Views
Last Modified: 2015-01-13
Just pulled a Vantec 2Tb USB drive off the shelf to use for a backup drive on a physical server.  Its' previous application was as a Windows Server Backup drive on a Windows 2008R2 server.  The new application is also 2008R2.  The drive was not "decommissioned" after the backups on the old server were no longer relevant.  That server got virtualized.

When I run Windows Server Backup, the USB drive does not show under available targets for my backup.

The USB drive shows up in File Manager, but prompted me to format before it could be used.  I did a quick format - show Properties comes back with the full drive capacity unused, Security shows full control for SYSTEM and Administrators, but I notice no rights are selected for Owner/Creator and access is denied when I attempt to edit logged in as Administrator.

A couple things that shouldn't matter.  I say the drive is inaccessible on a new server.  Turns out that it's actually the same physical server.  It is, however, a clean installation of Windows Server 2008R2, different host name and different roles.  The USB 3.0 drive is connected with a 2.0 cable.  The 3.0 cable appears to be have been misplaced.  I think the only penalty here is speed.

Thanks,
Wayne
0
Comment
Question by:HerrBall
  • 5
  • 4
9 Comments
 
LVL 47

Accepted Solution

by:
noxcho earned 2000 total points
ID: 40544504
Connect the drive - go to Windows Disk Management (right click on My Computer - Manage - Disk Management).
Delete the current partition from this drive.
Then right click on the free space - create new partition. Follow the wizard and select NTFS - quick format.
After that see if you can use the drive for backup.
0
 

Author Comment

by:HerrBall
ID: 40544781
OK I follow up to the point where I have Disk Management screen up.  The top "Volume List" does not show this device.  It does show up in the lower "Graphical View" as Basic and Online.  Delete Partition is not an option I see, but Delete Volume is, as well as Mark Partition Active.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40544892
Take a screenshot of Windows Disk Management and post it here. Looks like the drive is dynamic somehow. That could explain why you cannot select it for backup.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Closing Comment

by:HerrBall
ID: 40545370
Delete Volume gives me the desired result.  Thanks
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40545472
You are welcome. Thanks for feedback and take care.
0
 

Author Comment

by:HerrBall
ID: 40545487
Guess I didn't refresh before I accepted the solution...  I didn't notice your request for a screen shot.

After deleting the volume and creating a new volume and doing a quick format, this disk, as F: showed up in both views in Disk Management (instead of just the Graphical View).    It still shows as Simple/Basic/NTFS.

As it turns out, there is still an issue.  Now I have more failure modes.  Depends on how I configure Server Backup.  If I Schedule Backup, it all looks normal, except perhaps where I pick the target hard drive.  The USB drive shows as Disk4 and when I ask for additional details, it does not include volume F:  I select Disk4 and get the warning that the target disk is to be formatted.   A few minutes later, I got an error telling me the format failed.  I tried this a second time and the MMC snap-in unloaded after a "non-valid operation."
When I Backup Once, the F: still does not appear at the point I select a target for the backup.
Disk-Management.rtf
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40546129
Is the drive new and functioning well when you use it in Windows for data only?
Does it have its own power supply?
0
 

Author Comment

by:HerrBall
ID: 40547211
I tried a second external USB device - same issues.  After deleting the existing volume and creating/formatting a new one (both had been used for Windows Server Backup), they both worked fine with file copy/paste/open/delete operations.  The first device had an external power supply, the second did not.

FYI, looking for issues in Device Manager, I found that there was no driver for the add-in USB 3.0 card installed in this server.  Any successful connection has been through USB2.0  ports.  Am looking for that driver.  Would certainly rather have this using USB3.0.

I'm getting close to just installing an agent on this physical server and backing it up with my VM environment...  This is a temporary server and didn't see an advantage in doing that initially.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40547828
Thats correct. Windows Server Backup is not perfect and should be used if third backup tool is a no go only.
Anyway with USB2.0 and external power supply it shoud work. As an example you can try taking backup to network share or internal drive. Maybe proble is in WSB and not in HDD.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
Each year, investment in cloud platforms grows more than 20% (https://www.immun.io/hubfs/Immunio_2016/Content/Marketing/Cloud-Security-Report-2016.pdf?submissionGuid=a8d80a00-6fee-4b85-81db-a4e28f681762) as an increasing number of companies begin to…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question