Solved

group policy document redirect

Posted on 2015-01-12
5
38 Views
Last Modified: 2015-06-30
When I setup a group policy to redirect documents it shows: \\Server\Department\%username%\documents.  Is there a way to have it redirect to "My Documents" instead of "Documents" so it looks like: \\Server\Department\%username%\My Documents?  This was possible in Server 2003 but cannot get it to work in Server 2008R2.

When I try to put the above information in, I get an error about path being wrong.  I need it setup for My Documents because a couple of our programs are looking for the "My Documents" directory instead of "Documents".

Thanks for any help.
0
Comment
Question by:amforem
  • 2
5 Comments
 

Author Comment

by:amforem
ID: 40545026
I might have a fix but want to confirm.  I had already setup a Group Policy that was setup as follows:

Target Folder Location: Create a folder for each user under the root path
Root Path: \\Server\Department\

That had created on the server the %username%\Documents directory.   What I am thinking now is go back into the Group Policy and changing to:

Target Folder Location: Redirect to the following location
Root Path: \\Server\Department\%username%\My Documents

For future users in this department I will have to manually setup up Department their username\My Documents directory with the applicable permissions.   It will be some extra steps but will be easier than have the users trying to fix program locations.

If someone has a better suggestion, let me know.

Thanks
0
 
LVL 24

Accepted Solution

by:
VB ITS earned 500 total points
ID: 40546050
The Redirect to the following location setting is the correct setting for what you want to achieve.

You're also correct in that you will have to create the username\My Documents folder manually as the redirection method you have chosen requires the folder to exist first, whereas the original setting you chose would have auto-created the "Documents" folder.

You could look at using a script to create the user accounts, create their username\My Documents folder, and thenapply the required permissions to the folder.

Is this for Windows XP or Windows 7 workstations?
0
 

Author Comment

by:amforem
ID: 40546528
It is for Windows7 and Windows 8 workstations.  I was able to confirm that the solution I found did work.   I would have tried a script if I knew how to build scripts.  :)

Thanks for your help
0
 
LVL 34

Expert Comment

by:Seth Simmons
ID: 40859099
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question