Solved

Connect Remote Desktop with Windows 7 client, Windows 8.1 Pro as host?

Posted on 2015-01-12
34
169 Views
Last Modified: 2016-10-27
Trying to do RDS between my desk PC and a notebook on the same LAN.  DESK is Windows 7 Home Premium, NOTEBOOK is Windows 8.1 Pro.  My understanding is that Win 7 HP cannot be remotely controlled, but can connect to another machine that can be.  Windows 8.1 Pro allows incoming RDS and it is enabled under System.  When I launch RDS from DESK it times out.
0
Comment
Question by:Mike Caldwell
  • 18
  • 10
  • 2
  • +3
34 Comments
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545671
In Computer, Properties, Advanced System Properties, Remote Tab, is "Allow connections to this computer enabled?  (DESK computer).
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545680
Is it was, though not sure why if Home Premium cannot be remotely controlled, or perhaps that is only limiting controlled from outside my LAN?  But both are set this way.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545684
Just to be clear: I want to control NOTEBOOK from DESK.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545685
Try connecting to DESK by IP address (enter the IP address of DESK into remote desktop connection). See if that allows you to connect.

Same the other way.
0
 
LVL 53

Expert Comment

by:McKnife
ID: 40545689
If the connection times out, the port (rdp uses port 3389) cannot be reached. So there's a firewall blocking it.
->install telnet as a windows feature on win7, then enter the command
telnet notebook 3389
and see whether the screen goes black (which means it can connect). if it doesn't, you have found your problem.
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 40545694
Make sure the Notebook has a username and password, this is required for Remote desktop.

Also try turning off the firewall to verify it's not blocking the connection for some odd reason.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545699
DESK to NOTEBOOK: no change

NOTEBOOK:  cannot find the utility for RDS.  I find RemoteApp and Deskstop Connections, but it is looking for an email or URL.  When I put in the IP address for DESK it rejected it saying it was an invalid email address.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545711
Enabled telnet client & server on both machines.  No change.  Ran telnet MIKE8 3389 and telnet 19.168.11.147 3389; both reported "Connecting", then vanished.  Firewall off during all of this.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545713
On NOTEBOOK, type Win+R  mstsc,exe and launch Remote Desktop that way.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545719
NOTEBOOK will not connect to DESK.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545724
On NOTEBOOK, in Remote Desktop, enter the IP address (only) of DESK.

Does this connect?  If no, the firewall must be in the way.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545733
Both firewalls are off.  I have always used both name and IP address in attempts to connect.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545746
On DESK, open cmd.exe and type NET USE Z: \\ipaddressofNOTEBOOK\folder and enter.

What answer do you get?
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545754
Search not found, and a window for DESK, not NOTEBOOK.
0
 
LVL 87

Expert Comment

by:rindi
ID: 40545761
On the Desktop you are connecting to, (not the notebook as mentioned earlier) the user you are connecting to must have a password. But of course also any user on any PC should always be password protected.

Then, on the host (desktop PC), also add the user accounts to the remote desktop users (right click "This PC", select "Properties", click on the "Remote Settings", and then you can add those user accounts you need.

Also as already mentioned, add the remote desktop rules to the allowed exceptions of the PC's firewall. Remember that many AV utilities include a firewall, so maybe you have done that for the windows built-in one, and not the AV one. As the Windows Built-in firewall is already more than adequate, I suggest only to use that firewall and disable the one of your AV tool.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545793
Rindi: the only direction I am interested in is connecting to the Windows 8.1 Pro NOTEBOOK from the Windows 7 Home Premium DESK.  Both firewalls are already off, both have names and passwords.  Not sure about user accounts; I'll check on that.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545794
BTW: I can connect just fine with VNC / TIghtVNC, just that it does not support sound from the server to come through the client.
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545804
Rindi: I am the only user of both machines.  This is a home network, and I work from home.  I do have two accounts defined on DESK with unique names and each has a password and are administrator type.  But Windows 8.1 wants changes to all go through Microsoft, which is really irritating.  The issue would be that I only have one uSoft account.  Not sure what to do re: NOTEBOOK.

BTW: I had Norton 360 on both machines and uninstalled on both.  I don't know how to strip these machines down any further.
0
 
LVL 87

Expert Comment

by:rindi
ID: 40545808
I thought the desktop was the one with the pro version of windows. As I mentioned you need to add theuser account to the remote desktop group. I explained how that is done above (you can also enable/disable remote desktop there, and change the authentication level, maybe you could try the lower security version first, without the checkbox enabled).
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545812
Both machines have both user accounts.  Both have RDS enabled.  They are user accounts; is there some sort of different "remote desktop group"?
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40545817
OK, found users under RDS.  Account is there.  Also, UAC is turned off on NOTEBOOK.  Still cannot connect.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40545843
Search not found, and a window for DESK, not NOTEBOOK

This is NOT an answer for NET USE.

Also, are you sure you are using Remote Desktop   mstsc.exe  What window do you get ?  Post a screenshot please.
0
 

Expert Comment

by:jamesl001
ID: 40545931
This is a longer post. However, to sum it up. The Host PC (the one that you are connecting to) must be on (not asleep, hibernating or turned off) Stay logged on with your user account. For example, if the notebook if 192.168.1.x and then open up remote desktop and type in 192.168.1.x for the computer name. The Windows firewall and any other third party firewall (such as the norton 360 firewall) needs to either allow port 3389 or turned off. When asked for the username and password when you connect from the desktop, type in the username and password for the laptop. (the laptop username MUST have a password in order for RDP to work.) From that point you should be connected.

If you are connecting to the laptop from outside the network you will need to use the public IP address of the router that provides the internet connection for the computer name to connect from the desktop. You will need to set up the laptop with a staic IP in order to perform port forwarding to the laptop from the router. You will need to forward port 3389 from the router to the internal host of the IP address of the static IP of the laptop that you have configured the laptop to use.

From this point remote connections will work from outside of the local network when you are remote to the machine to which you are connecting. If you do not have a static list then you will need to set up a Dynamic URL to connect to. But that is another discussion.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40546026
This is strictly within my LAN.  Both PCs have user names and passwords.  When I launch RDS I do not get a request for a user name or PW, but I do put the user name under the "Options" tab.  I get the error that DESK cannot connect with NOTEBOOK before I am asked for a PW.

And of course NOTEBOOK is on, etc.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40546029
John, as you can see, it was treated as a search, not a connection.  CMD line is in upper right hand corner.
DESK-Screenshot.jpg
0
 

Expert Comment

by:jamesl001
ID: 40546363
Can you connect to Notebook by IP address. If so then you may have a DNS resolution problem. If the firewalls are all turned off then you should also be able to ping NOTEBOOK. Also, if you are connecting wireless make certain that you do not have client isolation turned on. If client isolation is turned on then the WIFi will stop the clients from connecting to each other.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40546452
Going back to an earlier post, open a command prompt on DESK and type:

 NET USE Z: \\IPaddressofNOTEBOOK\folder

Please let us know the actual error.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40546580
James: please read all the posts first.  I always try both name and address.  And both machines are wired.

John: there is no error message.  The system waits about ten seconds, then the screen I posted pops up.

I can ping NOTEBOOK successfully.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40546588
Something is strange in your system.

If you open a command window (black text window) and leave it open, no screen will pop up when you type NET USE.  It will tell you in text whether you connected successfully or not.

I went back and looked at your screen shot above and you are not opening a command window.

On DESK (Windows 7) in the Start Button, type cmd.exe and click on cmd.exe. A black window opens. Please confirm.

Now in the black window, type NET USE Z: \\IPaddressofNOTEBOOK\folder.   What text error do you get?

I am asking you to do this to test your system. Remote Desktop is not connecting and we know that.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40547630
Ah; you are right, I was typing the instruction into the screen line, not getting CMD first.  I'll give that a go right now.

Got System error 67, network name could not be found

even though I used the IP address.

Thanks for sticking with me John.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40547633
Just checked, and PING to that address is fine, under 1 ms.
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 500 total points
ID: 40547650
System Error 67 says not connected and now we know, this is why Remote Desktop does not work.

Here is a Microsoft Support article on Error 67. It is geared to servers, but notice the section on network cards.

Before reinstalling drivers, you could reset TCP/IP on both machines.

Open cmd.exe with Run as Administrator  <-- Make sure you do this correctly
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache

Now restart both computers and test.

Upon restart, look in Advanced Network Sharing (Control Panel) and make sure network cards on both machines are attached to Work/Private and NOT Public. Make sure Network Discovery is ON and make sure File and Print Sharing is ON.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 40547984
John, you may remember that about two weeks ago you had me do this same thing because I could not sync these same two machines with a sync utility (BTW: I switched to the one your recommended, and like it a lot more).  But when I did it and restarted, the NOTEBOOK totally crapped out.  Toshiba threw up a message that the PC would not start, and would not repair.  I finally got an Acronis True Image file to rebuild it, but decided to just use the notebook as a travel backup.  So I did the same thing today, with same result.  So I am going to send this new notebook to Toshiba to repair (takes about three weeks) and when I get it back, sell it,  Meanwhile I'm going to go buy a new notebook and it sure won't be a Toshiba.  I have always had good luck with Sonys and Acer; I hate everything HP makes and will never by anything HP again.  So I assume this fix would have worked if the darned thing didn't blow up, but for now this subject is done.  Thanks for your persistence.

Mike
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40547995
Mike - Yes, I do remember. Thanks for the update and good luck with a new computer.  I was very happy to help.
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
A Short Story about the Best File Recovery Software – Acronis True Image 2017
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now