Solved

Exchange 2013 Repair

Posted on 2015-01-13
4
89 Views
Last Modified: 2015-01-15
Hi Everyone

My Exchange 2013 server did crashed and I did reset the computer from AD and created a new VM to install Exchange 2013. When running the following command Setup /m:RecoverServer /IAcceptExchangeServerLicenseTerms it comes up with the following error.

while($currTime -le $timeout)
          {
            $setSharedCDCErrors = @();
            try
            {
              Set-SharedConfigDC -DomainController $RoleDomainController -ErrorVariable setSharedCDCErrors -ErrorAction SilentlyContinue;
              $successfullySetConfigDC = ($setSharedCDCErrors.Count -eq 0);

              if($successfullySetConfigDC)
              {
                break;
              }
              Write-ExchangeSetupLog -Info ("An error ocurred while setting shared config DC. Error: " + $setSharedCDCErrors[0]);
            }
            catch
            {
              Write-ExchangeSetupLog -Info ("An exception ocurred while setting shared config DC. Exception: " + $_.Exception.Message);
            }

            Write-ExchangeSetupLog -Info ("Waiting 30 seconds before attempting again.");
            Start-Sleep -Seconds 30;
            $currTime = Get-Date;
          }

          if( -not $successfullySetConfigDC)
          {
            Write-ExchangeSetupLog -Error "Unable to set shared config DC.";

Not sure what to do ,did read about IP v 6 but on my VM its already enabled.

Thanks
SD
0
Comment
Question by:Dirkie Laubscher
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 20

Accepted Solution

by:
Satya Pathak earned 500 total points
ID: 40546646
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40547060
Was the old machine a domain controller or a member server?

Simon.
0
 

Author Comment

by:Dirkie Laubscher
ID: 40548427
Hi Simon it was only a member server
0
 

Author Comment

by:Dirkie Laubscher
ID: 40548753
Did try article above but still no luck ,please help nothing wrong with audit policy
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video discusses moving either the default database or any database to a new volume.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question