Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 281
  • Last Modified:

help with SQL server name

I am in the process of learning how to set up high availability RDS server on MS Server 2013.

I am using this as a guide https://msfreaks.wordpress.com/2013/12/09/windows-2012-r2-remote-desktop-services-part-1/comment-page-2/#comment-2134

I’m getting stuck when specifying the connection string details. To make things easy I have used the same server names as the author

It specifies :

DRIVER=SQL Server Native Client 11.0;SERVER=ITWDC01;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;DATABASE=ITWRDCB

Where does the Database=ITWRDCB come from? I get an error that it cant find it when trying to apply these settings.

During the sql setup I specified “default” as was suggested, but what is the actual name in this case.

Any suggestions?
0
roy_batty
Asked:
roy_batty
  • 9
  • 6
  • 3
  • +1
2 Solutions
 
Haris DjulicCommented:
Hi,

it is name of your database , you can check it like this:

select @@servername  

Open in new window

0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
That connection string only works if you have the same SQL Server version, machine name and database name.

DRIVER=SQL Server Native Client 11.0 --> This driver allows connections to SQL Server 2012 & 2014
SERVER=ITWDC01 --> The server name where SQL Server is installed
Trusted_Connection=Yes --> Means that will use the current user credentials to connect to the database. Be sure that your user has access to SQL Server and permissions is the database
APP=Remote Desktop Services Connection Broker --> Informational only. Can be removed
DATABASE=ITWRDCB --> The database name. Change to your database name
0
 
roy_battyAuthor Commented:
OK that is the name of the server. I have already tried that in the connection string and it says in cant connect to the sql database.

I can ping the server using its hostname.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Haris DjulicCommented:
Hi,

is the MS SQL port allowed on your Windows Server Firewall?
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Check the SQL Server version and if you user has permissions on the database.
0
 
roy_battyAuthor Commented:
I have configured the firewall to allow the sqlservr.exe but I have just completely disabled the firewall on the SQL Server and that didnt help either.

I am logged into the server as the domain administrator.

I am using the Express version of SQL. How do I find the exact version?

Also how do I check that I have permission?
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Ok, being a SQL Server Express the default instance name should be SQLEXPRESS so change the server name in the connection string to SERVER=ITWDC01\SQLEXPRESS.
0
 
roy_battyAuthor Commented:
I'm still getting the same error. The exact error I'm getting s below:

the database specified in the database connection string is not available from the RD connection Broker Server.

The connection string I have used now has :

SERVER=ITWDC01\SQLEXPRESS

Database = SQLEXPRESS
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Don't change the database name. Only the server, that is the SQL Server instance name. Database should be ITWRDCB.
0
 
roy_battyAuthor Commented:
I think you mean ITWDC01.

Well I tried it as below and that doesnt work.

DRIVER=SQL Server Native Client 11.0;SERVER=ITWDC01\SQLEXPRESS;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;DATABASE=ITWDC01

Is it a permissions issue?
0
 
David Johnson, CD, MVPOwnerCommented:
open the sql configuration managerClient Protcols TCPIP must be enabledEnable set to yes using the drop down and restart the sql server instance
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
I think you mean ITWDC01.
No. I really mean DATABASE=ITWRDCB

DRIVER=SQL Server Native Client 11.0;SERVER=ITWDC01\SQLEXPRESS;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;DATABASE=ITWRDCB
0
 
roy_battyAuthor Commented:
In the end it wasn't anything to do with the database name.

Run the SQL configuration tool and enable IP not using dynamic ports in SQL network configuration.
0
 
roy_battyAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for roy_batty's comment #a40555624

for the following reason:

Expert got close but didn't mention the particular area that needed amending. I would like to offer points for helping but I have accepted my own solution.
0
 
David Johnson, CD, MVPOwnerCommented:
Isn't this what I said in http:#a40547934
0
 
roy_battyAuthor Commented:
Not exactly no, but I appreciate it was fairly close and feel you deserve points here but didn't want it marked as the final answer
0
 
David Johnson, CD, MVPOwnerCommented:
should get points for the assist
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
So you ended up with the initial connection string?
DRIVER=SQL Server Native Client 11.0;SERVER=ITWDC01;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;DATABASE=ITWRDCB
0
 
roy_battyAuthor Commented:
Yes
0
 
roy_battyAuthor Commented:
Thanks for the help David and sorry for the points confusion. I know for the future. :)
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 9
  • 6
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now