Windows Server 2008 R2 Hyper-V

I have 2 physical NICs on a physical server.
All works well, one NICs is for internal network, the other NIC is for internet access.
NIC2 I can access the web, and  NIC1 is strictly internal.

This is on a test VLAN.

I installed Hyper-V on this server, Windows Server 2008 R2.

Created a VM, and added the two NICs:  one internal and one external.
Internal works fine, but the external keeps getting the default DHCP IP address.
The external is supposed to get the IP address from the router/switch.

I cannot get this thing to work, the external NIC.  These are the settings from the VM.
I cannot get the External NIC to work.

Can anyone help me.

NIC1
techgeniousAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Philip ElderConnect With a Mentor Technical Architect - HA/Compute/StorageCommented:
In the properties window above rename the vSwitches as I indicated.

Close that properties window and right click on the VM in question and Properties.

Under its Networking section you can then change the vSwitch each vNIC is connected with to change the network shown _within_ the VM.

I hope that clarifies things a bit better?
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Your vNICs are bound backwards.

That is, your vNIC that is to pull a public IP is connected to your Private vSwitch. The vNIC for your External is actually connected to the Private vSwitch.

Reverse them in the VM's Network properties in Hyper-V Management and all should be okay.
0
 
techgeniousAuthor Commented:
I am confused can you explain, keep in mind I am really new to Hyper-V, I am in Virtual Network Manager
Here is the settings or am I in the wrong place

NIC Settings
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
In the above snips rename them as follows:
vSwitch - Internal
vSwitch - External

Once that is done bring up the properties for the VM itself and change each vNIC's vSwitch association. That is, reverse them so that current Internal becomes External and the current External becomes Internal.

Once you do that your VM will have the "correct" network setup you are looking for.
0
 
techgeniousAuthor Commented:
The picture above is on the Server 2008 R2 Hyper-V server not on the VMs.
 So are you saying do it at the root main windows server hyper-v , not on the individual VM.
This is very confusing to me sorry.
0
 
techgeniousAuthor Commented:
let me try that and I will get back to you on this.  Thanks for everything.
0
 
techgeniousAuthor Commented:
Just an FYI, all the VM's cannot access the internet.    They can access each other internally via the Internal NIC , with no problems, but they cannot get out to the internet, and I need that for patching.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Your VM with two vNICs needs to have a proxy setup like RRAS on 2008 R2, Untangle, or SOPHOS Edge (ISO download).
0
 
techgeniousAuthor Commented:
why would I need a proxy setup like RRAS, all I want is internet access out on one NIC card and internal access on the other NIC card.
0
 
techgeniousAuthor Commented:
All I had to do was removed the external NIC Virtual Switch and add it back in and it all worked.
thanks everyone for your help.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Proxy access would be for a virtual environment behind a Private network on a Hyper-V host.

If the guests are accessing the same network as the host along with Internet access then the point is moot. :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.