Solved

Remote Web Access - can't connect to specific computer

Posted on 2015-01-14
15
197 Views
Last Modified: 2015-01-14
Hi,

SBS 2011 Essentials here.

When using RWA, I can reach every computer but one. I get this msg:

Error msg
I don't know if this is related, but within the network, if I try to RDC into this computer using its name, it fails. But if I punch in the IP address, it connects fine.

Thanks in advance.
0
Comment
Question by:Go-Bruins
  • 7
  • 4
  • 4
15 Comments
 
LVL 90

Expert Comment

by:John Hurst
ID: 40548998
Make sure Network Discovery and File and Print Sharing are ON for the problem computer. Make sure the NIC is attached to Work/Private and not Public.

That you can properly connect by IP means the basic connection is fine and means the DNS or a setting is not working well.
0
 

Author Comment

by:Go-Bruins
ID: 40549033
Thank you. Discovery is On, and we are on a domain.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40549047
There must be a DNS setting somewhere if IP address works.
0
 

Author Comment

by:Go-Bruins
ID: 40549053
That's what I'm thinking. In terms of OS/setup, There's nothing that really sets this machine apart from the others.

So I'm *guessing* it's some kind of tweak on the Server...
0
 
LVL 3

Accepted Solution

by:
roycbene earned 350 total points
ID: 40549068
A couple things to check:

Check for a duplicate DNS record for the same computer name (if there are duplicate ones, you may also want to check your DNS scavenging settings).

Check for duplicate SIDs in Active directory

Please let me know if I can provide any further assistance.

-Roy
0
 

Author Comment

by:Go-Bruins
ID: 40549073
Sorry, this may be above my paygrade. I may need something like:

1. Click Start
2. etc.

Thanks.

I've gone to:

Server Manager
Roles
DNS Server
Forward Lookup Zones
XYZ.local

I see an entry for the machine, and it's the wrong IP address. Now, is it a matter of me deleting the entry, or do I modify it?

And why isn't the Server smart enough to recognize that it's the wrong IP address and fix it?
0
 
LVL 3

Expert Comment

by:roycbene
ID: 40549135
What you want to do is double click the entry and put the correct IP address in. Depending on the size of your domain, it may take up to 15 minutes for the DNS servers to propagate the new entry. Try again and let me know. :)
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:Go-Bruins
ID: 40549159
It seems to work, but shouldn't there be some kind of auto-refresh, where the Server polls and updates the entries?

is this what all the other network admins have to go through?
0
 
LVL 90

Assisted Solution

by:John Hurst
John Hurst earned 150 total points
ID: 40549172
is this what all the other network admins have to go through?

Generally no, because if DNS works for one it normally works for all.

Is there a Host entry on the problem computer.

Also do a TCP/IP Reset on the problem computer.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache

Now restart and test.
0
 
LVL 3

Assisted Solution

by:roycbene
roycbene earned 350 total points
ID: 40549217
If the IP has recently been changed statically, or if there is a host entry on the computer, there will be an issue. Also, if your scavenging settings in your DNS are not set properly, this will cause issues and duplicate or incorrect entries.

To add to John's comment, also do an ipconfig /registerdns. This will ensure an updated entry from the client machine.

Do you know if you have NETBIOS over TCP/IP enabled as a general rule?

-Roy
0
 

Author Comment

by:Go-Bruins
ID: 40549294
Where can I go to check:

1. Scavenging settings


Thanks.
0
 

Author Comment

by:Go-Bruins
ID: 40549360
Here's what I see. Our Asus router serves as the DHCP server, and I've assigned some static IP addresses through the Asus router:

Snapshot
0
 
LVL 3

Assisted Solution

by:roycbene
roycbene earned 350 total points
ID: 40549392
Scavenging records are set in two places. The mistake I see made most often with DNS configuration is that people often set scavenging at the Zone level, but do not set it at the server level. There is no need to defer from the default setting (7 days), as long as your DHCP server's IP lease time is set for 7 days. If your DHCP lease time is set for, let's say, 10 days, then you would want your scavenging settings to match that time period. Otherwise, it could potentially cause issues in the future.

To set at the server level:

1. open DNS manager
2. Right click the name of the DNS server and go to properties
3. Go to the advanced tab
4. Click on 'Enable automatic scavenging of stale records'. You will see the default is 7 days.

This only needs to be performed on one server in the domain (the authoritative server). The scavenging results will be propagated to the other servers in the domain during replication.

To set on the zone level:

- Highlight (left click) the zone in question (i.e. yourcompany.local).
- Right-click and go to properties
- Under the 'General' tab, you'll see an 'Aging' button on the bottom. Click that
- Check 'Scavenge stale resource records', then click ok.

Here is a good link if you want to actually know about scavenging (how and why, how to check to be sure it's being done, etc.).

http://blogs.technet.com/b/networking/archive/2008/03/19/don-t-be-afraid-of-dns-scavenging-just-be-patient.aspx

For checking NETBIOS over TCP/IP, this is done on the network card of the machine, itself. Go to TCP/IP 4 properties and click the advanced button. Then go to the WINS tab. Check to see if NETBIOS over TCP/IP is enabled.


Let me know if you need anything else. I'm always happy to help. :)


-Roy
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 40549612
The NetBIOS setting you showed is default and correct.

Look in c:\windows\system32\drivers\etc\hosts to see if there are any entries in the Hosts file which should not be there (there should be none in most cases).
0
 

Author Comment

by:Go-Bruins
ID: 40549865
Thank you one and all. I've made the changes at the Server and Zone level.

If the Server is set to be the DHCP server, I shouldn't have to do this stuff, correct?
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now