• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 299
  • Last Modified:

Single domain user cannot add Exchange account to his iPhone?

Hello experts,

We are having trouble adding an exchange mailbox to a user's iPhone. After typing in all of the correct server information, and tapping save, we get "Unable to verify exchange information." The user can log in to OWA (same address, same password) and his outlook client has no issues either.

In fact, he had this account added and functioning perfectly fine as recent as last week!

Since then, on this past Saturday, we finally completed the removal of our old exchange 2007 server.
(we migrated from 2007 to 2013 a month ago, and after having many issues, we finally followed the steps outlined: here
to take the old server offline completely).

 This solved most of our other intermittent issues across the organization, but interestingly enough seemed to cause this issue on a couple of our users' mobile devices.

On Saturday, when we removed the server, these 2 users reported an out of date mailbox on their phones. User A removed his account, and was met with the "Unable to verify exchange account information" message for the next hour or so while he was trying to re add the account, until it seemingly resolved itself, and he was able to add the account fine.

User B removed his account to re add it, and he has yet to successfully add it. (4 days later)

As I explained, he can access his account via OWA fine, and we also tried adding his accounts to other phones with the same results. He is using an iPhone 6, but I tried it on other devices and it gave the same message.

Additionally, a month ago when we migrated the mailbox database originally, we had an issue very similar to this where a select half-dozen users just stopped getting mail on their phones. We solved this by going into A/D Users and Computers, and PropertiesSecurityAdvancedAdd on the affected profiles, and applying a permission to the principle "Exchange Servers" labeled "msExchgActiveSync Devices objects". This completely solved the issue then, but has helped us none on this one affected user.

Is there anything else I can try? The last resort is for us to recreate his mailbox, but that would require the back up all his current mail, so if it is possible to fix the issue, I would like to try first.

Thanks in advance to all who contribute!
0
BMFC
Asked:
BMFC
  • 2
1 Solution
 
Will SzymkowskiSenior Solution ArchitectCommented:
Might be a long-shot but have the accounts been disabled from using ActiveSync? It is possible that something had happend during the  migration from 2007 to 2013. You might spend more time trying to figure out how to get ActiveSync working when creating the mailbox might be a quicker route. If you are only experiencing this issue with 1 or 2 users might be a better option to just re-create the mailbox use the New-MailboxExportRequest and New-MailboxImportRequest cmdlets to Export the mailbox contents and Import them into the new destination mailbox. If the mailbox is not too big it shouldn't take too long.

Will.
0
 
VB ITSSpecialist ConsultantCommented:
I have to agree with Will, it may just be quicker to recreate the mailbox if the problem is only occurring for a single person. These sort of issues can have you pulling your hair out trying to find the root cause of the problem.

The actual export and import process is very straight forward once you've created and assigned the necessary mailbox import/export role to your admin account. If you haven't already done so, you'll need to assign yourself the Mailbox Import Export management role. Read here if you need help doing this: http://technet.microsoft.com/en-us/library/ee633452%28v=exchg.141%29.aspx
0
 
BMFCAuthor Commented:
Thanks for confirming that was the best way to tackle it guys, I will do this today!
0
 
BMFCAuthor Commented:
I meant to accept both as answers, sorry for the mistake.
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now