Solved

DNS did not resolve exchange .local record

Posted on 2015-01-15
16
158 Views
Last Modified: 2015-01-16
i have an exchange server with server.loca name and i have installed the ssl UCC certificate and the autodiscover is working properly but   am getting  this error in Outlook connectivity test  

Untitled.png
0
Comment
Question by:mohammed-khalaf
  • 9
  • 7
16 Comments
 
LVL 19

Expert Comment

by:R--R
ID: 40552653
Server.local is for the internal domain. Please include the external name as mail.domain.com in SSL certificale and configure the Exchange virtual directories and OA. Also create the host A record mail.domain.com and point it to public IP of the firewall.
0
 

Author Comment

by:mohammed-khalaf
ID: 40552660
i did all the SAN names in the ssl
autodicover.domain.com
dmain.com
mail.domain.com
but how to create host record with mail.domain.com??
0
 

Author Comment

by:mohammed-khalaf
ID: 40552663
i configured the virtual directory address in the ECP  mail.domain.com
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 19

Expert Comment

by:R--R
ID: 40552664
You have to create it with your DNS hosting provider.
0
 
LVL 19

Expert Comment

by:R--R
ID: 40552666
OWA, ACtivesync, OA also configure autodiscoveruri in clientaccessserver
0
 
LVL 19

Expert Comment

by:R--R
ID: 40552671
Set-ClientAccessServer -Identity "server" -AutoDiscoverServiceInternalUri https://mail.domain.com/autodiscover/autodiscover.xml
0
 
LVL 19

Expert Comment

by:R--R
ID: 40552672
Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory -InternalUrl https://mail.domain.com/ews/exchange.asmx -ExternalUrl https://mail.domain.com/ews/exchange.asmx
0
 

Author Comment

by:mohammed-khalaf
ID: 40552694
https://mail.domain.com/autodiscover/autodiscover.xml     (test resullt)

This XML file does not appear to have any style information associated with it. The document tree is shown below.
      <Autodiscover><Response><Error Time="03:41:49.2031191" Id="3970427709"><ErrorCode>600</ErrorCode><Message>Invalid Request</Message><DebugData/></Error></Response></Autodiscover>
0
 

Author Comment

by:mohammed-khalaf
ID: 40553361
i did not understand the comment ID: 40552672
0
 

Author Comment

by:mohammed-khalaf
ID: 40553374
i tryed to run the commend but no ues
0
 

Author Comment

by:mohammed-khalaf
ID: 40553423
OK in Autodiscover test
         Autodiscover settings for Outlook connectivity are being validated.
       The Microsoft Connectivity Analyzer validated the Outlook Autodiscover settings.
       
But RPC /HTTP Still
      Additional Details
      Testing RPC over HTTP connectivity to server ex-mail.server.local
       RPC over HTTP connectivity failed.
       
      Additional Details
       
Elapsed Time: 139 ms.
       
      Test Steps
       
      Attempting to resolve the host name ex-mail.server.local in DNS.
       The host name couldn't be resolved.
        Tell me more about this issue and how to resolve it
       
      Additional Details
0
 
LVL 19

Accepted Solution

by:
R--R earned 500 total points
ID: 40554197
Do you have a DNS host A  ex-mail.server.local  record on public dns.
The record  ex-mail.server.local should not be in the public dns. The record should be mail.domain.com and autodiscover.domain.com and pointed to public IP of the firewall and nat to the server internal IP.

Once you create the A records you have to configure the virtual directorie with mail.domain.com

check this article from http://www.msexchange.org may help you.

http://www.msexchange.org/articles-tutorials/exchange-server-2010/management-administration/exchange-autodiscover-part2.html
0
 

Author Comment

by:mohammed-khalaf
ID: 40554219
we made the virtual directories to use the public domain name and we have A record in the zone file in the internet and autodiscover & MX,,    and forwarded  the ports the exchange and we have internal MX record and  in the internal network

any one can help me though teamviewer  i can give access
0
 

Author Closing Comment

by:mohammed-khalaf
ID: 40554269
we added an host record with the mail.dmainname.com and we pointed the IP address the public ip address
0
 

Author Comment

by:mohammed-khalaf
ID: 40554281
it is working now we added an Host record with mail.domain.com and we pointed to the Public IP Address

Many Thanks
0
 
LVL 19

Expert Comment

by:R--R
ID: 40554331
Thank you. I am glad that it helped you.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
The new Gmail Phishing Scam going around is surprising even the savviest of users with its sophisticated techniques.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question