• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

How to Configure UEFI to trust your custom bootloader

Microsoft indicates that  you can "Configure UEFI to trust your custom bootloader" and also you can "Turn off Secure Boot".

how do you do this with a windows 8 PC ?
0
alcindor
Asked:
alcindor
  • 6
  • 3
  • 3
  • +1
2 Solutions
 
rindiCommented:
UEFI is turned off in the BIOS. Just look for that option. To add anew boot OS to secureboot, you need to apply for a key, then again add it via the BIOS. That in my point of view doesn't make much sense though, as you can easily turn off secureboot and then it doesn't matter.
0
 
nobusCommented:
disable secure boot :  http://technet.microsoft.com/en-us/library/dn481258.aspx

2.Open the PC BIOS menu. You can often access this menu by pressing a key during the bootup sequence, such as F1, F2, F12, or Esc.
Or, from Windows, hold the Shift key while selecting Restart. Go to Troubleshoot > Advanced Options: UEFI Firmware Settings.
3.Find the Secure Boot setting, and if possible, set it to Disabled. This option is usually in either the Security tab, the Boot tab, or the Authentication tab.
4.Save changes and exit. The PC reboots.
0
 
noxchoCommented:
This is not Windows option but UEFI BIOS feature. Disable Secure Boot in BIOS and you get the same freedom as you get with disabling UAC.
0
 
nobusCommented:
only trouble is - if you don't do it, and windows does not start anymore, you're in a bit of a fix
0
 
rindiCommented:
Turning SecureBoot off won't cause Windows from not booting anymore. It just allows you to boot from more media.
0
 
nobusCommented:
i never said it caused windows not to boot - only IF
0
 
rindiCommented:
But what would that have to do with secureboot?
0
 
nobusCommented:
i warned that  - IF secure booit is not disabled, you may have trouble starting from other devices (cd) - when windows does not start
that's all
0
 
alcindorAuthor Commented:
Thanks for your comments, I was interested in the subject after installing a replacement system dis in a friend's laptop.
I replaced a 750 GB windows 8.1 system mechanical disk with an SSD by taking a disk backup with Acronis 2014 and restoring to the SSD.
The restored SSD system would not boot with UEFI configured in the BIOS although the original system booted with UEFI configured in the BIOS, to get the SSD system to boot I had to select Legacy boot as opposed to UEFI boot in the BIOS settings.
In order to restore the system to the SSD I used the Acronis 2014 bootable media which would not boot with UEFI configured in the BIOS.
0
 
nobusCommented:
tx for feedback
0
 
noxchoCommented:
Bad for Acronis. Looks like you did not copy entire drive.
0
 
nobusCommented:
without screenshots of what you did, we can't possibly say what was wrong - if any - only guess
0
 
alcindorAuthor Commented:
You're correct noxcho. I only copied the system partition. Originally I planned to clone the disk but as the SSD drive was only 250 GB and the mechanical drive was 750GB (although only 93 GB was in use), I couldn't shring the system partition of the drive. I had re-located the swap file and removed  hiberfil.sys but could still not shrink the system partition enough.
It isn't perceived as a problem that the SSD system now boots with non-UEFI configured in the BIOS.
0
 
noxchoCommented:
That's why I said - bad for Acronis. Migrate OS for SSD from Paragon would copy the EFI partition and system partition together.
0
  • 6
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now