[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

MySQL Server Access

Posted on 2015-01-17
8
Medium Priority
?
305 Views
Last Modified: 2015-01-24
I have a Windows 2008 Server in a Cloud.  I am having issues connecting to the MySQL Server.
When I run the following from the Comand Line:
C:>"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld"

I get the following Error:
150117 22:05:55 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Se
rver 5.5\data\azwebdev02.lower-test
150117 22:05:55 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Se
rver 5.5\data\azwebdev02.lower-test
150117 22:05:55 [Note] Plugin 'FEDERATED' is disabled.
150117 22:05:55 InnoDB: The InnoDB memory heap is disabled
150117 22:05:55 InnoDB: Mutexes and rw_locks use Windows interlocked functions
150117 22:05:55 InnoDB: Compressed tables use zlib 1.2.3
150117 22:05:55 InnoDB: Initializing buffer pool, size = 128.0M
150117 22:05:55 InnoDB: Completed initialization of buffer pool
150117 22:05:55  InnoDB: Operating system error number 5 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory. It may also be you have created a subdirectory
InnoDB: of the same name as a data file.
InnoDB: File name .\ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.

I read to fix this issue I need to run the follow line:
C:>sudo chaown -R mysql:mysql /var/lib/mysql

I get this error:
'sudo' is not recognized as an internal or external command,
operable program or batch file.

If I run it this way:
C:>"sudo chown -R mysql:mysql /var/lib/mysql"

I get this error:
The filename, directory name, or volume label syntax is incorrect.

Can anyone shed any light on what I am doing wrong?  Do I have the correct Directory name?  Is my Syntaxt Correct?
0
Comment
Question by:rgranlund
  • 3
  • 3
  • 2
8 Comments
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 40555834
'mysqld' is the Service that responds to request for the MySQL server.  It is Not the command line program to access the server.  That is just 'mysql.exe'.

'sudo' is not recognized as an internal or external command,
operable program or batch file.
Of course you do.  'sudo' only works on Linux or Unix, not Windows.
0
 
LVL 7

Author Comment

by:rgranlund
ID: 40555837
How do I write this line:
C:>sudo chaown -R mysql:mysql /var/lib/mysql
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 40555839
You don't.  It won't work on Windows.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 81

Expert Comment

by:arnold
ID: 40555842
you do not the commands you list are unix/linux related not windows.  You use the properties of the directory and add security, though I do not believe it is necessary.
open services and see if you have a mysql server reference.

It was pointed out if you do not have the workbench GUI install which include the GUI administrator for mysql.

command line you would run mysql -u root -p if you set a root password, if you did not run mysql -u root
and you should be on the mysql server.
show databases; should list all your databases.

I think it is possible, though did not try isntalling/running mysql under cygwin.

presumably you downloaded mysql-server.msi from mysql.com and you installed it directly on windows.
0
 
LVL 7

Author Comment

by:rgranlund
ID: 40555847
How do I fix this problem
0
 
LVL 81

Expert Comment

by:arnold
ID: 40555851
it is not clear to me what your issue is?

it was pointed out when you run mysqld you are trying to start the service

look in services,
rerun the mysql configuration tool.
double check where you place the data directory.

Is the mysql running on this server, or you have a mysql server in the cloud?

mysql -u username -p -h ipaddress_of_mysql_server
0
 
LVL 7

Author Comment

by:rgranlund
ID: 40555866
The server is in the cloud.
0
 
LVL 81

Accepted Solution

by:
arnold earned 2000 total points
ID: 40555871
i understand you have 2008 server in the cloud. on this server you installed mysql.
you are seemingly trying to start mysql server directly  (mysqld) versus the services.msc mysql server which might be running already using the credentials if ant specified during the configuration tool.

please try using the services.msc to check whether there is mysql server listed there and if so what is it set manual, automatic, automatic delayed, disabled and is it started?

what happens if you run mysql -u root -h localhost?
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this blog, we’ll look at how improvements to Percona XtraDB Cluster improved IST performance.
The title says it all. Writing any type of PHP Application or API code that provides high throughput, while under a heavy load, seems to be an arcane art form (Black Magic). This article aims to provide some general guidelines for producing this typ…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question