?
Solved

Remove "asterisk" from SIP header

Posted on 2015-01-17
10
Medium Priority
?
946 Views
Last Modified: 2015-01-21
I am having an issue with my VOIP provider rejecting outbound/inbound calls. They offer no support for BYOD accounts and all I can get out of the tech was I needed to remove the "asterisk" from the From: in the SIP header. No issues with other trunks I have on the server. At this point I have read way too many posts on the topic and am at my wits end. Here is a portion of an inbound packet. Outbound is basically the same 403 Forbidden from "asterisk". This also happens for the OPTIONS requests sent do to the qualify=yes in sip.conf.

INVITE sip:4444444444@sip.provider.com SIP/2.0
Via: SIP/2.0/UDP 192.168.1.2:5060;branch=z9hG4K28116437;rport
Max-Forwards: 70
From: "asterisk" <sip:5555555555@sip.provider.com>;tag=as1e82b91
To: <sip:444444444@sip.provider.com>
Contact: <sip:555555555@192.168.1.2:5060>
Call-ID: 51ebe372cafb3df26de4e7247df5fcf@sip.provider.com
CSeq: 102 INVITE
User-Agent: Asterisk PBX 10.12.2
Date: Thu, 15 Jan 2015 22:16:52 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Type: application/sdp
Content-Length: 182

v=0
o=root 132995492 132995492 IN IP4 192.168.1.2
s=Asterisk PBX 10.12.2
c=IN IP4 192.168.1.2
t=0 0
m=audio 12028 RTP/AVP 0
a=rtpmap:0 PCMU/8000
a=ptime:20
a=sendrecv
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.1.2:5060;received=x.x.x.x;branch=z9hG4K28116437;rport=5060
From: "asterisk" <sip:555555555@sip.provider.com>;tag=as1e82b91
To: <sip:4444444444@sip.provider.com>
Call-ID: 51ebe372cafb3df26de4e7247df5fcf@sip.provider.com
CSeq: 102 INVITE

SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.2:5060;received=x.x.x.x;branch=z9hG4K28116437;rport=5060
From: "asterisk" <sip:5555555555@sip.provider.com>;tag=as1e82b91
To: <sip:4444444444@sip.provider.com>;tag=aprngfrt-ln9hii10000c6
Call-ID: 51ebe372cafb3df26de4e7247df5fcf@sip.provider.com
CSeq: 102 INVITE

Based on what the tech support said. I need to remove "asterisk" from here:

From: "asterisk" <sip:5555555555@sip.provider.com>;tag=as1e82b91

I don't believe there is anything in sip.conf for this. Thanks in advance.

-gr
0
Comment
Question by:GR999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 20

Assisted Solution

by:José Méndez
José Méndez earned 1336 total points
ID: 40555867
0
 
LVL 4

Assisted Solution

by:Ruel Tmeizeh
Ruel Tmeizeh earned 664 total points
ID: 40555985
Actually it is in your sip.conf --- your callerid string. Also, you can change the user agent string, which can remove all other mentions of Asterisk (You can change it to "Magic Jack" or "Shoretell" or whatever).
Let me know if you need detailed help with this or the callerid string and I can go further into it.

And I'm sure you have already thought of this and probably have a good reason, but there are several very good VoIP providers that are reasonably priced and do support Asterisk, like Vitelity, Flowroute, and Voip.ms. Maybe it's time for a change?
0
 

Author Comment

by:GR999
ID: 40556607
Thank you both for replying. Yes, I have tried that. That's where the "asterisk" comes up. If I remove any callerid or blank out the user agent it is still somehow getting a default "asterisk" into the From:. I think I will eventually change, but I guess it has become a bit of me wanting to figure it out to help others. I'd like to know what they are doing. I have been away from the Voip game for awhile and I used to use a company that supported asterisk very well, unfortunately the current provider bought that company and seems to have ruined it. Here is a message after attempting an outbound call minus all possible callerid...user agent....etc. Still no luck. Somewhere there is a default "asterisk".

[Jan 18 16:11:48] WARNING[25999]: chan_sip.c:21557 handle_response_invite: Received response: "Forbidden" from '"asterisk" <sip:4444444444@192.168.1.2>;tag=as512a5f2'
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 20

Expert Comment

by:José Méndez
ID: 40556677
I am currently using asterisk 11 and the setcallerid functionality in the dial plan, and I do not see any trace of the word Asterisk in the caller ID:


INVITE sip:1337@192.168.13.125 SIP/2.0
Via: SIP/2.0/UDP 192.168.13.132:5060;branch=z9hG4bK239c364c
Max-Forwards: 70
From: "John Norse" <sip:545678@192.168.13.132>;tag=as76e6d154
To: <sip:1337@192.168.13.125>
Contact: <sip:545678@192.168.13.132:5060>
Call-ID: 1e18b50326d115820eefb4d248d23983@192.168.13.132:5060
CSeq: 102 INVITE
User-Agent: Asterisk PBX 11.15.0
Date: Sun, 18 Jan 2015 16:02:05 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Type: application/sdp
Content-Length: 287

As RuhNet said, if I wanted to remove the User-Agent portion then I would use something like this in sip.conf:

useragent=AnythingGoesHere

Currently this is my peer definition for the INVITE sample above:


[111]
type=friend
host=dynamic
defaultuser=111
secret=????
mailbox=111@default
qualify=yes
qualifyfreq=20
context=????


Extensions.conf looks like this for that particular outbound call;

[context-name]      
exten => _XXXX,1,NoOp(Calling Farend Phones)
      same => n,Set(CALLERID(all)="John Norse" <545678>))
      same => n,Dial(SIP/d4-um-p105/${EXTEN})
      same => n,Hangup()
      

Hope that helps
0
 

Author Comment

by:GR999
ID: 40556777
Right. I do remove everything:

[general]
realm=
useragent=
allowguest=no
defaultexpiry=3600
pedantic=no
nat=never
alwaysauthreject=yes
srvlookup=no
videosupport=yes
language=en

Somehow still seems to come up with "asterisk" in the From: field. Ok I noticed via 'sip show settings'
Global Settings:
----------------
  UDP Bindaddress:        0.0.0.0:5060
  TCP SIP Bindaddress:    Disabled
  TLS SIP Bindaddress:    Disabled
  Videosupport:           Yes
  Textsupport:            No
  Ignore SDP sess. ver.:  No
  AutoCreate Peer:        No
  Match Auth Username:    No
  Allow unknown access:   No
  Allow subscriptions:    Yes
  Allow overlap dialing:  Yes
  Allow promisc. redir:   No
  Enable call counters:   No
  SIP domain support:     No
  Realm. auth:            No
  Our auth realm          
  Use domains as realms:  No
  Call to non-local dom.: Yes
  URI user is phone no:   No
  Always auth rejects:    Yes
  Direct RTP setup:       No
  User Agent:            
  SDP Session Name:       Asterisk PBX 10.12.2
  SDP Owner Name:         root
  Reg. context:           (not set)
  Regexten on Qualify:    No
  Trust RPID:             No
  Send RPID:              No
  Legacy userfield parse: No
  Caller ID:              asterisk
  From: Domain:          
  Record SIP history:     Off
  Call Events:            Off
  Auth. Failure Events:   Off
  T.38 support:           No
  T.38 EC mode:           Unknown
  T.38 MaxDtgrm:          -1
  SIP realtime:           Disabled
  Qualify Freq :          60000 ms
  Q.850 Reason header:    No
  Store SIP_CAUSE:        No

that callerid is "asterisk". I removed it in global settings and now the 403 looks like this:

[Jan 18 18:15:29] WARNING[25999]: chan_sip.c:21557 handle_response_invite: Received response: "Forbidden" from '"" <sip:5555555555@192.168.1.2>;tag=as74d321f'

Packets:

INVITE sip:4444444444@sip.provider.com SIP/2.0
Via: SIP/2.0/UDP 192.168.1.2:5060;branch=9hG4bK3cf2a49d;rport
Max-Forwards: 70
From: "" <sip:5555555555@192.168.1.2>;tag=s41f6c40c
To: <sip:4444444444@sip.provider.com>
Contact: <sip:5555555555@192.168.1.2:5060>
Call-ID: 477313e72487d0f0af02c1e33cf480d@192.168.1.2:5060
CSeq: 102 INVITE
Date: Sun, 18 Jan 2015 23:33:36 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Type: application/sdp
Content-Length: 180

v=0
o=root 46712254 346712254 IN IP4 192.168.1.2
s=Asterisk PBX 10.12.2
c=IN IP4 192.168.1.2
t=0 0
m=audio 15264 RTP/AVP 0
a=rtpmap:0 PCMU/8000
a=ptime:20
a=sendrecv
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.1.2:5060;received=x.x.x.x;branch=9hG4bK3cf2a49d;rport=5060
From: "" <sip:5555555555@192.168.1.2>;tag=s41f6c40c
To: <sip:4444444444@sip.provider.com>
Call-ID: 477313e72487d0f0af02c1e33cf480d@192.168.1.2:5060
CSeq: 102 INVITE

SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.2:5060;received=x.x.x.x;branch=9hG4bK3cf2a49d;rport=5060
From: "" <sip:5555555555@192.168.1.2>;tag=s41f6c40c
To: <sip:4444444444@sip.provider.com>;tag=prqngfrt-dbic410000c6
Call-ID: 477313e72487d0f0af02c1e33cf480d@192.168.1.2:5060
CSeq: 102 INVITE

ACK sip:4444444444@sip.provider.com SIP/2.0
Via: SIP/2.0/UDP 192.168.1.2:5060;branch=9hG4bK3cf2a49d;rport
Max-Forwards: 70
From: "" <sip:5555555555@192.168.1.2>;tag=s41f6c40c
To: <sip:4444444444@sip.provider.com>;tag=prqngfrt-dbic410000c6
Contact: <sip:5555555555@192.168.1.2:5060>
Call-ID: 477313e72487d0f0af02c1e33cf480d@192.168.1.2:5060
CSeq: 102 ACK
Content-Length: 0

I'm at a loss. I'm just going off what the tech said "Remove the "asterisk" and you should be good" (in a wink wink kind of sense). I have searched the internet for solutions previously:

http://www.iptel.org/FAQ_To_From_change     -- as long as you don't change <tag>

http://www.voip-info.org/wiki/view/Asterisk+func+sip_header

But I am at a loss of experience and how to implement.
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 40557020
Do you have an account name that you were given initially to authenticate with them? Try hardcoding that into the "" to see if it lets you through. Use the syntax

Set(CALLERID(all)="YourACcountName" <5555555555>))

At this point you are at the mercy of what your provider says. They are the ones rejecting, so they should tell you why
0
 
LVL 20

Accepted Solution

by:
José Méndez earned 1336 total points
ID: 40557026
Also, do you see yourself registered to them? What does

sip show registry

show?
0
 

Author Comment

by:GR999
ID: 40557088
Same thing:

sip.provider.com:5060                 N      5555555555        3585 Registered           Mon, 19 Jan 2015 01:41:19

[Jan 19 01:43:58] WARNING[28183]: chan_sip.c:21557 handle_response_invite: Received response: "Forbidden" from '"5555555555" <sip:5555555555@192.168.1.2>;tag=as2672920'

Packets say the same thing. I really don't get what they are up to and why they are doing it. Guess I will dump them tomorrow and get a new provider.
0
 
LVL 4

Expert Comment

by:Ruel Tmeizeh
ID: 40558232
In your sip.conf, you can try changing the "realm"  item to the domain of your provider. Right now it probably says "asterisk" on the realm. Sometimes authentication is done based on the realm/domain as well as the user/password.

Just out of curiosity, which provider is it that you are working with?
0
 

Author Closing Comment

by:GR999
ID: 40561642
No solution found. PhonePower seems to be a lost cause for BYOD.
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Although VoiceOver IP has been around for a while, internet connections have only recently become fast enough to provide good call quality. Now, VoIP has become a real option for businesses looking at ways to improve their business model. In this ar…
I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question