I have a XLSM where the macro/VB is no longer working, can someone review

An XLSM was created to consolidate files and generate an email it is no longer working. I don't know enough to know how to fix it.
MonthlyRepStatement-V02.xlsm
Tracy JohnsonAsked:
Who is Participating?
 
gowflowConnect With a Mentor Commented:
I changed in your file the reference to outlook 2007 and it worked perfectly.
gowlfow
0
 
SimonCommented:
More information please: At what point in the process is it failing?
Do any of the buttons still work as expected?
Has anything significant changed in your environment - e.g. Office version?

Note: this looks like a follow-up to http://www.experts-exchange.com/Software/Office_Productivity/Spreadsheets/Q_28518112.html
0
 
Tracy JohnsonAuthor Commented:
Yes, this is that same file. Environmentally speaking, nothing has changed. I had a virus that did something and I needed to reinstall the license of Office 2013 and it required getting a new license key because the OEM code that came with my PC was lost. Other than that, as far as I know nothing has changed.

None of the buttons works as expected.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
SimonConnect With a Mentor Commented:
When I open your workbook (admittedly in the Mac2011 version of Office), none of the buttons work for me either. They just don't behave as buttons when clicked.

Could you try adding an ActiveX commandbutton object to a brand new workbook and tell us if you get an error message. If the problem doesn't just exist in that specific workbook I think you have the ActiveX problem caused by the December 2014 MS security update. The fix for that is shown in this MS suppport link (with fixit).
0
 
Tracy JohnsonAuthor Commented:
I am not sure that I know how to do that.
0
 
SimonCommented:
Do you have any other workbooks with buttons on? If so, do they work?

If not, please try this very simple test workbook (blank with just a button in). It should just say Hello when you click on it.ButtonTest.xlsm
0
 
Tracy JohnsonAuthor Commented:
I researched the MS support link you provided here and that was exactly my problem.
0
 
gowflowCommented:
Looking at the file I can see that it is linked to outlook 2013 is this the version you have ? When it was developed it was Outlook 2007 did you change it from then ?

gowflow
0
 
gowflowCommented:
Oops your quick !!! I know your very busy but ... can we just exchange few things ?
gowflow
0
 
Tracy JohnsonAuthor Commented:
My file has an error and in between each rep it is asking me to continue, end or debug can you review?

Doc1 is a screen shot of the error
MonthlyRep file is the actual macro file
I also attached the three files I am working with.

I am not sure if there is something in the file we need to change or not again...sorry I don't know enough about VBA and excel version changes/tweaks.
Doc1.docx
MonthlyRepCommissionStatementGenerator-w
OP512-APR2015.XLS
SA612-APR2015.XLS
SA646-APR2015.XLS
0
 
gowflowCommented:
ok just quickly in here

when are you getting this error I mean when you press what button ?
Selecting the files ?
Generate Monthly Rep statements ?
Generate Emails for Sales ?

gowflow
0
 
Tracy JohnsonAuthor Commented:
every time the reps are parsing through each of the files...
0
 
gowflowCommented:
I saw the file quickly it seems you have a new version of outlook it is outlook 2013 ? did you just installed it and the problem started ?

You did not answer my question. What button you activate so it give you the error ?

I tried the file and it is fine with outlook 2007. No error.
gowflow
0
 
Tracy JohnsonAuthor Commented:
yes i have outlook 2013, i have always had

happens with either button.
0
 
gowflowCommented:
If you noticed on this question you had accepted when I posted that I changed to oulook 2007 and it worked perfectly. Please see the threads again.

I still don't know what error you get what is the message. I saw the instruction in yellow that you posted but don't know what is the error that is caused maybe then I could help.
gowflow
0
 
Tracy JohnsonAuthor Commented:
I am getting an error on the one spreadsheet and no reason why. I have attached the files I am using. Please help!
SA646-MAY2015.XLS
SA612-MAY2015.XLS
OP512-MAY2015.XLS
Doc1.docx
MonthlyRepCommissionStatementGenerator-w
0
 
gowflowCommented:
Yes I just checked it out and here is the problem:
In all your files (booking, shippments and commissions) you had mentioned that the data was in sheet SUBTOTALS

but it happened so that the file it is failing on
SA612-MAY2015.XLS
has the sheet SUBTOTAL

it is missing 'S' at the end just put S so it Is SUBTOTALS and run the macro all should be fine.
gowlfow
0
 
Tracy JohnsonAuthor Commented:
Oh my how simple. I checked the PriSlp field....ugh! sorry! but thank you!!!!!!!
0
 
gowflowCommented:
Your welcome
gowflow
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.