Error adding WiFi virtual switch to Hyper-V on Win 8.1

I've installed a VM on Hyper-V. I want it to share WiFi for full access. When I add a new virtual network switch for the WiFi adapter, I get this error:
[Window Title]
Virtual Switch Manager for PC
[Main Instruction]
Error applying Virtual Switch Properties changes
Failed while adding virtual Ethernet switch connections.
[Expanded Information]
Ethernet port '{97D28A98-EFFD-4A4C-B56D-CDCC8E584C74}' bind failed: This operation returned because the timeout period expired. (0x800705B4).
So, why does it fail? And what's with all the stuff in the message about Ethernet?

I *do* have a virtual Ethernet switch, which installed correctly.
Who is Participating?
BlearyEyeConnect With a Mentor Author Commented:
Well, the problem is that it wasn't binding at all, so I couldn't do that. However, I tried the universal specific: reboot Windows. This time it went through. I now have vEthernet (Ethernet) and vEthernet (WiFi) connections. Calling both vEthernet is a little confusing but I guess it's right.

So, the original question is answered. I'll accept my post as the answer and credit points for the help.
David Johnson, CD, MVPOwnerCommented:
create a new external switch binding it to the wifi network adapter.  hyper-v manager must be run as an administrator
BlearyEyeAuthor Commented:
I believe that's what I was doing
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Philip ElderConnect With a Mentor Technical Architect - HA/Compute/StorageCommented:
BlearyEyeAuthor Commented:
Actually, I had seen that in my poking around; should have mentioned it, sorry.

My WiFi adapter already has the Microsoft Network Adapter Multiplexor Protocol installed (but not checked). WiFi propertiesI don't see any other recommendation.
Philip ElderConnect With a Mentor Technical Architect - HA/Compute/StorageCommented:
This is what my WiFi vSwitch looks like:
WiFi vSwitchYours looks to be missing a check mark.
BlearyEyeAuthor Commented:
OK, I enabled the Microsoft LLDP Protocol Driver. Still no joy. And I don't understand why is says "Failed while adding virtual Ethernet switch connections" when I've selected the WiFi adapter.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Could you post a snip of the Hyper-V vSwitch properties that is bound to the WiFi as I did please?
BlearyEyeAuthor Commented:
Phillip Elder's comments were helpful and, having exhausted suggestions, led me to the idea of a clean start which sorted things out.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.