Folder not showing up when browsing windows

I noticed today that a folder created on a Windows 2008 server is not appearing when I browse the partition it is installed on.  However if I type the path in manually in windows explorer, I can get to the folder.  I selected view hidden files and folders and that did not solve the issue.  I even found when robocopying this directory to another windows server, it became hidden as well.
Chris RiceAsked:
Who is Participating?
 
Phillip BurtonConnect With a Mentor Director, Practice Manager and Computing ConsultantCommented:
You can using the attrib command - see this webpage for examples on how to do that.

Please note that you are trying to remove System and Hidden, so instead of using

Attrib MyFolder +s +h

you should use

Attrib MyFolder -s -h
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
It may be a SYSTEM folder. I've come across this before - see http://www.filecats.co.uk/what-is-filecats/a-diagnostic-tool/ for more information.
0
 
Chris RiceAuthor Commented:
It shouldn't be a system folder.  Its a share that people access every day without any issues, but when I log into the server, I can see the folder.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
I would suggest cataloging it, either using MS-DOS or some other file cataloger, and have a look at its attributes.
0
 
Chris RiceAuthor Commented:
Do you know the DOS commands? I',m not find anything obvious when googling.
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Have a look at

Dir *.*

for example, to see system files/folders

dir *.* /AS

You might find the folder cataloger easier.
0
 
Chris RiceAuthor Commented:
Where can I find the folder cataloger?
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Try either Filecats Standard (if you have and like Microsft Excel), or Filecats Explore (if you don't). The download page is here: http://www.filecats.co.uk/download-free-trial/

Both of them will capture the attributes, as you can see in the video on this page: http://www.filecats.co.uk/what-is-filecats/a-diagnostic-tool/
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Thinking about it, maybe the share is hidden.

If the last character is a $ sign, then it will be hidden, so you can only access it if you know the path.

See http://technet.microsoft.com/en-us/magazine/dd767761.aspx for more details.

If that's the case, and you don't want it hidden, then share it without the $ sign at the end.
0
 
Chris RiceAuthor Commented:
Not a hidden share.  I can browse to it by going to the share \\server\clients or browse to it directly from the server by going to D:\Clients
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
And does cataloging it show anything?

I've just cataloged a folder now for a search I am doing, and I can see a hidden file and a hidden and system file...
0
 
Chris RiceAuthor Commented:
I did that dir command and it didn't show it as a system folder.  I'm running that filecatexplore right now and it gave me a spreadsheet of items, but not sure what it all means.
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Have a look at the attributes. It gives you the same as in MS-DOS

D = Directory
R = Read-only
H = Hidden
A = Files ready for archiving
S = System files
0
 
Chris RiceAuthor Commented:
For the folder in question, the attributes are RHSD
0
 
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Read-only; Hidden; System and Directory.

The thing that struck me about your question was "I selected view hidden files and folders and that did not solve the issue."

That's because Hidden and System are different. It struck a chord with me, because I came across and had to solve this problem before.

In Windows Explorer:

If you have Windows 8, you have to go to Options...
If you have Windows Vista, you have to go to Tools - Options...
If you have Windows 7 - you have to see the Tools menu first. Open Windows Explore, and press the Alt key once. Then Tools - Options.

(Take a breath.)

Then, in View tab, deselect (i.e. clear the checkbox for) "Hide protected operating system files (Recommended).

You will get a warning - just ignore it.

Hopefully then you can see the folder in Windows Explorer. If not, I'm out of ideas!

However, please notice that, even though you can't see the folder in Windows Explorer, as Filecats Explore can see it, with enough tweaks, you should eventually be able to see it in Windows Explorer.
0
 
Chris RiceAuthor Commented:
Can I change the attributes of the folder so its not a system folder?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.