Solved

Outlook (2010 - Exchange) Deleting email rather than archiving as per settings

Posted on 2015-01-19
5
196 Views
Last Modified: 2015-01-20
Hello Experts,
 


I'm having difficulty troubleshooting an issue and I really could use some assistance if anyone can.
 


The issue is like the title says, auto-archive is deleting some emails (about 4GB so far) instead of archiving them.
 


What things have I checked?
 


-any settings on Exchange / GPO - nothing there and no other users (from 40ish) reporting similar issue.
 
-size of archive file (it's 8GB currently)
 
-scanpst.exe - no errors found
 
-new mail profile - created a new one and that hasn't changed anything.
 
-auto archive settings are being applied to all folders and there aren't any subfolder settings that would conflict with this as far as I can see.
 


At first the issue was that the auto archive didn't appear to be doing its job, then we found the threads about it running on the last modified date rather than the sent / received date. I added the reg entry about ignoring last modified time and that appeared to do the job, however the next working day the user discovered that the emails were not archived but had been deleted. So I have recovered them and am now looking for a reason as to why these were deleted and not archived.
 


Any help or other things I can try would be greatly appreciated.

EDIT: further reading up on this prompted me to launch Outlook in safe mode and check the auto archive settings there. When I did, the settings did not match the normal mode settings. It looks as though they have never been set. Is this expected behaviour?
0
Comment
Question by:redredandrew
  • 3
  • 2
5 Comments
 
LVL 18

Accepted Solution

by:
SimonAdept earned 500 total points
ID: 40559191
Wild guess: You mention the difference between sent/received date and the last modified date. How old are the emails? Is there any records management/Information Governance policy (possibly exchange-wide) that may cause the emails to be deleted immediately after archiving them?

I've had a few archive settings problems and had to 'apply to all folders' a few times to get all mail going to the correct archive.
8GB archive is rather large, even if allowable. Is it on C: drive or a network share?

Was the PST originally created in Outlook 2010 or an earlier version of Outlook? May be worth re-creating the archive and moving old items into it (yes, that will take a while)

Do you still get the problem if you write to a new archive PST?

I'll check whether I get the same diference in archive settings when in safe mode when I get to the office.
0
 

Author Comment

by:redredandrew
ID: 40559292
Hello Simon,

Many thanks for your reply. I'll try and provide some answers to your questions.

The emails date back to Jan 2010. Although the majority of them are from 2013.

I've checked on any exchange-wide settings for deleting email but there aren't any set.

The archives are on a datashare / redirected folder on our network so they are not being stored locally.

The PST was created using this version of Outlook (2010), I created it at the end of November last year.

I would very much appreciate a check on the safe mode archive settings - just for some piece of mind really.

In the meantime I am going to try something as per your suggestions, but one at a time so I can try and work out which one is the culprit.

-create a new PST and try the archive routine

if that doesn't work:

-new PST on a local drive and see if that works.

I'll report back...
0
 
LVL 18

Expert Comment

by:SimonAdept
ID: 40559312
I have just checked and can confirm that I get nearly the same auto-archive settings in safe mode as in normal mode. The key difference is that the 'Run Autoarchive every * days' is disabled in safe mode and the 'delete expired items' has been re-enabled.

When I reviewed my auto-archive settings earlier this morning I found that they were not what I thought I had last set them to (i.e. I have separate archives for each year but they were still set to write to an older archive file), and I had to remind myself that auto-archive settings can be set at folder level (right-click folder and choose properties) and account level (via backstage /options/advanced/auto-archive). I run Outlook on a number of devices and think that auto-archive settings have synced incorrectlly.

I also checked my enabled/disabled add-ins because we have had issues with our anti-virus add-ins and these are currently disabled for me (Outlook prompted me about disabling them when it automatically opened in safe mode after failed attempts to start up).
0
 

Author Comment

by:redredandrew
ID: 40559449
Simon, thank you for checking our safe mode settings. I can't say I understand why they would be different, but this user's settings were completely different.

In any case, I launched Outlook normally again and ran the Auto Archive after clicking the apply settings to all folders button a couple of times for good measure.

This time the archive worked. Not with a new PST, not on a local drive. Just exactly as it was before when it didn't work.

Very strange. Just one of those things I guess. It would have been nice if there was a specific answer to this, but I am just glad that it has finally worked!

Thank you ver much for your help! I'll mark your first reply as the answer I think :)
0
 

Author Closing Comment

by:redredandrew
ID: 40559452
We didn't discover a specific cause for the problem, but Simon's assistance was greatly appreciated so I have marked his responce as the answer as he deserves the well earned points! :)
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
Set OWA language and time zone in Exchange for individuals, all users or per database.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now