Solved

iis express cannot access the IIS express applicationHost.config file

Posted on 2015-01-19
4
302 Views
Last Modified: 2015-01-27
Not able to create new web projects in Visual Studio 2013.  When I try open a web site I notice a yellow error icon below IIS Express Sites and the message "Cannot access the the IIS Express applicationHose.config.file.  I have tried everything listed on StackOverflow regarding permissions...
0
Comment
Question by:hertzgordman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 12

Expert Comment

by:FarWest
ID: 40557990
if you did not use administrator try working on using a user with administrator rights
if yes, try run VS with administrative privilege
I think this will solve the problem
0
 

Accepted Solution

by:
hertzgordman earned 0 total points
ID: 40558091
Thanks Fryezz I have tried that...

I am not able to at least create the MVC solution and open it after doing this:

 (from stackoverflow.com/questions/24582929/unable-to-create-a-new-web-project-in-visual-studio-2013)


Alright - I am able to find the workaround.

If you find this error coming then probably it is to do with the IISExpress or IIS configuration that you may not be able to control from home.

The workaround that I have found is that:

Create Project,
System will not be able to attach the project, however it has been created. Then browse to that directory where the project has been created, and open the project file in the notepad or any editor.
Make sure that <UseIISExpress>false</UseIISExpress>
Before modifying further in the project file, Create a virtual directory in your IIS and point to the project path.
find <WebProjectProperties> in your project file config.
Define the virtual directory path under IISUrl.
Your config file should look something like this:

<WebProjectProperties>
          <UseIIS>True</UseIIS>
          <AutoAssignPort>True</AutoAssignPort>
          <DevelopmentServerPort>0</DevelopmentServerPort>
          <DevelopmentServerVPath>/</DevelopmentServerVPath>
          <IISUrl>http://localhost/app.account/</IISUrl>
          <NTLMAuthentication>False</NTLMAuthentication>
          <UseCustomServer>False</UseCustomServer>
          <CustomServerUrl>
          </CustomServerUrl>
          <SaveServerSettingsInUserFile>False</SaveServerSettingsInUserFile>
        </WebProjectProperties>
0
 
LVL 12

Expert Comment

by:FarWest
ID: 40558140
good job, and thanks for sharing
0
 

Author Closing Comment

by:hertzgordman
ID: 40572388
Solved the issue myself
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Calculating holidays and working days is a function that is often needed yet it is not one found within the Framework. This article presents one approach to building a working-day calculator for use in .NET.
It’s a strangely common occurrence that when you send someone their login details for a system, they can’t get in. This article will help you understand why it happens, and what you can do about it.
Wufoo.com provides powerful tools for surveying targeted groups, and utilizing data from completed surveys to find trends, discover areas of demand or customer expectation, and make business decisions on products or services.
Learn how to set-up PayPal payment integration in your Wufoo form. Allow your users to remit payment through PayPal upon completion of your online form. This is helpful for collecting membership payments, customer payments, donations, and more.

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question