Solved

Redhat module install failure

Posted on 2015-01-20
4
384 Views
Last Modified: 2015-01-28
I get the following trying to install a module on a newly installed server. Redhat has escolated to second level support but are slow to respond. Can anyone offer suggestions?

================================================================================
 Package          Arch       Version             Repository                Size
================================================================================
Installing:
 unixODBC         x86_64     2.2.14-14.el6       rhel-x86_64-server-6     378 k
Installing for dependencies:
 libtool-ltdl     x86_64     2.2.6-15.5.el6      rhel-x86_64-server-6      44 k

Transaction Summary
================================================================================
Install       2 Package(s)

Total size: 422 k
Installed size: 0
Is this ok [y/N]: y
Downloading Packages:
error: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID fd431d51: BAD


Problem opening package unixODBC-2.2.14-14.el6.x86_64.rpm
0
Comment
Question by:cotton0226
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 21

Expert Comment

by:Mazdajai
ID: 40561187
What version of RHEL are you running? Try adding --nogpgcheck.
0
 
LVL 1

Expert Comment

by:Mahesh Y
ID: 40561238
Seems the downloaded rpm's are corrupted. Please verify with md5sum.
0
 

Accepted Solution

by:
cotton0226 earned 0 total points
ID: 40566619
Redhat has resolved my issue. See the follow text.

From our last remote session we we're able to identify that the issue was caused by mismatched nss-softokn/nss-softokn-freebl package versions. In this case, updating to nss-softokn-3.14.3-19.el6_6 did not update the corresponding nss-softokn-freebl-3.14.3-19.el6_6 (which there is a dependency with). A private bugzilla has already been filed for this issue (BZ#1182662), and a fix identified. The fix involves updated dependency definitions for the nss-softokn/nss-softokn-freebl packages (RPM spec).

In order to workaround the issue we had to manually extract libfreeblpriv3.so from the nss-softokn-freebl-3.14.3-19.el6_6.x86_64 RPM to /lib64, at which point we followed the RPM database rebuild steps outlined here:

"How to rebuild RPM database on a Red Hat Enterprise Linux system?"
https://access.redhat.com/solutions/6903

We verified successful recovery by running a `yum update`.
0
 

Author Closing Comment

by:cotton0226
ID: 40574829
Solution provided by RedHat support resources
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Users of Windows 10 Professional can disable automatic reboots using the policy editor. This tool is not included in the Windows home edition. But don't worry! Follow the instructions below to install (a Win7) policy editor on your Windows 10 Home e…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question