Solved

Why is free\busy information unreliable after hybrid migration to Office 365

Posted on 2015-01-20
11
1,035 Views
Last Modified: 2015-01-26
Office 365 Enterprise E4
Outlook 2010 (downloaded\installed via 365 site)
Migrated from Exchange 2003 on premise to 365 via Hybrid deployment (EX2010)
New users added in on premise AD, then synced using on premise directory sync server
Client Outlook 2010 configured by running through setup onetime (auto discovery), enter username\password, click always remember, done.
Problem is free\busy area.  User A invites user B & C to meeting.  Can see B free\busy, but for user C, user A gets slash marks with message “No Information, No Free/busy information could be retrieved & you do not have permissions to see the recipient’s free busy.”
In Outlook, if user C opens his calendar permission properties, removes the name “other”, then closes.  User A can then see free\busy.  I’ve tested this procedure with several other same situations.  It takes care of the issue, but always reverts back.
I’ve tested in OWA, and get the same results.
Any troubleshooting tips would be appreciated.
Sincerely,
Bob
0
Comment
Question by:bobgraf
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 41

Expert Comment

by:Vasil Michev (MVP)
ID: 40560700
What you are describing seems like permission issue. Where are the mailboxes located, all in O365? Just in case, lets start with the hybrid free/busy troubleshooter: http://support.microsoft.com/common/survey.aspx?scid=sw%3ben%3b3526&showpage=1
0
 

Author Comment

by:bobgraf
ID: 40560864
Hello,
All mailboxes are located in O365.  We migrated about a year ago, and decommissioned the old on Premise Exchange server.  However, all migrated users still have an on premise AD user account, and new users are created on premise.  Synced to the cloud via dirsync, then assigned a 365 license via the 365AC.  I think you're onto something with the permission issue.  But I don't know how to change that, and it seems sporadic.  I did run the auto discover utilities, and I believe it looks ok.  see attached.
Thank you,
Bob
Results.jpg
0
 
LVL 41

Expert Comment

by:Vasil Michev (MVP)
ID: 40561801
So, what is the output of the following cmdlet against user C?

Get-MailboxFolderPermission userC@domain.com:\Calendar

Open in new window

0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:bobgraf
ID: 40561976
Hi, here it is:

PS C:\Users\administrator\Desktop> Get-MailboxFolderPermission jnoblitt@isiameri
ca.com:\Calendar

FolderName           User                 AccessRights
----------           ----                 ------------
Calendar             Default              {None}
Calendar             Anonymous            {None}
Calendar             Chris Wineinger      {Reviewer}
Calendar             Dylan Zielinski      {Reviewer}
Calendar             Bob Graf             {Editor}
Calendar             Gavin Barfknecht     {Editor}
Calendar             Shannon Schill       {Reviewer}
Calendar             NT:S-1-5-21-20729... {Reviewer}


PS C:\Users\administrator\Desktop>
0
 
LVL 41

Expert Comment

by:Vasil Michev (MVP)
ID: 40562041
Change the Default one to AvailabilityOnly:

Set-MailboxFolderPermission user@domain.com:\Calendar -User Default -AccessRights AvailabilityOnly

Open in new window

0
 

Author Comment

by:bobgraf
ID: 40562592
Ok, made that change.  Original message User A got for user C, was “No Information, No Free/busy information could be retrieved & you do not have permissions to see the recipient’s free busy.”

After the change, the message is “No Information, No Free/busy information could be retrieved & your server location could not be determined.  Contact your  administrator"


Any other details I can provide, please let me know.
0
 

Author Comment

by:bobgraf
ID: 40562616
Sorry, maybe I spoke to soon.  Now it appears user A can access user C free busy.  I assume maybe it took some time to replicate?  I'll keep an eye on it.  If this is the fix, is there a way to do it to the entire GAL?   Or does it have to be run individually?
0
 
LVL 41

Accepted Solution

by:
Vasil Michev (MVP) earned 500 total points
ID: 40562729
AvailabilityOnly is the default option, not sure why it's set to None in your case. You can bulk change them with something like this:

$calendars = Get-Mailbox -RecipientTypeDetails UserMailbox | Get-MailboxFolderStatistics | ? {$_.FolderType -eq "Calendar"} | select @{n="Identity"; e={$_.Identity.Replace("\",":\")}}

$calendars | % {Set-MailboxFolderPermission -Identity $_.Identity -User Default -AccessRights AvailabilityOnly}

Open in new window

0
 

Author Comment

by:bobgraf
ID: 40562953
Ok, I'm certain I'm not doing something correct when I run the command.  Below is the error I get.  I am a very new to Power Shell commands.

PS C:\Users\administrator\Desktop> $calendars = Get-Mailbox -RecipientTypeDetail
s UserMailbox | Get-MailboxFolderStatistics | ? {$_.FolderType -eq "Calendar"} |
 select @{n="Identity"; e={$_.Identity.Replace("\",":\")}} $calendars | % {Set-M
ailboxFolderPermission -Identity $_.Identity -User Default -AccessRights Availab
ilityOnly}
Select-Object : A positional parameter cannot be found that accepts argument '$
null'.
At line:1 char:133
+ $calendars = Get-Mailbox -RecipientTypeDetails UserMailbox | Get-MailboxFolde
rStatistics | ? {$_.FolderType -eq "Calendar"} | select <<<<  @{n="Identity"; e
={$_.Identity.Replace("\",":\")}} $calendars | % {Set-MailboxFolderPermission -
Identity $_.Identity -User Default -AccessRights AvailabilityOnly}
    + CategoryInfo          : InvalidArgument: (:) [Select-Object], ParameterB
   indingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell
   .Commands.SelectObjectCommand
0
 
LVL 41

Expert Comment

by:Vasil Michev (MVP)
ID: 40563058
Those are two different lines of code, paste them separately.
0
 

Author Closing Comment

by:bobgraf
ID: 40571214
It appears that my problem is solved.  The first command line took quite a few hours, but  after contacting various users, they were no longer getting the security rights error when trying to access others free\busy schedule.  Hopefully with this solution, the problem will not come back.
Thank you very much for all the help.
Bob Graf
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A project that enables an administrator to perform actions within a user session context not just at the time of login but any time later on day(s) or week(s) later.
Access developers frequently have requirements to interact with Excel (import from or output to) in their applications.  You might be able to accomplish this with the TransferSpreadsheet and OutputTo methods, but in this series of articles I will di…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question