Solved

Can't see ADMX files on Server 2008R2

Posted on 2015-01-21
13
1,627 Views
Last Modified: 2015-01-22
We have a Windows Server 2003 domain controller so in order to manage our users that have outlook 2013 on their computers through group policy, I installed RSAT tools on a Windows Server 2008R2 machine and downloaded the ADMX files but when I go to Add a template from the 2008R2 machine and browse to the folder where my ADMX files were extracted, it doesn't see any valid template files to add. Please help!

Thanks!
0
Comment
Question by:tpezzullo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 3
13 Comments
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40563114
The ADMX files don't work exactly the same way as the older ADM files that you're used to with Windows 2003.  In order to work with the ADMX files, you have to create a PolicyDefinitions folder (folder name must be all one word) on the server in the \\Windows\SYSVOL\Domain\Policies folder and then copy the ADMX files into that folder. Then, within the PolicyDefinitions folder, you also must make sure that the language folder (named "EN") is also there.
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40563119
PS - I don't remember whether the PolicyDefinitions folder is already there in Windows 2008 upon installation - it might already be there but nevertheless you have to copy the ADMX files and EN folder into that folder.
0
 

Author Comment

by:tpezzullo
ID: 40563126
On which server should I create this PolicyDefinitions folder? On the server 2008 where I'm trying to administer from or on the 2003 DC? Thanks
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:tpezzullo
ID: 40563129
Ah ok, the 2008 server. I will try that.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40563169
You just need to copy the .ADMX files to C:\Windows\PolicyDefinitions on your 2008 R2 server and that's it.

If your 2008 R2 server is not a Domain Controller it won't be able to see the ADMX files if you place them in the SYSVOL directory as this directory only get replicated across Domain Controllers.
0
 

Author Comment

by:tpezzullo
ID: 40563180
Ah, good to know since that's what I had done before and it didn't work. Thank you will try your suggestion!
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40563186
Don't forget to copy the Office 2013 .ADML files to the C:\Windows\PolicyDefinitions\en-US folder as well (sorry, left that out in my previous post).

Once you've copied across the necessary files, restart the Group Policy Management Console and you should see the new Office 2013 policies appear when you go to edit a GPO.
0
 

Author Comment

by:tpezzullo
ID: 40564309
I tried these suggestions and they didn't work. I put the admx files in the C:\Windows\PolicyDefinitions folder and the adml files in the C:\Windows\PolicyDefinitions\en-us folder on my 2008 server (which is not the domain controller) and when I got into group policy editor and tried to add the template it does not see any admx files in the PolicyDefinitions directory. Any other ideas as to what could be the issue?
0
 
LVL 24

Assisted Solution

by:VB ITS
VB ITS earned 100 total points
ID: 40564327
You shouldn't need to add the templates manually, they should appear by themselves under Computer\User Configuration > Policies > Administrative Templates
0
 

Author Comment

by:tpezzullo
ID: 40564331
Yea, that is where I checked and since they were not in there I tried to add manually...to no avail.
0
 
LVL 38

Accepted Solution

by:
Hypercat (Deb) earned 400 total points
ID: 40564352
The issue is probably where your group policy console is pointing. If you want to manage domain-wide group policies, you have to store those group policies on a domain controller. If you're using the GPMC to manage policies, then this will be looking at domain-wide policies stored on the domain controller, not local policies.

There is a way to add these policies to a Windows 2003 domain controller, at least it worked for Vista and Windows 7 group policies. I'm not entirely sure it will work for the Outlook 2013 policies, but you could try it.  

Essentially what you need to do is copy the PolicyDefinitions folder to the domain controller, and put it in the c:\Windows\SYSVOL\Domain\Policies folder. Give that a try and see if you can then connect to it and manage it from the Windows 2008 server.  You definitely will NOT be able to manage the policies from the Windows 2003 server, because the management console versions are different.

Here's a Technet article for reference:

https://technet.microsoft.com/en-us/library/cc754948(WS.10).aspx

There's a lot of info in there, but if you scroll down to the section on Group Policy and Sysvol, you'll see an explanation there of how it works.
0
 

Author Comment

by:tpezzullo
ID: 40564745
I have already tried what you suggest in terms of putting it on the 2003 servers in the policies folder and still I cannot see the admx files from the 2008 server. I will read the article and see if I can dig anything else up. Thanks.
0
 

Author Comment

by:tpezzullo
ID: 40564815
Ok it seems that when I move the admx file to C:\\windows\sysvol\PolicyDefinitions on the domain controller I can now see the templates in the 2008 server from GPMC! Thank you for the article. That's what did it!
0

Featured Post

10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question