Solved

Forms Library Permissions

Posted on 2015-01-21
9
67 Views
Last Modified: 2015-01-31
SharePoint 2010
InfoPath 2010

I have created an InfoPath Form and published it to a SharePoint Forms Library.  I've set up two "Submit" Data Connections (one to Submit to the Forms Library and the other to Submit via e-Mail) and added a rule to make this happen.  Everything is working with all of that.

Now here's the problem (and I've read much about this online but am hoping for a "not-so-complicated" solution):  

I want the users to be able to submit their forms, but I only want them to be able to view their own forms but not what everyone else submits, since the information can be confidential.  There will be a set of Admins who can view all submitted forms, but user's should only be able to view their own.

(Note: I am not very experienced with SharePoint Designer, but with specific instructions I should be able to get through anything.  I have also read posts about changing to View to only allow certain users to see others' posts.  Just not sure what the best way to do this is.)
0
Comment
Question by:CityofDelrayBeach
  • 6
  • 2
9 Comments
 
LVL 29

Accepted Solution

by:
QPR earned 250 total points
Comment Utility
A simple way is to change the default view and set the filter to be created by = [Me]
Delete any other views and disable opening with explorer.
Not perfect but it avoids coding or webparts
0
 

Author Comment

by:CityofDelrayBeach
Comment Utility
Hi QPR. Thanks for your response.  I changed the default view and set the filter to be "Created by" [Me].  I tested it and the user can't see his/her own submissions.

I'm also not sure why I have to delete other views and disable opening with explorer. If I do that won't it prevent my user's from accessing the web-based form?
0
 
LVL 5

Expert Comment

by:tapiwab
Comment Utility
hi there

you can solve by going to the form library then  Library Settings,

Under General Settings  click on  Versioning settings , and configure as per attach screen shot.
 you need to ensure that all users have contribute permissions and administrators have approve rights or higher

formlibrary.JPG
0
 

Author Comment

by:CityofDelrayBeach
Comment Utility
OK, things are not working as they should be once I made QPR and Tapiwab's changes.

Here's what I did:

1.  Created unique permissions to the Library as follows: Library Admins have Approve, Authenticated Users have Contribute, SharePoint Admins have Full Control.

2. Per QPR's suggestion, I changed the Library's default view to Filter as "Created by" [Me].  When I do this the user's can't see anyone's submits including their own.  I need them to be able to see their own.

3.  Per Tapiwab, I changed the Versioning settings. Once I did this the users can no longer submit a form. They get "Access Denied".
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:CityofDelrayBeach
Comment Utility
I think QPR's suggestion would work, but for some reason the "Created By" field is always populated with my name, even if I log on to the computer as another user and submit the form. Whey is this?  Is it because I created the form?  Makes no sense.
0
 
LVL 5

Expert Comment

by:tapiwab
Comment Utility
did you configure the view to filter by "Created by"  like this below,

view.JPG
if you going to do this option you must ensure that users will not have access to administrators view, if security is a major concern
0
 

Author Comment

by:CityofDelrayBeach
Comment Utility
OK, I made some changes and now TAPIWAB's suggestion is working, but how to I make it so that Administrators can see all items?

Thanks, TAPIWAB.
0
 

Assisted Solution

by:CityofDelrayBeach
CityofDelrayBeach earned 0 total points
Comment Utility
I created a workaround, since QPR's suggest provided only half of the solution.

I created a new page on the site and gave only admins access.  I added a webpart to the new page that links to the original Forms Library.  Here's a link to the solution: http://sharepointquester.com/2013/01/28/setting-permissions-on-a-sharepoint-list-view/

If you think there's a better way, I'm open to suggestions, but for now this works.  Thanks so much for your help!
0
 

Author Closing Comment

by:CityofDelrayBeach
Comment Utility
QPR's solution provides half of the solution. My final comment provides the other half.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

If you create your solutions on SharePoint sooner or later you will come upon a request to set  permissions of the item depending on some of the item's meta-data - the author, people assigned as approvers, divisions, categories etc. The most natu…
Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now