Solved

Asterisk --> CUCM = OK      CUCM --> Asterisk = Fast Busy

Posted on 2015-01-21
7
102 Views
Last Modified: 2016-01-12
Experts, I have a working inbound SIP trunk from Asterisk (AsteriskNow to be exact) to CUCM.

Anything originating on the Asterisk side of the house has absolutely no issues dialing and reaching any extension or even other SIP trunk (Exchange UM, etc.) connected to CUCM.

Unfortunately, the same can't be said for the return path.  Calls originating from extensions attached to the CUCM side, get a fast-busy when trying to go out of the trunk towards Asterisk.  I'm willing to wager the configuration of CUCM is to blame, but I've checked everything and can't seem to find anything wrong.  I believe the issue's probably CSS, but everything checks fine as far as I can tell.

Could I get your guys' take on this to see what I could be doing wrong?  Thanks.

//======================================================================
CUCM Config

Device Name:  AsteriskTrunk
Device Pool:  <Associated DP>
Call Classification:  OffNet <-- have swapped back and forth between OnNet as well
Media Termination Point Required:  Checked
Retry Video Call as Audio:  Checked
Remote-Party-Id:  Checked
Asserted-Identity:  Checked

Calling Search Space:  CSS_Internal
     I also have an Exchange UM trunk configured in the same CSS.
     Phones and extensions within CUCM all sit within "CSS_FullAccess" which has all of the partitions available to them.

Redirecting Diversion Header Delivery - Inbound:  Checked
Redirecting Diversion Header Delivery - Outbound:  Checked

Destination Address:  <IP Address>
Destination Port:  5060

MTP Preferred Originating Codec:  711ulaw
SIP Trunk Security Profile:  STSP_UDP_Accept_OutOfDialog_UnsolicitedNotification_ReplacesH_Xmt
     Outgoing Transport Type:  UDP
     Accept out-of-dialog refer**:  Checked
     Accept unsolicited notification:  Checked
     Accept replaces header:  Checked
     Transmit security status:  Checked
SIP Profile:  Standard SIP Profile  <-- Default built-in SIP Profile


//======================================================================
AsteriskNow Config

Trunk Name:  CUCM
Outbound CallerID:  Blank  <-- This allows for inbound calls from the world to show their caller-id
CID Options:  Allow Any CID

Dial Number Manipulation Rules
match pattern = XXXX  <-- All extensions and trunks on the CUCM side are 4 digits

Outgoing Settings

Trunk Name:  CUCM

Peer Details:
     type=friend  <-- Have used "peer" as well here
     qualify=yes
     nat=no
     insecure=very
     host=<IP Address of CUCM>
     fromdomain=<IP Address of CUCM>
     dtmf=rfc2833
     disallow=all
     context=from-internal
     canreinvite=no
     allow=ulaw

Incoming Settings

User Context:  <IP Address of CUCM>

User Details:
     type=friend  <-- Have used "peer" as well here
     qualify=yes
     nat=no
     insecure=very
     host=<IP Address of CUCM>
     fromdomain=<IP Address of CUCM>
     dtmf=rfc2833
     disallow=all
     context=from-internal
     canreinvite=no
     allow=ulaw
0
Comment
Question by:usslindstrom
7 Comments
 
LVL 20

Assisted Solution

by:José Méndez
José Méndez earned 250 total points
ID: 40563632
Show me a sip debug please, calling and called number.
0
 
LVL 15

Assisted Solution

by:sr75
sr75 earned 125 total points
ID: 40575450
Did you run a Dialed Number Analyzer (DNA) to see if the call is even being routed to the Asterisk trunk?
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 40578556
Willy - you're assisting me with EE Question # 28590399 as well.  Apologies for the delay here.

- Been spending what time available to this, on researching how to perform the troubleshooting steps you guys are asking me on the CUCM side.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 20

Assisted Solution

by:José Méndez
José Méndez earned 250 total points
ID: 40578743
Log into asterisk's console and run

sip set debug on
core set verbose 9
core set debug 9

Replicate the issue
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 40608495
Had to research into this quite a bit.

I wasn't able to hit the console of the device and perform those steps.  As I would SSH or even log into the VM locally, I was getting returns that the "sip" command wasn't present.  Nor any of the "core" commands.

Jumping through forum after forum, your instructions were right on the money, but I didn't have those commands present still.  As it turns out, 100% due to my understanding (or lack thereof) - was that this was moved to the administrative gui in the version I'm running.  *Might be that way in all instances, but I was expecting that it was on the OS level, as I went with the AsteriskNow distribution, instead of just installing Asterisk over the top of another OS.  If that makes sense.

So, long story short - it's entirely my fault for taking as long as I have to reply...  but it's all in the nature of learning new technologies, right?  :)


For this particular question, after I finally was able to get in and see stuff - it doesn't appear that my CUCM originating calls are ever even making it to the asterisk box at all.  I could have swore that I have the Calling Search Spaces configured correctly, but I'm obviously missing something on the Cisco side.
0
 
LVL 6

Accepted Solution

by:
mark_06 earned 125 total points
ID: 41403999
Try allowing calls from annonymous sources in asterisk. I have found that helps.
Do you have multiple CUCMs? Pubs and Subs? You will need to confirm them all in asterisk as trunks.
0
 
LVL 5

Author Closing Comment

by:usslindstrom
ID: 41408923
All,

Sorry for my lack of ExpExch cleanliness.  Thanks for chiming in here on all the assistance.

I ultimately tore down both systems and rebuilt them from scratch.  Everything now works as intended.

The one change that I did on this rebuild, was NOT separating the CUCM side with any Calling Search Spaces.  I believe this was the underlying issue.  Even though I had placed them in the same CSS, there most likely was something preventing calls going one way.

My issue has been working now for a while.  For anybody having the same issue, please double and triple check all your CSS separation on CUCM.

Thanks.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

There are no good configuration guides for HP-H3C router to LYNC on the web. :( Big statement, but we havent been able to find one yet. We did find the following document useful, but the information was not enough to use H3C router for use as a L…
This is a step by step guide on creating single number reach (mobility) for Cisco Call Manager.  After configuring this when someone calls your deskphone after 3-4 rings your cell phone will start to ring.  If you do not answer the call will go to y…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now