Windows 7 with static IP gets 169.254 address

In my organization, we run Windows 7, and assign static IP's to each workstation. Many, if not most workstations have started acquiring link local addresses (169.254.x.x) upon a warm restart. Temporarily solving the problem can be achieved by:

1. Completely powering the machine down, and powering back on.
2. Disabling and enabling the NIC in the Control Panel.
3. Unplugging and replugging the network cable.

I have attempted upgrading NIC drivers without success. I even disabled the DHCP Client service without success. The only thing that permanently resolves the issue is running the following one-line batch file:

for /F %%a in ('reg query HKLM\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces') DO reg add %%a /v DhcpConnEnableBcastFlagToggle /t REG_DWORD /d 1 /f

Open in new window

My question is this: What am I doing wrong upon deploying computers that this cloogy fix is necessary? I use Windows Deployment Services to image new computers.
R. Toby RichardsNetwork AdministratorAsked:
Who is Participating?
nader alkahtaniConnect With a Mentor Network EngineerCommented:
Are The images  have settings of dynamically IPs from DCHP ?
nader alkahtaniNetwork EngineerCommented:
R. Toby RichardsNetwork AdministratorAuthor Commented:
I will try that, and see if it works by running it on my master image. My solution doesn't work on the master image as the newly imaged PC's NICs get new GUIDs.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.